Search found 16 matches

Return

by Benj
Thu Dec 08, 2011 12:17 pm
Jump to forum
Jump to topic

Re: Settting Clearing single bits on the output

Hello,

I've had a look at the FCD file and there is no problem there. Have you tried another 16F610 to ensure the one you are testing with is not damaged. If you are still having problems then I will see if we have a 16F610 here and give it a quick test.
by dbasnett
Wed Dec 07, 2011 5:24 pm
Jump to forum
Jump to topic

Re: Settting Clearing single bits on the output

I wasn't able to set the project to any of the chips you mentioned, so I used a different one. Since you are using them I thought you'd be able to just change the chip in the project and then try it.
by dbasnett
Tue Dec 06, 2011 4:10 pm
Jump to forum
Jump to topic

Re: Settting Clearing single bits on the output

You will need to change the Chip Settings to match your chip.
by Benj
Mon Dec 05, 2011 4:03 pm
Jump to forum
Jump to topic

Re: Settting Clearing single bits on the output

Hello, I have had a look at your program and the code is being generated correctly so I'm not too sure why the pins are not functioning correctly. It might be worth using a multimeter and checking the LED is correctly connected to the microcontroller pin this just rules out any breaks on the circuit...
by Benj
Mon Dec 05, 2011 1:27 pm
Jump to forum
Jump to topic

Re: Settting Clearing single bits on the output

Hello Jörg,

No misunderstanding, just do not say no one is helping you when someone blatantly is.
by medelec35
Mon Dec 05, 2011 11:32 am
Jump to forum
Jump to topic

Re: Settting Clearing single bits on the output

The bits do work independently. It looks correct on the simulator but not on hardware because of the simulator is running much slower. You have set the flowchart so when led_counter reaches 19 then RC0 is toggled. When led_counter led_counter reaches 20 then RC2 is toggled. Since they are toggle wit...
by medelec35
Sun Dec 04, 2011 8:22 pm
Jump to forum
Jump to topic

Re: Settting Clearing single bits on the output

Hi Jörg,
You had the LED set on port C0, and the C0 output was being toggled. I have set the o/p C2 for toggling.

Not sure what you want the other out puts to do yet?

Martin
by medelec35
Sat Dec 03, 2011 12:16 pm
Jump to forum
Jump to topic

Re: Settting Clearing single bits on the output

Hi Jörg , Sounds like you are selecting the whole port rather than the individual Bit. If you want to set Bit A2 high without affecting the any other bits then simplest way is to select individual bit as in the pic below: Individ bits.png If you have already set the individual bit and still does not...
by Spanish_dude
Fri Dec 09, 2011 6:29 pm
Jump to forum
Jump to topic

Re: Settting Clearing single bits on the output

Hi, I had a quick look at your code. (Downloaded the zip and checked the .c file in the 'not working' folder). The generated code is correct... void main() { //Interrupt-Initialisierungs-Kode option_reg = 0xC0; //Output: 0 -> PORTC trisc = 0x00; portc = 0; delay_s(1); //Output: 1 -> C0 trisc = trisc...
by Benj
Mon Jan 23, 2012 6:00 pm
Jump to forum
Jump to topic

Re: INT flag to variable / output flag / clear flag / need h

Hello,

Create a byte variable in flowcode called flag.

1) Using a C code icon.

Code: Select all

FCV_FLAG = test_bit(intcon, INTF);


2) Using a output icon in single pin mode - use the flag variable as the input data.

3) Using a C code icon.

Code: Select all

clear_bit(intcon, INTF);
by Benj
Wed Jan 29, 2014 12:04 pm
Jump to forum
Jump to topic

Re: source boost 7.2 update to release 7.21

Hello,

We will be including this compiler update in the next update release of Flowcode which should be available shortly.
by LeighM
Thu Mar 10, 2016 10:04 am
Jump to forum
Jump to topic

Re: strings/char converting --> uart problem

A string is an array of bytes, So for example you can place an A as the first character in the string with any of these insertA.jpg Similarly, if you want to look for a carriage return in a string you can compare with 13 testCR.jpg It looks like your string length for str3 is not large enough tostri...
by LeighM
Thu Mar 24, 2016 9:52 am
Jump to forum
Jump to topic

Re: Flowcode V6.1.2 PIC24FV32KA304 I2C not working

Hi Jörg

You need to add a call to the I2C Start macro before the TransmitByte, and then a Stop afterwards.

Have a look at the datasheet for your FRAM, you will most likely need something like:

Start, TransmitByte, ... Restart, ..., ReceiveByte, Stop

Leigh
by LeighM
Wed Mar 16, 2016 12:39 pm
Jump to forum
Jump to topic

Re: Flowcode V6.1.2 PIC24FV32KA304 I2C not working

Hi Jörg

As promised, I've just tested the Flowcode I2C component with hardware channel 1 on a 24F16KA102 and 24FV32KA302 and it all works OK,
(not tested with your particular FRAM though), so not sure what the issue was, but glad your project is now running.

Regards,
Leigh

i2c.jpg
by Benj
Thu Sep 08, 2016 10:55 am
Jump to forum
Jump to topic

Re: PIC24FV32KA304 Uart is twice speed

Hello Jörg, It looks like this is related to a compiler bug, the FV devices don't seem to have the standard compiler definition. I have added the definition to the header file for the chip which should solve the issue. The file needs to be placed into this directory. C:\Program Files (x86)\Flowcode ...
by Benj
Mon Jan 15, 2018 12:03 pm
Jump to forum
Jump to topic

Re: I2C Slave with PIC24F16KA301/302/304

Hi Jörg,

I've added the I2C slave interrupts to the attached definition files. Simply extract the files to your "Flowcode 7/FCD/PIC16" folder and restart Flowcode.

PIC16.zip


Let us know how you get on.