Search found 10 matches

Return

by Benj
Wed Apr 20, 2016 12:38 pm
Jump to forum
Jump to topic

Re: Interrupt evry 1/100s

Hello,

Something like this might help to get your values right.
http://eleccelerator.com/avr-timer-calculator/

Have a play and let us know how your getting on.
by Benj
Thu Apr 14, 2016 12:55 pm
Jump to forum
Jump to topic

Re: Interrupt evry 1/100s

Hello,

This should get you pretty close to 100Hz interrupt.

ArdTimerDemo.fcfx
by STibor
Tue Jun 07, 2016 8:28 pm
Jump to forum
Jump to topic

Re: max7219/SPI troubles.

Hi! initialize Chip_Select := 1; SPI_Init; Chip_Select := 0; SPI_Send_Char=0x0b; SPI_Send_Char=0x07; Chip_Select := 1; Chip_Select := 0; SPI_Send_Char=0x09; SPI_Send_Char=0xff; Chip_Select := 1; Chip_Select := 0; SPI_Send_Char=0x0c; SPI_Send_Char=0x01; Chip_Select := 1; Chip_Select := 0; SPI_Send_Ch...
by STibor
Fri Jun 10, 2016 4:15 pm
Jump to forum
Jump to topic

Re: max7219/SPI troubles.

Stibor, nice project - https://www.youtube.com/watch?v=L_2jvbifOwk How is this done? Arduino? Hello! Thanks! No Arduino, with Pic18F6622 made. I use Arduino development, final PIC microcontroller-based circuit. Controller pcb: https://fbcdn-sphotos-a-a.akamaihd.net/hphotos-ak-xta1/v/t1.0-9/1526595_...
by kersing
Fri Sep 30, 2016 10:11 pm
Jump to forum
Jump to topic

Re: I2C OLED Display 128x64

Based on the information on ebay you will need to use The SSD1306 component. Please try to create a flowchart yourself and if you do not succeed ask specific help.
by kersing
Tue Oct 04, 2016 11:36 pm
Jump to forum
Jump to topic

Re: I2C OLED Display 128x64

Try 'search' on the component bar. In the filter box enter SSD, this should list GLCD (SSD1306) I2C for Flowcode 6. Add the component to your flowchart and add some component macro calls to your flowchart starting with 'Initialize'. Make sure to check the component connections by selecting the compo...
by LeighM
Tue Jun 06, 2017 10:50 am
Jump to forum
Jump to topic

Re: AD9833 and SPI ->> not woeking

Hi, I've just tested this on a Uno (I don't currently have a Nano) and the SPI works fine. Perhaps there is an issue with your Seale logic analyzer setup? Based on a quick look at the AD9833 datasheet I would suggest you try changing the Clock Polarity to "Idle HIgh" and Clock Phase to &qu...
by LeighM
Wed Sep 20, 2017 9:42 am
Jump to forum
Jump to topic

Re: GLCD_ILI9341 - problem

Just a guess... try:
Pixel Height 320
Pixel Width 240
by Benj
Mon Nov 25, 2019 12:10 pm
Jump to forum
Jump to topic

Re: PWM doesn't work right - Arduino NANO

Hello,

The ATMEGA328 used on the Nano does not have a period register and so it can only use the period overflow value 255. In later versions of Flowcode we generate a warning message to inform the user of the lack of hardware capability.
by Docara
Mon Nov 25, 2019 2:43 pm
Jump to forum
Jump to topic

Re: PWM doesn't work right - Arduino NANO

Hi rradojko, In addition to what Ben posted, coincidentally, I have just watched a video by Eevblog (I think it was on the series he did about the 3 cent MCU) he programmed a blink LED function and showed the output on the same type of logic analyser you are using -Silae and it's clones, He said tha...