Search found 143 matches

Return

by medelec35
Sat Mar 28, 2015 7:18 pm
Jump to forum
Jump to topic

Re: Like to read Port B then send to Port D

Hi John, Your welcome and thanks. Testing for Digit 2 works wonderful Glad it's working. Found a glitch with Digit 9 not activating in: Guest Home Inning I have spotted the issue. I have added (RS232ReceveMode) && ((RXData < 57) && (RXData > 47) || (RXData = 99)) to prevent wrong dat...
by medelec35
Sun Mar 29, 2015 10:28 am
Jump to forum
Jump to topic

Re: Like to read Port B then send to Port D

Thanks John, Fingers crossed all will be working, esp when all connected together. Did you notice I have separated each transmitted Character by a 10ms delay? This is to increase receiving reliability. When a char is sent the Rx interrupt is triggered no matter what part of the software is being acc...
by medelec35
Mon Mar 30, 2015 3:01 pm
Jump to forum
Jump to topic

Re: Like to read Port B then send to Port D

No problem John. Reliability appeared to increase to 100% after the change. Don't forget a test program can be used to determine correct values for servo component. Let me know if yo want help in obtaining ideal values. Indecently, I created a flowchart for test rig that had two microswitches placed...
by medelec35
Sat Apr 04, 2015 5:45 pm
Jump to forum
Jump to topic

Re: Like to read Port B then send to Port D

Hi John,
Just wondering how it's all going?
by medelec35
Sun Apr 05, 2015 1:14 am
Jump to forum
Jump to topic

Re: Like to read Port B then send to Port D

Hi John, I 'm stuck on how to keep the display say Ball 1 up for A1 and when it sees A2 it will change like it does for the servo design ? Need a driver chip I think but not 100 % sure. Have you seen this thread ? Not sure if it's what you had in mind or not? Alternatively you could use MAX7219/MAX7...
by medelec35
Sat Sep 05, 2015 12:35 pm
Jump to forum
Jump to topic

Re: Push buttons not working

Hi John, Buttons should work, but when pressed movement changes are not noticeable when system panel is vertical . This would include the generic switches used when importing from Flowcode V5. Reason being is in the real word if looking directly on top of the switch then you won't see the change in ...
by medelec35
Sat Sep 05, 2015 10:16 pm
Jump to forum
Jump to topic

Re: Push buttons not working

At this moment I can not see how in Flowcode 6 to see the RS232 "Characters Sent" Select properties of RS232 then in properties simulation change Console Data from No to Yes. Make sure Console (allows viewing of comms components) is selected from the View menu: Console1.png Also FC6 simul...
by medelec35
Mon Sep 14, 2015 9:41 pm
Jump to forum
Jump to topic

Re: Adding Servo

Hi John, one Servo_Controller will control from 1 to 8 servos. So if you require say 10 servos for example you will need two Servo_Controllers in total. For simulation purpose you will also require You will also need 10 Standard servos. Servo_Controller0 will control servos on channels 0 to 7. In th...
by medelec35
Mon Sep 14, 2015 11:09 pm
Jump to forum
Jump to topic

Re: Adding Servo

Hi John,
I had spotted two mistakes.
1) Servo Object 0 was connected to Servo_Controller0 instead of Standard_servo0

2)EnableServo component was missing from Enable_servo_Clear Macro.

Can you see If attached that works any better?
by medelec35
Tue Sep 15, 2015 7:41 am
Jump to forum
Jump to topic

Re: Adding Servo

Hi John, I added breakpoints and variables to watch list. So when simulation stopped at a breakpoint you can then see what values are assigned to each variable. It was way past bed time so I rushed in the end. Your bug hunting skill are coming along nicely. So now all up and running? Just a reminder...
by medelec35
Tue Sep 15, 2015 8:24 pm
Jump to forum
Jump to topic

Re: Adding Servo

Hi John,
I mentioned adding variables to watch here.
by medelec35
Wed Sep 16, 2015 11:53 am
Jump to forum
Jump to topic

Re: PICkit2 reported error code 36

Benj wrote:I don't think the command line tool for the PICkit 2 supports the 16F18xx device your using.

It should if the dat and pk2cmd file will allow.
Posted about it including dat & pk2cmd file here
Although post is for Flowcode V5,
Should also work with V6.

Martin
by Benj
Wed Sep 16, 2015 11:15 am
Jump to forum
Jump to topic

Re: PICkit2 reported error code 36

Hello, I don't think the command line tool for the PICkit 2 supports the 16F18xx device your using. The cannot find device message is saying it cannot find the information to drive the specified device. I'm fairly certain that the 16F18xx devices were released after the PICkit 2 had been dropped. A ...
by medelec35
Wed Sep 16, 2015 6:18 pm
Jump to forum
Jump to topic

Re: PICkit2 reported error code 36

Hi John, PicKit 2 is not supported in PIC range higher then PIC12xxx. Going over my notes back in Flowcode 5 I was never able to get the compile to Chip to work.I suspect Benj info is true and why would Matrix not place a upgrade so PicKit 2 would work with Flowcode 5 or 6.Specially seeing Flowcode ...
by medelec35
Wed Sep 16, 2015 8:29 pm
Jump to forum
Jump to topic

Re: PICkit2 reported error code 36

Hi John,
Your parameter are wrong,
Take another look at the wiki link I posted in a previous post and make sure your programmer settings match:
Correct settings.png


Martin
by medelec35
Tue Sep 22, 2015 10:04 pm
Jump to forum
Jump to topic

Re: Race Car Timer not working on PIC

Hi John, The issues I have spotted are: 1) You have not got a 19.6608 MHz crystal connected on your diagram yet Flowcode is configured as though there is one. i.e within configuration settings osc is set to HS and not internal osc as the addition of osccon c code block suggests it should be. If that...
by medelec35
Fri Oct 09, 2015 11:23 pm
Jump to forum
Jump to topic

Re: Flowcode and Reality not matching

Hi John, They match for me: LCD Score Board1.jpg I have several suggestions with your Flowchart. 1) The RX interrupt calls a macro with in turn calls another macro that contains LCD components. Both of these are not good practice although hardware works for me. For good practice don't allow an inter...
by medelec35
Thu Oct 15, 2015 8:20 am
Jump to forum
Jump to topic

Re: Flowcode and Reality not matching

If it was was me, I would set the 51 in the same position as the 1 i.e for the top line use cursor x=5, Y=0 Then as i stated in my earlier post, Print received RX values. perhaps both on separate lines. Don't forget to add PrintString" " after the number appearing after : Otherwise if Ball...
by medelec35
Fri Oct 16, 2015 10:29 am
Jump to forum
Jump to topic

Re: Flowcode and Reality not matching

Hi John, I have modified your Flowchart to the way I suggested LCD is used as a diagnostic tool. The values represent ASCII data received: Diagnostic.png In this case ASCII 66 = B For the second command you will need to - 48. E.g 50 - 48 = 2 For Cc you should see: Diagnostic Cc.png The issue will be...
by medelec35
Fri Oct 16, 2015 5:23 pm
Jump to forum
Jump to topic

Re: Flowcode and Reality not matching

Hi John,
Sorry posted wrong version I should have posted the version with a in.
by medelec35
Sat Oct 17, 2015 12:31 am
Jump to forum
Jump to topic

Re: Flowcode and Reality not matching

Hi John,
I have modified flowchart for better simulation.
Should work faster.

Martin
by medelec35
Sat Oct 17, 2015 11:21 am
Jump to forum
Jump to topic

Re: Flowcode and Reality not matching

If there are never going to be servos connected, then all the servo routines could slow things down. Since RS232 interrupt is use that should not affect data. I have just been modifying the chart that you added Tree call macro and LCD macros to. To be honest if it was me I would not do it that way b...
by medelec35
Sat Oct 17, 2015 8:50 pm
Jump to forum
Jump to topic

Re: Flowcode and Reality not matching

Hi John,
After watching simulation, and remembering how the receiver is arranged.
I decided the time between the two commands will be far too short.
So I just separated each uppercase letter and c with 50ms in between.
and added 50ms at the start of clear command and at the end.

Martin
by medelec35
Tue Feb 02, 2016 10:53 pm
Jump to forum
Jump to topic

Re: Using 4 - 7 segment displays - Sync problem

Hi John, Family are well thanks, hope yours is too? Over Christmas we have a new grandson ( Benjermine ). Dec 18th. Congrats on the new edition. :) read thru the link you posted and I could be 100% wrong but it is realted to the QUAD display Yes but you can ADD the quad component and just use two of...
by medelec35
Wed Feb 03, 2016 10:42 pm
Jump to forum
Jump to topic

Re: Using 4 - 7 segment displays - Sync problem

Hi John, I have been testing multiple 7segs. They work fine with hardware but unfortunately there is a simulation bug which I have reported. So if you want simulation best stick with the quads for now. Besides if using quads type then it simplifies flowchart since with single 7segs you must switch o...