Search found 66 matches

Return

by lordhex
Tue Sep 20, 2016 8:11 pm
Jump to forum
Jump to topic

You are not authorised to read this forum.
by SimonB
Mon Sep 26, 2016 11:37 am
Jump to forum
Jump to topic

Re: Startup problems with Flowcode 7.1

Lagoda,

I think I know what the problem is. Please can you go in to the languages directory (C:\Program Files (x86)\Flowcode 7\languages) and you will see a file in there called flowhu.dll

Rename that file, and extract the new one that I have attached in to that folder.

Simon
by SimonB
Mon Sep 26, 2016 12:39 pm
Jump to forum
Jump to topic

Re: Startup problems with Flowcode 7.1

Hi Simon, I replaced the original V7.exe Flowcode file. Now the program is running well . :D I start to test it. Thank you very much for your help. Best Regards Lagoda Excellent this is great news :D The problem was with the language files, but only for certain languages. The following languages ar...
by Benj
Mon Oct 03, 2016 3:59 pm
Jump to forum
Jump to topic

Re: SSD1305 simulation problem

Hello Lagoda, Working fine for me here. Can you try changing the Display Method property on the GLCD component properties from Bitmap to Point cloud and see if this makes any difference. I have seen the bitmap method have a problem on a single Win 10 machine but not been able to replicate it anywher...
by Benj
Mon Oct 03, 2016 11:59 am
Jump to forum
Jump to topic

Re: PIC12F508, 509, 510 related compilation error

Hello Lagoda,

Thanks for letting us know. I believe I have now fixed the problem with the attached updated files.

Simply extract and copy the attached files to your "Flowcode 7/FCD/PIC" folder and restart Flowcode for the changes to be loaded.

PIC.zip
by Benj
Tue Oct 11, 2016 1:06 pm
Jump to forum
Jump to topic

Re: SSD1305 simulation problem

Hello Lagoda, We have found and fixed the issues with this component in simulation now. There was a couple of problems specific to this component. Base_GLCD.fcpx gLCD_SSD1305.fcpx Hopefully these components will fix any simulation problems you are having and allow the bitmap mode and point cloud mod...
by Benj
Tue Oct 04, 2016 5:30 pm
Jump to forum
Jump to topic

Re: SSD1305 simulation problem

Hello, Here is how the two simulation modes should look based on your example. DrawModes.jpg 7.1 uses significantly less RAM than 7.0.4 so maybe there is an issue that has crept in here? However things are working well for me still in 7.1. Is anyone else having simulation issues with gLCDs in 7.1? M...
by Benj
Wed Oct 12, 2016 6:19 pm
Jump to forum
Jump to topic

Re: SSD1305 Component Macro problem?

I've emailed TME to see if they have any specific example code for the display.

Fingers crossed they can dig something out for us.

Otherwise your best bet may be to send us a display so we can play with it and get it working correctly.
by Benj
Wed Oct 12, 2016 3:34 pm
Jump to forum
Jump to topic

Re: SSD1305 Component Macro problem?

Sounds like the lower 32 rows may have a different offset again! e.g. the SSD1305 memory map for your display may look something like this. Rows 0 - 31 = Nothing Rows 32 - 63 = Top 32 lines Rows 64 - 95 = Nothing Rows 96 - 128 = Bottom 32 lines Hmm how to deal with this in a nice way!? I'll think on...
by Benj
Wed Oct 12, 2016 12:04 pm
Jump to forum
Jump to topic

Re: SSD1305 Component Macro problem?

Here is another attempt to solve the problem, this time rather than manipulate the pixel address I have applied the offset to the display initialisation values using command 0xD3 - Set display Offset. Hopefully this will improve things. Again try the value 32 for the Height Offset, if this doesn't w...
by Benj
Wed Oct 12, 2016 10:24 am
Jump to forum
Jump to topic

Re: SSD1305 Component Macro problem?

Hello Lagoda, I have added offset properties to the component to try and help work around the problem. I think in your case you would need to set the new Height Offset property to 32. To add the new component to your installation simply copy the file to your "Flowcode 7/components" folder ...
by Benj
Tue Oct 11, 2016 12:55 pm
Jump to forum
Jump to topic

Re: SSD1305 Component Macro problem?

Hello, Sometimes the GLCD manufacturers don't place pixel 0,0 at location 0,0 of the controller IC. There is often an offset. Maybe we can add an offset component property to allow for this. I will investigate and see how much of a job it would be to do. For now try increasing the dimensions of the ...
by Benj
Wed Oct 12, 2016 9:45 pm
Jump to forum
Jump to topic

Re: SSD1305 Component Macro problem?

Sounds like it's wrapping. Maybe the X coordinate is the key. What if you go beyond the X = 127 boundary? does that allow you to control the other half of the display?
by Benj
Fri Oct 14, 2016 3:54 pm
Jump to forum
Jump to topic

Re: SSD1305 Component Macro problem?

Hello Lagoda,

Looks like we're nearly there.

This component should hopefully fix the mirrored display problem.

gLCD_SSD1305_buffered.fcpx


I take it the clear function is not currently clearing everything. Are you drawing those horizontal lines?
by Benj
Fri Oct 14, 2016 2:12 pm
Jump to forum
Jump to topic

Re: SSD1305 Component Macro problem?

Right the manufacturer has been in touch with some example demo code.

I've changed the initialise routine to match up with their example.

gLCD_SSD1305_buffered.fcpx


Fingers crossed.
by Benj
Fri Oct 14, 2016 5:41 pm
Jump to forum
Jump to topic

Re: SSD1305 Component Macro problem?

Thanks for letting me know. I have been through the clear function now too so hopefully this will also work correctly.

gLCD_SSD1305_buffered.fcpx
by Benj
Mon Oct 17, 2016 5:02 pm
Jump to forum
Jump to topic

Re: SSD1305 Component Macro problem?

Brilliant, looks like we're finally there. :mrgreen:

I've rolled out the changes to the none buffered SSD1305 component now too if anyone else needs this.

Let me know if anything else crops up.
by Benj
Mon Oct 17, 2016 2:23 pm
Jump to forum
Jump to topic

Re: SSD1305 Component Macro problem?

Hi Lagoda,

Thanks for the file. Please can you try this and let me know how you get on. I'm hoping that coordinate 0,0 should be 0,0 on the display now using the H Offset property with the value 4.

1305display_test012.fcfx
by Benj
Mon Oct 17, 2016 11:58 am
Jump to forum
Jump to topic

Re: SSD1305 Component Macro problem?

Hi Lagoda,

Have you changed the value of the H Offset property? I thought a value of 4 would fix the issue, the default is 0. Have you tried any other values?
by Benj
Mon Oct 17, 2016 10:03 am
Jump to forum
Jump to topic

Re: SSD1305 Component Macro problem?

Great, Very close now. :D

Looks like there is still a bit of an X offset so the attached has a new property which should hopefully fix that.

Set the H Offset property to 4 and hopefully you should now be good to go.

gLCD_SSD1305_buffered.fcpx
by Benj
Wed Oct 19, 2016 4:51 pm
Jump to forum
Jump to topic

Re: SSD1305 Component Macro problem?

Right please can you try this out and hopefully the problem will now be resolved. gLCD_SSD1305_buffered.fcpx Printing "OOOOOO" at 94, 0 is ok. Printing "123123123" at 0, 59 is not ok. The coordinates should be 0, 54 to correctly fit the vertical 8 bits onto the screen at pixels 5...
by Benj
Thu Oct 20, 2016 9:53 am
Jump to forum
Jump to topic

Re: SSD1305 Component Macro problem?

Phew, that is good news :D

Glad I could be of help. Turns out a lot of the display components had the same problem so I have been through and fixed it in all of them now.

Thanks for your patience and help to get this up and running.
by Benj
Mon Mar 06, 2017 11:11 am
Jump to forum
Jump to topic

Re: Floating point numbers

Hello Lagoda,

Thanks for letting us know of the problem. I have found the cause and hopefully fixed it.

Simply copy the file below into your "Flowcode 7/CAL/PIC16BIT" folder and then compilation should work correctly.

PIC16BIT_CAL_Float.c


Let me know how you get on.
by Benj
Wed Mar 08, 2017 5:50 pm
Jump to forum
Jump to topic

Re: ASCII characters on GLCD

Hello Lagoda,

This forum topic may help to explain how the gLCD font works.
viewtopic.php?f=54&t=16703&p=69140#p69118

Which characters would you like to add support for?
by jgu1
Sun Mar 12, 2017 2:33 pm
Jump to forum
Jump to topic

Re: Unable to download software

Dont know if it help or you already do it on same way. I started FC7 go to the helpmenu, check for update, Then I get the message, there is a never version, do you want to download. I save it on my HD. Uninstall version 7.1 and then I run the new install file. Another way, maybe, you could dowload t...