Search found 58 matches

by electronix
Wed Jan 30, 2019 9:54 pm
Forum: Bug reports
Topic: RFID_MFRC522_V2 non remappable?
Replies: 2
Views: 1073

Re: RFID_MFRC522_V2 non remappable?

Hi Ben☺

Thanks for clearing that one so quick for me ☺.

Best regards

Nick
by electronix
Wed Jan 30, 2019 10:29 am
Forum: Bug reports
Topic: RFID_MFRC522_V2 non remappable?
Replies: 2
Views: 1073

RFID_MFRC522_V2 non remappable?

Hi all. I recently discovered that the above mentioned component(RFID_MFRC522_V2) is no longer remappable? If I choose for example ch 2 then all com pins are locked to RG6-RG7-RG8. but pin SS and Reset can still be remapped. My target: 33EP512MU814 Is this a bug or done by purpose? Best regards Nick
by electronix
Sun Nov 11, 2018 11:27 am
Forum: Bug reports
Topic: Modbus master remap bug?
Replies: 7
Views: 2320

Re: Modbus master remap bug?

Hi Ben. Thanks for your answer :-) I changed my target MCU from 24EP512GU810 to 33EP512MU810 And now it`s working beautyfully :-) so thanks for the tip to just change tartget device. By the way, have you had anything to do with 33EP512MU814? just asking since my next project propobly will involve mo...
by electronix
Sat Nov 03, 2018 8:16 pm
Forum: Bug reports
Topic: Modbus master remap bug?
Replies: 7
Views: 2320

Re: Modbus master remap bug?

Hi all.

Did anyone look into the problem remapping UART?
I was intending to use modbus slave component yesterday but it still has the above mentioned flaws it seems...

Edit.
My target is : PIC24EP512GU810
by electronix
Thu Sep 27, 2018 11:39 am
Forum: Bug reports
Topic: PIC24EP512GU810 PWM problems
Replies: 4
Views: 1532

Re: PIC24EP512GU810 PWM problems

Hi Ben.
:oops: :shock: ....
I cant belive I just didn´t see that :oops:

Thank you for, as always, excellent support Ben :D

Best Regards
Nick
by electronix
Wed Sep 26, 2018 4:54 pm
Forum: Bug reports
Topic: PIC24EP512GU810 PWM problems
Replies: 4
Views: 1532

Re: PIC24EP512GU810 PWM problems

Hi Ben.
Thanks a lot for looking into it, maybe I´m just not seeing the problem.

I have tried it on hardware.
Here´s the file

Best Regards
Nick
by electronix
Wed Sep 26, 2018 3:28 pm
Forum: Bug reports
Topic: PIC24EP512GU810 PWM problems
Replies: 4
Views: 1532

PIC24EP512GU810 PWM problems

Hi all.
I have been trying to use a PWM component in a project but no matter what I put in the duty cycle it always stays 50%, Has anyone else experienced the same thing or am I missing something?
Have tried both 10-bit setting and 8-bit setting and the result stays the same...50%

Regards

Nick
by electronix
Thu Aug 02, 2018 3:29 pm
Forum: General Programming
Topic: fingerprint flowcode component?
Replies: 11
Views: 4364

Re: fingerprint flowcode component?

Hi all. Thanks for all the feedback, I´ll try too describe the problem. I have a client that currently are using an RFID tag/card passage system designed by me and it has been working prettu much ok fore a couple of years, but now the RFID tag/card doesn´t provide a high enough security level anymor...
by electronix
Thu Aug 02, 2018 8:55 am
Forum: General Programming
Topic: fingerprint flowcode component?
Replies: 11
Views: 4364

Re: fingerprint flowcode component?

Hi Ben.
Thanks alot for the quick reply.
I´ll give it a try and post the result here later.
by electronix
Wed Aug 01, 2018 4:53 pm
Forum: General Programming
Topic: fingerprint flowcode component?
Replies: 11
Views: 4364

Re: fingerprint flowcode component?

Does anybody know if the fingerprint sensor, mentioned above, ever were implemented in FC7? Or am I just blind and can´t find it?
by electronix
Fri Feb 16, 2018 5:01 pm
Forum: Bug reports
Topic: Modbus master remap bug?
Replies: 7
Views: 2320

Re: Modbus master remap bug?

Another update, the modbus slave component are receiving on all 4 channels but it doesn´t transmit anything on any chanel, I have tried almost all pin configurations.
Any ideas anyone?

//
Nick
by electronix
Thu Feb 15, 2018 2:40 pm
Forum: Bug reports
Topic: Modbus master remap bug?
Replies: 7
Views: 2320

Re: Modbus master remap bug?

Hi Ben. Ok I´ve done some moore testing, Port F is not sending(TX) anything at all no mater what I try, Pin G0 and G1 are sending(TX) on HW chanels 2-4. Port D lower byte is working on chanel 3-4 not 1-2, port D upper byte doesn´t send anything on any chanel. Chanel 1 doesn´t seem to do anything muc...
by electronix
Thu Feb 15, 2018 9:38 am
Forum: Bug reports
Topic: Modbus master remap bug?
Replies: 7
Views: 2320

Modbus master remap bug?

Hi guys. I am trying to use the modbus master in a project, but when I try to remap TX RX to for example F.2 and F3 those pins become completely dead on my HW? The only pins that seems to work are G.0 and G.1 and it takes a lot of fiddeling to remap to those again, including chaning the pins in both...
by electronix
Fri Feb 02, 2018 4:53 pm
Forum: User Components
Topic: Modbus RTU/HC06
Replies: 2
Views: 1497

Re: Modbus RTU/HC06

Hi Ben.

Thanks for your reply, and your suggestion is spot on what I´m trying right now, I´ll post the result here when I´m done.

/Nick
by electronix
Thu Feb 01, 2018 5:46 pm
Forum: User Components
Topic: Modbus RTU/HC06
Replies: 2
Views: 1497

Modbus RTU/HC06

Hi all.
Would it be possible to use the bluetooth component HC06 in FC7 to connect, for example, an Android device and use modbus rtu protocol?
Has anyone tried already? Any ideas on how it could be done?

/Nick
by electronix
Tue Jan 30, 2018 9:59 am
Forum: Bug reports
Topic: Serial Eeprom 24C32 not working
Replies: 2
Views: 1177

Re: Serial Eeprom 24C32 not working

Hi Leigh.

I just did the last upgrade of 7.3 and after some testing it seems to work in both HW and SW mode, so I guess its working, I will use it in a project later on though for proper testing.

Thanks a lot :-)
by electronix
Sat Jan 06, 2018 1:14 pm
Forum: Bug reports
Topic: Serial Eeprom 24C32 not working
Replies: 2
Views: 1177

Serial Eeprom 24C32 not working

Hi all. So I`ve been trying to use the I2C Eeprom component without any success, has anybody else used it since upgrade 7.3? It compilates ok, but when running the program it stops in the Read command. The MCU speed seems ok after running the "blinker test" at several rates and also PWM ch...
by electronix
Mon Sep 25, 2017 5:33 pm
Forum: Flowcode V7
Topic: help with programming logic
Replies: 8
Views: 2899

Re: help with programming logic

You could use a suitable IC for the job such as: LM1815. it translates the sine to a nice clean TTL signal that can be captured by your PIC, I have used this IC in automotive aplications and it works like a charm.
by electronix
Fri Aug 25, 2017 9:04 am
Forum: Bug reports
Topic: ERRATA - dsPIC33EP512MU814 (solved)
Replies: 4
Views: 2094

Re: ERRATA - dsPIC33EP512MU814

Hi Ben.

Will you make a list of wich decvices you find? Since I have had some problems with dsPIC33ep512MU810, perhaps something similar to the mu814 issues.
by electronix
Mon Aug 14, 2017 2:41 pm
Forum: Flowcode V7
Topic: Component Required
Replies: 17
Views: 5619

Re: Component Required

Hi Docara.
Sounds like you need a pwm output and an RC filter(a resistor in series and a capacitor in parallel) after it, and by varying the dutycycle you will have an analog outputsignal.
About the values of the filter, it depends of how fast you need to alter the outputsignal.

regards
Nick
by electronix
Fri Jul 05, 2013 11:18 am
Forum: Flowcode V5
Topic: compiling FC4 code in FC5 don´t run on the target
Replies: 9
Views: 3219

Re: compiling FC4 code in FC5 don´t run on the target

Ah ok...

It is more or less the same deal for me as well, I´m still using FC4 since FC5 doesn´t seem to support the RF component... :-(
by electronix
Tue Jul 02, 2013 4:33 pm
Forum: Flowcode V5
Topic: compiling FC4 code in FC5 don´t run on the target
Replies: 9
Views: 3219

Re: compiling FC4 code in FC5 don´t run on the target

Hi Andreas. Did you ever receive any help for your problems with these RF modules? Cause it turns out I have the very same problem. In FC4 everything works just fine, no problems, but when compiling the FC4 code in FC5 nothing works, not even disturbance. What is even stranger is that if I rewrite b...
by electronix
Thu Sep 13, 2012 12:08 pm
Forum: Flowcode V4
Topic: 18F8627 speed problem.
Replies: 4
Views: 2269

Re: 18F8627 speed problem.

Hi Ben

Ok I´ll try that straight away.

Thanks alot Ben :-)

electronix
by electronix
Thu Sep 13, 2012 11:20 am
Forum: Flowcode V4
Topic: 18F8627 speed problem.
Replies: 4
Views: 2269

Re: 18F8627 speed problem.

Hi Ben.

Thanks for your very quick reply, the main problem is not the missing 2Hz but the lack of coms with the RF unit, I just thought it may be related someway.
Sure I´ll post the program but all it actually does is; send a byte and wait a sec.

Thanks alot Ben.

electronix
by electronix
Thu Sep 13, 2012 9:09 am
Forum: Flowcode V4
Topic: 18F8627 speed problem.
Replies: 4
Views: 2269

18F8627 speed problem.

Hi everyone. Has anyone made a design/program using 18F8627 succesfully? I have been trying to make it work @20MHz but there seem to be some oscillator problem, if I make a loop with a 2mS delay and toggle a port pin I get 498Hz! Tried to compensate this by reducing the oscillator speed in projekt o...