Search found 195 matches

by Zane
Fri May 31, 2019 12:05 pm
Forum: Bug reports
Topic: PIC18F26K80 LCD wont work on PORTC
Replies: 3
Views: 1169

Re: PIC18F26K80 LCD wont work on PORTC

Hi Guys,

Thanks for your help here, got it working fine now. :D
by Zane
Thu May 30, 2019 1:35 am
Forum: Bug reports
Topic: PIC18F26K80 LCD wont work on PORTC
Replies: 3
Views: 1169

PIC18F26K80 LCD wont work on PORTC

Hi,

I have tried to connect an LCD display to PORTC pins 0-5 and it will not work. I have connected it to PORTB with no problems. I have also tried with the same program using a PIC16F823 and connected the display to both PORTB and PORTC and it works ok on both ports.

Thanks
by Zane
Mon Dec 03, 2018 7:13 pm
Forum: General Programming
Topic: Programming advice when using interrupts
Replies: 4
Views: 1356

Re: Programming advice when using interrupts

Hi Ben,

Thanks for that explanation, that clarifies the issue and i can now work around that. Thanks for your help :D
by Zane
Mon Dec 03, 2018 3:53 pm
Forum: General Programming
Topic: Programming advice when using interrupts
Replies: 4
Views: 1356

Re: Programming advice when using interrupts

Hi Ben, Thanks for your reply. If i have a macro call for a send for the CAL UART in the main loop and also any other macro that i have created there are no problems. If i also put in a call for the CAL UART from any macro that is called via an interrupt i get the following message when there is the...
by Zane
Mon Dec 03, 2018 8:36 am
Forum: General Programming
Topic: Programming advice when using interrupts
Replies: 4
Views: 1356

Programming advice when using interrupts

Hi, I have a program i am writing with code present in the main loop. I am also using the CAL UART component. I have an interrupt routine that is triggered by data being received by the UART. The interrupt routine processes the incoming data. Once this is done a status needs to be transmitted from t...
by Zane
Thu Nov 15, 2018 11:09 am
Forum: Flowcode V7
Topic: Larger than expected delay between Modbus commands
Replies: 3
Views: 1503

Re: Larger than expected delay between Modbus commands

Hi Leigh, Thanks for your reply. I have done some additional testing and found that with each data transaction, the correct data was being sent and received with no timeouts so proving that the delay was not a result of a timeout situation. I noticed it was not working as expected so have let you kn...
by Zane
Wed Nov 14, 2018 11:31 pm
Forum: Flowcode V7
Topic: Larger than expected delay between Modbus commands
Replies: 3
Views: 1503

Re: Larger than expected delay between Modbus commands

Hi Ben,

Wondering if you have been able to look at this yet.

Thanks
by Zane
Tue Nov 13, 2018 7:38 am
Forum: Flowcode V7
Topic: Larger than expected delay between Modbus commands
Replies: 3
Views: 1503

Larger than expected delay between Modbus commands

Hi Ben, I am using the Modbus master component to communicate with a slave i/o device. The component functions appear to work fine with the data being sent and received as expected. However from when one command is sent to the module to another being sent, there is a larger than expected delay. I am...
by Zane
Mon Nov 12, 2018 11:48 am
Forum: Flowcode V7
Topic: Unable to get Modbus to work with VNET
Replies: 4
Views: 1567

Re: Unable to get Modbus to work with VNET

Hi Ben,

I have tried using the modbus master function and i am getting the results i expect.

Thanks
by Zane
Thu Oct 11, 2018 3:54 am
Forum: Flowcode V7
Topic: Unable to get Modbus to work with VNET
Replies: 4
Views: 1567

Re: Unable to get Modbus to work with VNET

Hi Ben,

The simulation is working as you mentioned. I understand about the compatibility issues, no worries there. I have some hardware arriving soon so can try with that. Once again thank you for your help, its always appreciated. Cheers
by Zane
Thu Oct 04, 2018 10:49 am
Forum: Flowcode V7
Topic: Unable to get Modbus to work with VNET
Replies: 4
Views: 1567

Re: Unable to get Modbus to work with VNET

Thanks for your work on this, I am away for the next few days. When I get back I will try this out and let you know how we get on.

Thanks

Zane
by Zane
Wed Oct 03, 2018 2:09 pm
Forum: Flowcode V7
Topic: Unable to get Modbus to work with VNET
Replies: 4
Views: 1567

Unable to get Modbus to work with VNET

Hi Ben, I have tried getting the Modbus components working, a master sending data to a slave and looking for the confirmation back at the master. In the master flowchart in the console you can see Modbus data being generated and the data in the Modbus master - Vnet that is being sent to the slave. W...
by Zane
Tue Oct 02, 2018 4:28 pm
Forum: Flowcode V8
Topic: Using vNet injector in FC8
Replies: 10
Views: 2490

Re: Using vNet injector in FC8

Hi Ben,

Ok with the unique channel instances it works fine now. Once again thanks for your good work. :D

Zane
by Zane
Tue Oct 02, 2018 1:59 pm
Forum: Flowcode V8
Topic: Using vNet injector in FC8
Replies: 10
Views: 2490

Re: Using vNet injector in FC8

Hi Ben, The extracted DLL file has been installed and I have set up two instances of flowcode each sending and receiving characters. It looks like they are sending but not receiving. Looks like only the one channel is being opened up. See what you think, hope i have set it up correctly? Running both...
by Zane
Tue Oct 02, 2018 1:30 am
Forum: Flowcode V8
Topic: Using vNet injector in FC8
Replies: 10
Views: 2490

Re: Using vNet injector in FC8

Hi Ben, I installed the latest component, put a VNET and RS232 component into a project, very basic with an initialize for the rs232 component and then sending out a character every second in a loop. Looking at the console it looks like there is still an issue. Once again tried with the firewall off...
by Zane
Mon Oct 01, 2018 12:11 pm
Forum: Flowcode V8
Topic: Using vNet injector in FC8
Replies: 10
Views: 2490

Re: Using vNet injector in FC8

Hi Ben, Would these bugs also be present in FC7? I have tried to get my VNET injector running but have had no luck. I get the message UDP socket on channel 6 failed. I have seen another post relating to this. I have tried disabling my firewall and this has no effect. Do you have any ideas where i ca...
by Zane
Fri Jul 20, 2018 12:40 am
Forum: General Programming
Topic: Cheap PCB manufacturing
Replies: 3
Views: 2490

Cheap PCB manufacturing

I have recently finished a job and needed PCB's to be made. I found a place in China called Seeed studios. https://www.seeedstudio.com/fusion_pcb.html If you stay within their standard manufacturing parameters it gives you a board 100mm x 100mm or smaller, 1oz copper, green solder mask etc and the c...
by Zane
Thu Jun 07, 2018 9:12 pm
Forum: Bug reports
Topic: PIC16F18326 PMW Timer 2 only available timer
Replies: 25
Views: 5761

Re: PIC16F18326 PMW Timer 2 only available timer

Hi Ben,

I have tried out the PWM function with timers 2, 4 and 6 and everything now works as expected :D

Thanks for your help with getting this fixed, most appreciated.

Cheers

Zane
by Zane
Mon Jun 04, 2018 10:37 pm
Forum: Bug reports
Topic: PIC16F18326 PMW Timer 2 only available timer
Replies: 25
Views: 5761

Re: PIC16F18326 PMW Timer 2 only available timer

Hi Ben, Thanks for looking at this for me. I have attached a small program where the two PWM channels are used. Channel 1 has timer 2 assigned to it. The values used for the period and the duty cycle work as expected. Channel 2 has timer 4 assigned to it. Any changes to the period are not reflected ...
by Zane
Wed May 30, 2018 9:38 am
Forum: Bug reports
Topic: PIC16F18326 PMW Timer 2 only available timer
Replies: 25
Views: 5761

Re: PIC16F18326 PMW Timer 2 only available timer

Hi Ben,

How are you going with this, have you managed to find any time to look at this.

Thanks

Zane
by Zane
Tue May 22, 2018 7:20 am
Forum: Bug reports
Topic: PIC16F18326 PMW Timer 2 only available timer
Replies: 25
Views: 5761

Re: PIC16F18326 PMW Timer 2 only available timer

Hi Ben,

I was wondering if you have had a chance to follow this up. I have also found that when using T2, T4 or T6 to drive an interrupt they all work at the given intervals set and when T4 and T6 are used with a PWM channel they experience the problems mentioned in the last post.

Thanks

Zane
by Zane
Sun May 20, 2018 9:42 pm
Forum: Bug reports
Topic: PIC16F18326 PMW Timer 2 only available timer
Replies: 25
Views: 5761

Re: PIC16F18326 PMW Timer 2 only available timer

Hi Ben,

I have downloaded the latest updates. I can get both PWM channels to work. However it looks like when using T4 or T6 to drive a given channel it looks like T4 and T6 are getting their values from T2. When using T2 all the timing values seem correct.

Thanks

Zane
by Zane
Wed May 16, 2018 8:27 pm
Forum: Bug reports
Topic: PIC16F18326 PMW Timer 2 only available timer
Replies: 25
Views: 5761

Re: PIC16F18326 PMW Timer 2 only available timer

Hi Ben

I have ordered some PIC16F18326's. When they arrive i will try with those too and let you know how we get on. I am sure they will work a treat. Once again thanks for your help. :D

Cheers

Zane
by Zane
Tue May 15, 2018 8:33 pm
Forum: Bug reports
Topic: PIC16F18326 PMW Timer 2 only available timer
Replies: 25
Views: 5761

Re: PIC16F18326 PMW Timer 2 only available timer

Hi Ben, Thanks, i have tried with these file updates and it works a treat. :D How the .FCDX file required updating to allow the PWM output to work on the PIC16F18323, is the same mod required for the PIC16F18326's .FCDX file as well? If so are you able to post the mod for that file as well. Thanks Z...
by Zane
Mon May 14, 2018 9:19 pm
Forum: Bug reports
Topic: PIC16F18326 PMW Timer 2 only available timer
Replies: 25
Views: 5761

Re: PIC16F18326 PMW Timer 2 only available timer

Hi Ben,

Have you had a chance to look into the problem with the PIC16F18323 with the PWM not working when using timer 2 to drive the channel?

Cheers

Zane