Search found 33 matches

by TerryV
Sun Feb 24, 2013 11:24 am
Forum: General Programming
Topic: Programming with connected I/O
Replies: 7
Views: 1567

Re: Programming with connected I/O

Hi Ben, Thank you for the response. Appologies for getting my Vdd/Vss crossed. What ever happened to Vcc and Gnd? But I still have the situation; Pin 1 = clean 5Vdc Pin 8 has spikes of varying magnitude but up to 1.6V at what appears to be 20 mS apart which seems to point to the 50Hz supply. The 14V...
by TerryV
Sun Feb 17, 2013 3:03 am
Forum: General Programming
Topic: Programming with connected I/O
Replies: 7
Views: 1567

Re: Programming with connected I/O

Hi, I am still having difficulties. Pin 8 (Vdd) wrt power supply gnd shows random spikes upto 1.6 V o-p (I have a Picoscope Image but unable to attach picture) Vss is a clean 5V dc. Not sure what is going on but I dont think it would be overly healthy. Where does Vdd originate? Obviously it is not t...
by TerryV
Sun Feb 10, 2013 7:21 am
Forum: General Programming
Topic: Programming with connected I/O
Replies: 7
Views: 1567

Re: Programming with connected I/O

Thanks for the response Ben. The system is set to HS with the crystal selected and the watchdog is off. Is there an explaination for this - I went back to check settings and repowered the board and the program started running - It was not running when I switch power off. Then I attempted to load the...
by TerryV
Wed Feb 06, 2013 6:08 am
Forum: General Programming
Topic: Programming with connected I/O
Replies: 7
Views: 1567

Re: Programming with connected I/O

I think I have answersed this myself ------ chip uses some of the I/O pins for programming.
Sorry should have thought of this :oops:
by TerryV
Wed Feb 06, 2013 6:02 am
Forum: General Programming
Topic: Programming with connected I/O
Replies: 7
Views: 1567

Programming with connected I/O

Hi This is a general question – Is it recommended to remove the connected I/O devices before programming/reprogramming a PIC using the HP488v3? I seem to have damaged two 12F675 by what appears to be reprogramming with I/O connected -making simple timing changes. I ran a small test flashing LED prog...
by TerryV
Thu Dec 23, 2010 9:36 pm
Forum: General Programming
Topic: USB cable not connected
Replies: 15
Views: 4887

Re: USB cable not connected

Hi Ben, thanks for the suggestion but this was done previously and checked again but no success came of that. However, the last thing I tried was to overwrite all files in the C4PICs3 directly with a copy from my old machine. This was a success with the exception of the PIC launcher all is working f...
by TerryV
Tue Dec 21, 2010 11:38 pm
Forum: General Programming
Topic: USB cable not connected
Replies: 15
Views: 4887

Re: USB cable not connected

I use both Firefox and MSIE and have tried both but no go from the comms point of view. The software C4PICS appears to function ok however when I attempt to run an exercise by clicking on the link in C4PICS I get a message from the Matrix Document Launcher - "cannot open file C:/....../ex11.c3l...
by TerryV
Sun Dec 19, 2010 10:48 pm
Forum: General Programming
Topic: USB cable not connected
Replies: 15
Views: 4887

Re: USB cable not connected

I am running XP ver 2002 Ser Pac 3 which from what I can gather is a 32 bit OS.
by TerryV
Fri Dec 17, 2010 12:15 pm
Forum: General Programming
Topic: USB cable not connected
Replies: 15
Views: 4887

Re: USB cable not connected

Hi,
any progress?

Cheers
by TerryV
Wed Dec 15, 2010 11:18 am
Forum: General Programming
Topic: USB cable not connected
Replies: 15
Views: 4887

Re: USB cable not connected

Hi David,
Spec is:
SPECIFICATIONS

Processor Number N450

# of Cores 1

# of Threads 2

Clock Speed 1.66 GHz

L2 Cache 512 KB

Bus/Core Ratio 10

Instruction Set 64-bit

Instruction Set Extensions SSE2, SSE3, SSSE3

Embedded Options Available Yes

Supplemental SKU No

Max TDP 5.5 W



Cheers

TerryV
by TerryV
Tue Dec 14, 2010 11:06 am
Forum: General Programming
Topic: USB cable not connected
Replies: 15
Views: 4887

Re: USB cable not connected

Hi,
Any further developments?

Cheers
by TerryV
Sun Dec 12, 2010 7:23 am
Forum: General Programming
Topic: USB cable not connected
Replies: 15
Views: 4887

Re: USB cable not connected

Thanks Ben, once i get C4PICS sorted I will start on Flowcode.

Cheers
by TerryV
Sat Dec 11, 2010 10:42 am
Forum: General Programming
Topic: USB cable not connected
Replies: 15
Views: 4887

Re: USB cable not connected

Thanks for the advice but so far no go. I have un insatalled Flow code V3 and I am concentrating on C4PICS. There seems to be several issues here regarding the locating of the files such as PPP which may have something to do with the launch of these programs. The device manager indicates that the HP...
by TerryV
Sun Dec 05, 2010 10:28 am
Forum: General Programming
Topic: USB cable not connected
Replies: 15
Views: 4887

USB cable not connected

Hi, I have just, well about 2 weeksw ago reinstalled flow code 3 on my new netbook and whilst all appears to install and run ok, PPP constantly tells me that the USB cable or is not connected and when I attempt to confirgure the chip through flow code it tells me it can't id the chip and it assumes ...
by TerryV
Wed Jul 14, 2010 5:56 am
Forum: Bugs / Application Errors
Topic: Unable to save newly created **.fcf
Replies: 3
Views: 3180

Re: Unable to save newly created **.fcf

You are correct, that is exactly what was happening.

many thanks
by TerryV
Tue Jul 13, 2010 11:04 am
Forum: Bugs / Application Errors
Topic: Unable to compile
Replies: 8
Views: 11271

Re: Unable to compile

Hi,
The FRAQ refernces Windows 7 and I am running XP but I did manage to resolve the problem by saving to another directory.

Thanks
by TerryV
Tue Jul 13, 2010 6:32 am
Forum: Bugs / Application Errors
Topic: Unable to save newly created **.fcf
Replies: 3
Views: 3180

Unable to save newly created **.fcf

Further to my previous, in addition to the problem covered by that, I now find I am unable to save new programs and the message as follows when attempting to do so. ___________________________________________________________________ Access to F:\***.fcf was denied ___________________________________...
by TerryV
Tue Jul 13, 2010 6:19 am
Forum: Bugs / Application Errors
Topic: Unable to compile
Replies: 8
Views: 11271

Unable to compile

Hi, I am and have been for some time using Flowcode Ver 3. I have just struck a problem whereby I am unable to generate the asm file and get the following error message. ________________________________________________________________________________________________ FATAL: Unable to create output fi...
by TerryV
Sun Jun 13, 2010 10:57 pm
Forum: Electronics products
Topic: V3 Dev Boards - LCD &7SD not working
Replies: 1
Views: 2121

V3 Dev Boards - LCD &7SD not working

Hi, I have a V3 development board which i have had for a few years. I have not sofar used the 7SD or LCD and now that i am attempting to use them neither of them appear to be working. The LCD seems to be illuminating all pixels of the entire first row. In flow code all seems to working well. Is the ...
by TerryV
Tue Feb 23, 2010 7:22 am
Forum: C and ASM Programming
Topic: C2C "For"
Replies: 5
Views: 3063

Re: C2C "For"

Hi, I have tried changing the value of "i", in fact I created the following to determine whether the program was getting past the for loop, and it appears it is not. #include <system.h> #include "Project_1A.h" void main (void) { unsigned int i ; /* set bit 0 of PORTA for output *...
by TerryV
Tue Feb 23, 2010 6:35 am
Forum: Electronics products
Topic: V3 Oscillator cap values
Replies: 1
Views: 2080

V3 Oscillator cap values

Hi,
I am having difficulty reading the compnent values on the HP488-00-3 Data sheet.

In particular the oscillator capacitor values. Actually, all component values.

Is a more readable circuit diagram available or may be a parts list?

Thanks
by TerryV
Sat Feb 20, 2010 7:51 am
Forum: C and ASM Programming
Topic: C2C "For"
Replies: 5
Views: 3063

Re: C2C "For"

Hi, Thanks for the response. It is actuallly a for loop. i was jumping ahead of myself but the problem is the same. The Watch dog timer is off. As I said - it compiles and assemles and downloads - but only a (0) lights up and does not flash??? The instructions are: The program we have written will m...
by TerryV
Sun Feb 14, 2010 1:04 pm
Forum: C and ASM Programming
Topic: C2C "For"
Replies: 5
Views: 3063

C2C "For"

Hi, I am working through the "C4PICs" version 3 and example 1.4 uses the "For" loop with v3 development board. Whilst the program compiles and the assembler runs and the chip is programmed, the "For" loop does not appear to operate. The program just appears to stop. I h...
by TerryV
Tue Jan 19, 2010 1:23 am
Forum: C and ASM Programming
Topic: Source File Path Exceeds 62 Characters
Replies: 1
Views: 2187

Source File Path Exceeds 62 Characters

On trying to creat a New Project under the SourceBoost IDE all is well until I attempt to generate the assembly code where I get the following error Error [173] source file path exceeds 62 characters yet on checking back at the examples supplied the file path length appears to be compressed by use o...
by TerryV
Tue Jan 05, 2010 11:19 am
Forum: General Programming
Topic: Error
Replies: 4
Views: 1766

Re: Error

Problem solved .

Thanks Ben.

PPP V3.9 works fine.

Thanks

Cheers