Search found 62 matches

by patrick schoon
Thu Jan 23, 2020 9:21 pm
Forum: Bug Reports
Topic: Bad mistake in FC8!
Replies: 40
Views: 3326

Re: Bad mistake in FC8!

Hi, Today i experianced a FC8 bad start again. (Win-7 Pro) I did leave my PC with running FC8 overnight without working on it. I only switched off my monitors.. After switching on my monitors a did a safety backup of my project and closed FC8, all was well. Then i had to update my Qnap Qsync and res...
by patrick schoon
Sun Jan 19, 2020 5:09 pm
Forum: Flowcode V8
Topic: No internal EEProm with use of bootloader
Replies: 8
Views: 500

Re: No internal EEProm with use of bootloader

Hi, I solved my issues with the epprom by using replacing the eeprom macro by two C- macro's. A read macro named NVMRead and a write macro named NVMWrite. NVMRead.fcm NVMWrite.fcm Both macro's do use the Address Hi byte (0xF0 for eeprom) as well. Advantage to this is that also the User, Revision and...
by patrick schoon
Tue Jan 14, 2020 11:06 pm
Forum: Flowcode V8
Topic: No internal EEProm with use of bootloader
Replies: 8
Views: 500

Re: No internal EEProm with use of bootloader

Hi Ben, For now I did a read test by adding an address read commando in C. Test.jpg This works and to my suprise all values read by the eeprom macro are read as well. To check why, i only put the "NVMADRH = 0x70" in the C-code at the beginning of the sequence and the eeprom read function d...
by patrick schoon
Mon Jan 13, 2020 11:53 am
Forum: Flowcode V8
Topic: No internal EEProm with use of bootloader
Replies: 8
Views: 500

Re: No internal EEProm with use of bootloader

Hi Ben, I also checked the Microchip datasheets and Googled to find answers, but did not find satisfying answers. I programmed the eeprom for a few bytes with use of the MPlab IPE. Also these values are not read by the program. I made a LUT with the initial values for the eeprom. The eeprom is check...
by patrick schoon
Sat Jan 11, 2020 2:13 pm
Forum: Flowcode V8
Topic: No internal EEProm with use of bootloader
Replies: 8
Views: 500

Re: No internal EEProm with use of bootloader

Hi Christina, Thanks for your input. I'm aware of these data's. Hi Ben, I think this is the case. I compiled my project with compiler offset parameter "--codeoffset=0x700". Then i load my project with use of the bootloader into the project. Configuration bits are the same for bootloader an...
by patrick schoon
Wed Jan 08, 2020 9:14 pm
Forum: Flowcode V8
Topic: No internal EEProm with use of bootloader
Replies: 8
Views: 500

No internal EEProm with use of bootloader

Hi, In my project (PIC16F18857) i use the internal eeprom for storing parameters. All is working fine. Now I added a bootloader, starting 0x00-0x6FF. I shifted the application starting from 0x700. This is working except for the internal eeprom. I did some tests but all results are "0" when...
by patrick schoon
Wed Jan 08, 2020 9:08 pm
Forum: Flowcode V8
Topic: Flowcode 8 crash
Replies: 16
Views: 952

Re: Flowcode 8 crash

Hi, I have the same issue. As wel on Win7 as Win10. Just while working the software freeses and disapears. After restart of the pc and starting FC8 it popup and disapears the same time. Dead software A reinstall did not work.. Then deleted the FC8 in regedit and all words again. Settings gone.. Hope...
by patrick schoon
Sat Dec 28, 2019 1:22 pm
Forum: Flowcode V8
Topic: XC Compiler Pro mode
Replies: 10
Views: 678

Re: XC Compiler Pro mode

Hi Martin,

Yes I did change the batch file as suggested in the post link.

This is working in both cases. Old and new compiler.
If this works less well in V2.10 i can't say. I just don't have no experience in this field.
I can do some checks for you if you like..

Thanks.

PS
by patrick schoon
Sat Dec 28, 2019 12:09 pm
Forum: Flowcode V8
Topic: XC Compiler Pro mode
Replies: 10
Views: 678

Re: XC Compiler Pro mode

Hi Q,

I'm not into the options compilers do and don't have.
As a hardware engineer i only look at the results.

As you say, after installing the license the standard is going to a pro version. For me this does the job.

Thanks.

PS
by patrick schoon
Sat Dec 28, 2019 11:35 am
Forum: Flowcode V8
Topic: XC Compiler Pro mode
Replies: 10
Views: 678

Re: XC Compiler Pro mode

Hi Guys, Here some results from my experiences with using different XC8 compilers. At this moment i'm working on a small PIC project. At this moment it is using up to 95% of it's programm space with the standard Flowcode XC8 compiler. I also need to put in a bootloader, so i needed a compiler with m...
by patrick schoon
Sat Oct 19, 2019 1:14 pm
Forum: Bug Reports
Topic: Cosmetic name of Component is Property Variable
Replies: 0
Views: 742

Cosmetic name of Component is Property Variable

When editing the name of a Property in a component macro the Name in the component feet gets the property variable value and not the cosmetic name value..

Naamloos.png
Naamloos.png (23.13 KiB) Viewed 742 times
by patrick schoon
Mon May 27, 2019 8:50 pm
Forum: Flowcode V8
Topic: I2C problems with 16LF18857
Replies: 4
Views: 937

Re: I2C problems with 16LF18857

Hi Jan, I had the simular issues with a project i use the same 16F18857 MCU. Only software channel was working. Hardware channel 1 and 2 did not. Now i have updated FC8 to V8.2.0.12 and YES hardware channels are working now. I directly tested both channels (SDA to B4, SCL to B5) and all is working w...
by patrick schoon
Sun May 05, 2019 3:56 pm
Forum: Bug Reports
Topic: I2C 18F47K40
Replies: 14
Views: 2474

Re: I2C 18F47K40

Hi Guys,

I experiance the same problem with a PIC16F15356.

Software I2C is working but Ch1 and Ch2 are not.
FC8.1.1.11


Regards,

PS
by patrick schoon
Thu Apr 18, 2019 1:19 pm
Forum: 8-Bit PIC
Topic: ADC error
Replies: 3
Views: 890

Re: ADC error

Hi,

I Send it to you personal..
by patrick schoon
Thu Apr 18, 2019 12:41 pm
Forum: 8-Bit PIC
Topic: ADC error
Replies: 3
Views: 890

ADC error

Hi, I got several errors with using a second adc component. See listng: C:\Program Files (x86)\Flowcode 7\CAL\PIC\PIC_CAL_ADC.c: FC_CAL_ADC_Enable() 4786: ADREF = 0x00; ^ (192) undefined identifier "ADREF" 4801: ADPCH = 0x01; ^ (192) undefined identifier "ADPCH" 5038: ADCLK = Con...
by patrick schoon
Sat Dec 29, 2018 3:02 pm
Forum: User Components
Topic: ENC28J60 component remap does not work with PIC24FJ64GA
Replies: 1
Views: 1133

ENC28J60 component remap does not work with PIC24FJ64GA

Hi, I tried to use the TCP/IP ENC28J60 component in my PIC24FJ64GA (44pin) project. According to the PIC datasheet all SPI I/O is remappable. For the first channel I/O is fixed on port-B, except Reset and CS. The second channel is remappable but when selecting a pin the select tree is empty. Softwar...
by patrick schoon
Thu Dec 27, 2018 9:58 pm
Forum: Bug reports
Topic: PIC16F15355 Uart and ADC problem
Replies: 13
Views: 2369

Re: PIC16F15355 Uart and ADC problem

Sorry,

No results.

Attached my test file for check.
Test.fcfx
(24.23 KiB) Downloaded 69 times


Regards,

Patrick
by patrick schoon
Thu Dec 27, 2018 8:40 pm
Forum: Bug reports
Topic: PIC16F15355 Uart and ADC problem
Replies: 13
Views: 2369

Re: PIC16F15355 Uart and ADC problem

Hi Martin,

I did a quick test but no working results.
To be sure i deleted all timer2 components and reselected a new pwm component.
But no working output. Compiling does work..

Regards,

Patrick
by patrick schoon
Thu Dec 27, 2018 4:56 pm
Forum: Bug reports
Topic: PIC16F15355 Uart and ADC problem
Replies: 13
Views: 2369

Re: PIC16F15355 Uart and ADC problem

Hi Martin,

Many thanks in such short notice. :D

Both timers do compile and work on their own.
When used both (TMR1 and 2) they disturb each other, I get interupted pulses.. Proberly swatped some code...
Timer0 is ok.


Simple example in the attachment.
Test.fcfx
(22.84 KiB) Downloaded 79 times


Great help, thanks.

Patrick
by patrick schoon
Wed Dec 26, 2018 3:09 pm
Forum: Bug reports
Topic: PIC16F15355 Uart and ADC problem
Replies: 13
Views: 2369

Re: PIC16F15355 Uart and ADC problem

Hi Martin, All thumbs up. :D The ADC and both hardware uarts are working now. I still get compiling errors when using timer 1 and 2, timer 0 is working well. Proberly this is also the issue why the pwm is not working. Pwm is only using timer2. Pwm ch 1 and 2 can be compiled but no working results, 3...
by patrick schoon
Sun Dec 23, 2018 5:36 pm
Forum: Bug reports
Topic: PIC16F15355 Uart and ADC problem
Replies: 13
Views: 2369

Re: PIC16F15355 Uart and ADC problem

Hi Martin,

Thanks for the quick support.

I Can't find the latest 7.3.0.7 online!
But you may send me the two patch files.
I know how it works.

Thanks.
by patrick schoon
Thu Dec 20, 2018 7:54 pm
Forum: Bug reports
Topic: PIC16F15355 Uart and ADC problem
Replies: 13
Views: 2369

PIC16F15355 Uart and ADC problem

Hi, My project with PIC16F15355 has a problem with the Hardware uart. I get an undefined identifier error at compiling the project. Title: Description: Device: PIC.16F.16F15355 Generated by: Flowcode v7.3.0.5 Date: Thursday, December 20, 2018 19:34:08 Users: 1 Registered to: ps Licence key: X7-- htt...
by patrick schoon
Tue Sep 11, 2018 10:24 pm
Forum: Bug reports
Topic: I2C2 not fully working on PIC24EP512GU810
Replies: 1
Views: 1030

I2C2 not fully working on PIC24EP512GU810

Hey guys, In my FC6 project i use I2C1 port as well the I2C2 port. I2C1 (channel1) port is working well, I2C2 not. When Initializing the I2C2 (channel2) port at startup It blocks the alternative outputs ASCL2 and ASDA2 and no data from the Main SCL2/SDA2 port. Experimenting with the fuse bit setting...
by patrick schoon
Wed Jun 20, 2018 7:16 pm
Forum: Bug reports
Topic: Compiler error PIC24FJ128GA204 and 24EP512GU810
Replies: 3
Views: 1614

Re: Compiler error PIC24FJ128GA204 and 24EP512GU810

Guys,

Thanks for the quick help.

The workaround of re-installing and the register modification did work. All fine now. :D
by patrick schoon
Tue Jun 19, 2018 8:30 pm
Forum: Bug reports
Topic: Compiler error PIC24FJ128GA204 and 24EP512GU810
Replies: 3
Views: 1614

Compiler error PIC24FJ128GA204 and 24EP512GU810

Hi, Please check the compiler support for the PIC128GA204 and PIC24EP512GU810. On both i get an error. No complex data writen, just a blinking led in a loop.. Launching the compiler... C:\Program Files (x86)\Flowcode 7\compilers\pic16\batchfiles\pic16_C30_comp.bat "test" "D:\ELECTR~1\...