Search found 28 matches

by D.Bouchier
Fri Jan 28, 2011 10:34 am
Forum: E-blocks
Topic: PWM frequency
Replies: 3
Views: 2482

Re: PWM frequency

That could be the problem, i already solved it by using timer0, but i did not know why it solved it. i thought pwm was controlled by timer1, thanks anyway
by D.Bouchier
Thu Jan 27, 2011 2:55 pm
Forum: E-blocks
Topic: PWM frequency
Replies: 3
Views: 2482

PWM frequency

Hi, A nother problem, a nother topic... My Ecio-40 is programmed for PWM, in the prooerties menu is written that it is +/- 48kHz, but when i meassure it, it's 3kHz. Any idea what can cause this, more important, how to solve this? When i'm controlling a motor with it, it makes a high beep, probably ...
by D.Bouchier
Thu Jan 27, 2011 8:21 am
Forum: E-blocks
Topic: CCP pins + Vreg broken?
Replies: 4
Views: 2533

Re: CCP pins + Vreg broken?

Thanks for the expanded response, I replaced the L293D in a manner that i can't even tell anymore which one i replaced, so it had exactly the same name, i blew up the original one with the same motor, but switching it on/off too fast and frequently. I was supplying from the baseboard with the termin...
by D.Bouchier
Wed Jan 26, 2011 3:18 pm
Forum: E-blocks
Topic: CCP pins + Vreg broken?
Replies: 4
Views: 2533

Re: CCP pins + Vreg broken?

Hi, I don't think I clearly told you my set-up. I was driving the motor with the power E-block EB011. So I would think the CCP pin did not draw alot of current, just to put the signal to the IC of the EB011. My regulator is the one on the EB061 (ECIO base board) and considering i was using 12V, it d...
by D.Bouchier
Wed Jan 26, 2011 1:18 pm
Forum: E-blocks
Topic: CCP pins + Vreg broken?
Replies: 4
Views: 2533

CCP pins + Vreg broken?

Hello, I think i like to break stuff because i have yet again a fault in my hardware. i was operating a 12 watt motor 12v/1amp, with pwm ccp1 and after some time the motor kept bieing in the on state. So i grabed my multimeter and checked the voltages. CCP1/RC2 was +5V, CCP2/RC1 was 0V and the outpu...
by D.Bouchier
Tue Jan 25, 2011 10:22 am
Forum: E-blocks
Topic: LCD eb-005
Replies: 2
Views: 1867

LCD eb-005

Hi, My lcd screen of my EB-005 is broken and i wanted to replace it, but i cant desolder the original lcd, i used a 450 degrees hot rod and a suction pen, some minutes later, the only thing that has gotten desoldered are bits of my skin and part of my patience. How on earth do i get these things of?...
by D.Bouchier
Tue Jan 25, 2011 9:26 am
Forum: Flowcode V2 & V3
Topic: PPPv3 18f4550
Replies: 3
Views: 3289

PPPv3 18f4550

Hello, im having problems programming some microcontrollers with Flowcode, I bought flowcode v4, but to post there, you have to sign up, which is in progress, but i need the help today. When i programm my MIAC or ECIO-40 it all goes well, but when i try to even compile a piece of software for a 18f4...
by D.Bouchier
Thu Jan 20, 2011 9:12 am
Forum: Programming Tips & Tricks
Topic: Using the FlowKit ICD Tool
Replies: 29
Views: 52596

Re: Using the FlowKit ICD Tool

Ok, I managed to make this work with the pre-made .exe :D Now I would like to take it a step further and build my own GUI to control my ECIO-40 while it is running. To keep it clear, ill divide my question in 3 parts: 1. What program is suitable (easy to understand, able to make this usb connection)...
by D.Bouchier
Wed Jan 19, 2011 1:01 pm
Forum: Programming Tips & Tricks
Topic: Using the FlowKit ICD Tool
Replies: 29
Views: 52596

Re: Using the FlowKit ICD Tool

So if I programm the example in my ecio-40 and run the .exe I should be able to send characters to my LCD by typing them in the .exe and press transmit? Also, in the example there is a macro called "service_macro" but i dont see where it is called, could you explain this, or is there a tex...
by D.Bouchier
Wed Jan 19, 2011 12:06 pm
Forum: Programming Tips & Tricks
Topic: Using the FlowKit ICD Tool
Replies: 29
Views: 52596

Re: Using the FlowKit ICD Tool

Hi, thanks for the respons.

I have an ECIO-40 with flowcode v4, but i can't find a good example of what you are talking about, can you send a link to what you mean?
by D.Bouchier
Wed Jan 19, 2011 11:02 am
Forum: Programming Tips & Tricks
Topic: Using the FlowKit ICD Tool
Replies: 29
Views: 52596

Re: Using the FlowKit ICD Tool

Hello, is it possible to use the HP299 as a "virtual controll unit" from your pc to the target? So that if i simulate my program and press a button on the screen, my targets executes the task assigned to that button (ofcourse the task would have to be programmed and the button has to be re...
by D.Bouchier
Tue Dec 07, 2010 9:44 am
Forum: C and ASM Programming
Topic: ECIO+LCDportA+Analoge+pull-up
Replies: 5
Views: 4675

Re: ECIO+LCDportA+Analoge+pull-up

Hello again, I have been progressing with this project and stumbled on new found problems closely related to my previous one. I got the LCD working on portA I got the pull-ups working on portB I got the ADC channels 10,11 and 12 (on portB) working But the other ADC channels on this port always retur...
by D.Bouchier
Fri Nov 19, 2010 1:11 pm
Forum: C and ASM Programming
Topic: ECIO+LCDportA+Analoge+pull-up
Replies: 5
Views: 4675

Re: ECIO+LCDportA+Analoge+pull-up

"What is happening when you try to use both together? Is the LCD failing or is it the pull ups?"

It where the pull-ups that where not working.

With intcon2 = intcon2 & 0x7F; it works as intended, thank you very much
by D.Bouchier
Wed Nov 17, 2010 11:49 am
Forum: C and ASM Programming
Topic: ECIO+LCDportA+Analoge+pull-up
Replies: 5
Views: 4675

Re: ECIO+LCDportA+Analoge+pull-up

Anyone feels like having thew knowledge to help me out here?
by D.Bouchier
Thu Nov 11, 2010 9:56 am
Forum: C and ASM Programming
Topic: ECIO+LCDportA+Analoge+pull-up
Replies: 5
Views: 4675

ECIO+LCDportA+Analoge+pull-up

Weird titel... What I mean is; Im using a ECIO40 (18f4455) with application board, LCD E-block on port A, I want to use analoge inputs aswell as digital inputs with internal pull-up resistors on portB. Now there are some problems: I know you have to make "adcon0 = 0x30;" in order for the L...
by D.Bouchier
Wed Nov 10, 2010 7:59 am
Forum: E-blocks
Topic: EB011 Explosion
Replies: 3
Views: 2034

Re: EB011 Explosion

Hi Benj, Thanks for the response, would it also be possible to replace the L293D with a L293NE? This one seems to be able to supply more current then the L293D. Greetings. edit: after some more research I found out that the L293D already has diodes to protect the outputs, so now I don't understand h...
by D.Bouchier
Tue Nov 09, 2010 10:19 am
Forum: E-blocks
Topic: EB011 Explosion
Replies: 3
Views: 2034

EB011 Explosion

Ok, not really an explosion, but there was some smoke... I was driving a DC motor (too powerful) with PWM on 2 different EB011 boards for testing reasons, after switching direction a couple of times repeatedly, the L293D chip which was driving with PWM started to smoke and pretty much died. I knew t...
by D.Bouchier
Thu Oct 21, 2010 12:54 pm
Forum: E-blocks
Topic: EB022 and EB011 board questions
Replies: 6
Views: 2723

Re: EB022 and EB011 board questions

I'm starting to wonder if this application is even possible, because I'm not sure if there is a Microcontroller that can support all these's E-blocks. Some advice on that please?

ps. there is also a LCDscreen needed in this application, not mentioned before.
by D.Bouchier
Thu Oct 21, 2010 7:59 am
Forum: E-blocks
Topic: EB022 and EB011 board questions
Replies: 6
Views: 2723

Re: EB022 and EB011 board questions

Thank you very much for the answers and suggestions, I got it figured out now quite well with your help.
Greetings
by D.Bouchier
Tue Oct 19, 2010 11:19 am
Forum: MIAC
Topic: CAN-bus bug or intended?
Replies: 2
Views: 3266

Re: CAN-bus bug or intended?

Ok, I cannot seem to reproduce this, then probably something else was the problem, something I fixed earlier.

Sorry for the inconvenience.

ps. just delete this thread then...
by D.Bouchier
Tue Oct 19, 2010 11:15 am
Forum: E-blocks
Topic: EB022 and EB011 board questions
Replies: 6
Views: 2723

EB022 and EB011 board questions

I was looking for e-boards to drive these 12V DC motors: -Bi-directional 1A -2 single direction 2A each -Bi-directional 100mA -3 PWM-single-direction 500mA -single-direction 100mA and a 230V heating element I also need about 3 inputs (2 analoge and 1 digital) Looking at these values I need atleast 1...
by D.Bouchier
Tue Oct 19, 2010 9:18 am
Forum: MIAC
Topic: CAN-bus bug or intended?
Replies: 2
Views: 3266

CAN-bus bug or intended?

Hello, I was testing a little bit with the CAN-bus on the MIAC and discovered that if you reset the variable that is used as return value for CheckRx at the start of your programm (after CANinit, before the main loop) that the interface does not work. I have the urge to define all variables in start...
by D.Bouchier
Tue Oct 19, 2010 8:48 am
Forum: MIAC
Topic: Flowcode 4 / Miac compile error
Replies: 4
Views: 4590

Re: Flowcode 4 / Miac compile error

Sure you can ask me and I will do my best to anwer :)
by D.Bouchier
Fri Oct 15, 2010 1:30 pm
Forum: MIAC
Topic: Flowcode 4 / Miac compile error
Replies: 4
Views: 4590

Re: Flowcode 4 / Miac compile error

Hi Medelec,

thank you very much, this explains all my misunderstanding with strings. I have programmed in C before with strings, that's why i found it odd i could not assign them like that, but i see you can, i just need a different flowchart icon.
thanks alot!