Search found 30 matches

by jethronull
Thu Aug 15, 2013 6:47 pm
Forum: Flowcode v6 Beta
Topic: Can Download but Not Install
Replies: 8
Views: 4665

Re: Can Download but Not Install

Carl, Added it as a bug report as requested. My install directory is also setup as a Google Drive so I suspect there is something about that which is odd. Though I have to say I have had many other apps downloaded and installed from there with no issue. If there is any other detail you could use or ...
by jethronull
Wed Aug 14, 2013 11:23 pm
Forum: Flowcode v6 Beta
Topic: Can Download but Not Install
Replies: 8
Views: 4665

Re: Can Download but Not Install

My download was 164,350KB which seems right from what everyone has said. And I used Chrome. But I tried Wolfgang's trick of moving the installer to the root, and that worked. Never had that happen before and I've a LOT of downloads all of which normal install from my download directory. So, not a co...
by jethronull
Wed Aug 14, 2013 6:21 pm
Forum: Flowcode v6 Beta
Topic: Can Download but Not Install
Replies: 8
Views: 4665

Can Download but Not Install

The initial installation dialogue, user agreement stuff starts but as soon as the installation proper starts a Windows error says something like "Error reading from file.... "Verify that the files exists and that you can access it. Tried downloading it again incase it was corrupt, but got ...
by jethronull
Mon Jul 22, 2013 9:25 pm
Forum: Flowcode V5 Issues
Topic: Still Having problems with Uarts
Replies: 2
Views: 3010

Re: Still Having problems with Uarts

Mea Culpa ! I found the problem, not software at all. The power supply section had the wrong chip which wasn't delivering the required current which allowed the rails to be pulled down when the RF module received a message (which went to the PIC). Sorry guys, should have tested the hardware first. B...
by jethronull
Sun Jul 21, 2013 8:49 pm
Forum: Flowcode V5 Issues
Topic: Still Having problems with Uarts
Replies: 2
Views: 3010

Still Having problems with Uarts

Hi Guys, Looking back over posts for problems with Uarts seems like I posted half of them. I did finally get things stable and workable, but I have changed the schematic a little, just changed pins definitions and increased to larger processor in the same family. Now I have serial issues again. The ...
by jethronull
Wed Apr 24, 2013 12:54 am
Forum: Flowcode V5 Issues
Topic: Worrying Weirdness
Replies: 7
Views: 4323

Re: Worrying Weirdness

Ben,

Any luck finding a bug in my hex2int function?

Jon
by jethronull
Fri Apr 19, 2013 7:22 pm
Forum: Flowcode V5 Issues
Topic: Worrying Weirdness
Replies: 7
Views: 4323

Re: Worrying Weirdness

Hi Ben, My project is so wrapped up in external data sources, interfaces and so on it is not easy to simulate anymore, even with VNet (if you added a means to feed serial data in and out of the simulation from the PC serial port so that the simulation can talk to real world devices - that would be s...
by jethronull
Fri Apr 19, 2013 4:07 pm
Forum: Flowcode V5 Issues
Topic: Worrying Weirdness
Replies: 7
Views: 4323

Re: Worrying Weirdness

Thanks Kersing. That is probably it, though I had assumed Flowcode took care of that. It seems to in other instances. Anyway, I'll give all my strings at least one extra byte to be on the safe side. Thanks!
by jethronull
Fri Apr 19, 2013 8:13 am
Forum: Flowcode V5 Issues
Topic: Worrying Weirdness
Replies: 7
Views: 4323

Re: Worrying Weirdness

Jonny, You got it! I found a string variable that was set to only 2 bytes long and which was actually used just prior to passing data to the routine I sent you. I just set it to 20 chars long and the problem went away (I could delete the padding variable). But I am curious as to how it overran: Byte...
by jethronull
Thu Apr 18, 2013 8:27 pm
Forum: Flowcode V5 Issues
Topic: Worrying Weirdness
Replies: 7
Views: 4323

Worrying Weirdness

I got past all the RS232 weirdness and my project has grown greatly without issue. I took Ben's advice and stripped as much code as I can out of the RS232 interrupts. That worked well. Much time past without issue but today I found a new gremlin, or maybe it's the same old one. With some very minor ...
by jethronull
Sat Mar 23, 2013 12:25 am
Forum: Flowcode V5
Topic: Possible SW Stack Corruption
Replies: 2
Views: 969

Re: Possible SW Stack Corruption

Since using ReceiveRS232String only seems to work with ASCII data I can't use that (am I correct about that or am I missing something?). Could I cycle round ReceiveRS232Char feeding the incoming bytes into a int array? Then deal with the processing outside the interrupt. Or would I need to take one ...
by jethronull
Sat Mar 23, 2013 12:16 am
Forum: Flowcode V5
Topic: Internal VREF in 18F25K22
Replies: 2
Views: 1062

Re: Internal VREF in 18F25K22

Ben,

Perfect, that worked a treat. Duh me. binary without 0b!. But I wouldn't have known to do the while bit for settling.

Thanks a lot.
by jethronull
Fri Mar 22, 2013 3:03 am
Forum: Flowcode V5
Topic: Possible SW Stack Corruption
Replies: 2
Views: 969

Possible SW Stack Corruption

I've had a few of these warnings rush past without me noticing them till recently. Specifically I am getting: Serious Warning: Possible sw stack corruption, function 'FCI_GETLENGTH' called by more than one asynchronous thread (main/Task, interrupt, interrupt low) Serious Warning: Possible sw stack c...
by jethronull
Fri Mar 22, 2013 2:51 am
Forum: Flowcode V5
Topic: Internal VREF in 18F25K22
Replies: 2
Views: 1062

Internal VREF in 18F25K22

I read a couple of posts where people enquired about using the internal vrefs of various PICs and it seemed that it just needs a register appropriately set to take over from the standard ADC macro which is limited to VDD and the external VREF+. I could not find any reference to my PIC (18F25K22) on ...
by jethronull
Thu Mar 21, 2013 8:24 pm
Forum: Flowcode V5 Issues
Topic: More Problems with RS232 and PIC18F25K22
Replies: 8
Views: 4787

Re: More Problems with RS232 and PIC18F25K22

Ben, Still experiencing a lot of weirdness both from the code and Flowkit. Attached is a recent revision of my project. As long as I run a fast enough clock (I am using either 8Mhz xtal and 4xPLL or a 16Mhz xtal, both versions seem to work OK, or at least 16Mhz with 4xPLL does not fix any further pr...
by jethronull
Wed Mar 20, 2013 5:20 am
Forum: Flowcode V5 Issues
Topic: More Problems with RS232 and PIC18F25K22
Replies: 8
Views: 4787

Re: More Problems with RS232 and PIC18F25K22

OK, I tried to run it with an internal osc but could not get it to work at all. I reverted to the 8Mhz crystal and applied the 4xPLL, and what d'ya know, the RS232 started working properly. I had tried the 4xPLL before with no success. Not sure what I did differently but, hey, it works now. RX and T...
by jethronull
Tue Mar 19, 2013 2:50 pm
Forum: Flowcode V5 Issues
Topic: More Problems with RS232 and PIC18F25K22
Replies: 8
Views: 4787

Re: More Problems with RS232 and PIC18F25K22

That was the first thing I tried and should be off in the file I sent you. Though I do wonder if maybe the code does things that don't entirely match the flowchart. Yesterday I also tried using software option in the RS232 options, just to see if anything changed, it didn't, not at all. That suggest...
by jethronull
Tue Mar 19, 2013 3:03 am
Forum: Flowcode V5 Issues
Topic: More Problems with RS232 and PIC18F25K22
Replies: 8
Views: 4787

Re: More Problems with RS232 and PIC18F25K22

If anybody reading this has good experience with PIC's, C code, Flowcode and thinks they could help with this problem, I am willing to pay to get this problem resolved quickly. There will also be some significant follow on work for which I am looking for an experienced embedded coder. Let me know.
by jethronull
Mon Mar 18, 2013 5:58 pm
Forum: Flowcode V5 Issues
Topic: More Problems with RS232 and PIC18F25K22
Replies: 8
Views: 4787

Re: More Problems with RS232 and PIC18F25K22

Thanks Benj, your help is much appreciated. Yes, the config was set up wrong. In desperation I'd been playing with these and had neglected to put it back to HS and turn off 4xPLL before I sent the file to you. With HS and no 4xPLL I get the first 20 chars or so correctly, the rest are wrong and not ...
by jethronull
Mon Mar 18, 2013 4:52 am
Forum: Flowcode V5 Issues
Topic: More Problems with RS232 and PIC18F25K22
Replies: 8
Views: 4787

More Problems with RS232 and PIC18F25K22

I seem to have the same problem with as a previous poster with RS232 on an 18F25K22, I checked my FCD file and it is the same as the new one provided in that post. I can transmit but not receive. Simulation using VNet works fine in both directions. I also can prove that data is getting to the PIC, t...
by jethronull
Sun Feb 10, 2013 9:14 pm
Forum: General Programming
Topic: Compare$(String1,String2,0)
Replies: 4
Views: 1631

Re: Compare$(String1,String2,0)

I have a similar problem. In my case I get 32 as a result if the case sensitivity is set to 1 and 255 when 0. And this is with two input strings that are equal but not case identical. Just checked my version which is the latest (5.5). Replacing the string variables with literals of the same values w...
by jethronull
Sat Feb 09, 2013 2:56 am
Forum: Flowcode V5
Topic: RS232 Interupts
Replies: 15
Views: 5301

RS232 Interupts

The help file for creating interupts suggests that a custom interupt must be created for PIC uarts using: Enable code: intcon.PEIE = 1; // Enable peripheral interrupts intcon.GIE = 1; // Enable global interrupts pie1.RCIE = 1; // Enable USART receive interrupts Disable code: pie1.RCIE = 0; // Disabl...
by jethronull
Wed Dec 19, 2012 12:00 am
Forum: Flowcode V5
Topic: UARTS in ATXMega's
Replies: 11
Views: 2548

Re: UARTS in ATXMega's

Hi Ben,

I don't suppoed you've had a chance to check into the xmega baud rate weirdness yet?

Jon/JethroNull
by jethronull
Fri Dec 07, 2012 11:13 pm
Forum: Flowcode V5
Topic: UARTS in ATXMega's
Replies: 11
Views: 2548

Re: UARTS in ATXMega's

Ben, OK, I've scoped the output. The pulse period at 9600 baud looks like about 100uS maybe slightly less. So somewhere between 9800 and 10000. Set to 38400 the period is about 23.7uS so around 42200 baud (10% error). With this information I programmed the chip for 38400 baud but set the terminal pr...
by jethronull
Fri Dec 07, 2012 5:35 pm
Forum: Flowcode V5
Topic: UARTS in ATXMega's
Replies: 11
Views: 2548

Re: UARTS in ATXMega's

Ben, You're quite correct, the string was set to only 20 chars, my boo boo. I had previously set it longer when trying other baud rates and somehow it got reset to 20 for this last test and I didn't notice. So you've easily solved that one. But, still there are problems. Using the echo example, I ge...