Search found 18 matches

by Dr T JONES
Sat May 11, 2019 7:59 am
Forum: E-blocks
Topic: Trouble using BL0080 with mloader 4.001 same situation as danwest01
Replies: 1
Views: 691

Trouble using BL0080 with mloader 4.001 same situation as danwest01

I have tried to download a program into the board with the supplied 16F18877 and it doesn't detect the boards connected. I've tried to delete drivers and reinstall but no luck.
by Dr T JONES
Fri May 10, 2019 11:52 pm
Forum: E-blocks
Topic: Trouble using an EB-006-00-9 Board with mLoader V4.0.0.1
Replies: 6
Views: 794

Re: Trouble using an EB-006-00-9 Board with mLoader V4.0.0.1

Did you resolve the problem? I have exactly the same issue with the same images of files etc you had but am using a new eblocks2 Bl0080 board
by Dr T JONES
Fri Aug 01, 2014 9:51 am
Forum: E-blocks
Topic: Damaged EB006- 8 board ?
Replies: 14
Views: 4541

Re: Damaged EB006- 8 board ?

Ok thanks.
by Dr T JONES
Mon Jul 28, 2014 12:42 pm
Forum: E-blocks
Topic: Damaged EB006- 8 board ?
Replies: 14
Views: 4541

Re: Damaged EB006- 8 board ?

Yes i do this every time i programme a PIC chip, tried again now with no success.

As i say the chip is programmed correctly as it works on my own testing breadboard circuit, just won't work with EB006-8 and EB083.
by Dr T JONES
Mon Jul 28, 2014 10:18 am
Forum: E-blocks
Topic: Damaged EB006- 8 board ?
Replies: 14
Views: 4541

Re: Damaged EB006- 8 board ?

Heres the ASM file.
by Dr T JONES
Mon Jul 28, 2014 10:13 am
Forum: E-blocks
Topic: Damaged EB006- 8 board ?
Replies: 14
Views: 4541

Re: Damaged EB006- 8 board ?

Here's the test programme i'm using. Like i say it programmes the chip ok but no output when using EB006-8 and EB083. When i use my own test circuit the chip works as it should. ;******************************************************************* ; TITLE: New 16F88 project ; AUTHOR: ; DATE: ;*******...
by Dr T JONES
Fri Jul 25, 2014 11:49 am
Forum: E-blocks
Topic: Damaged EB006- 8 board ?
Replies: 14
Views: 4541

Re: Damaged EB006- 8 board ?

Have tried 2 or three other chips without any luck. As I said it programmes the chips ok but when testing on the EB006-8 board no outputs visible on all the output boards I've tried. When i check the chips on my other PIC testing circuits the chip works well after being programmed on the EB006-8 boa...
by Dr T JONES
Thu Jul 24, 2014 9:50 am
Forum: E-blocks
Topic: Damaged EB006- 8 board ?
Replies: 14
Views: 4541

Re: Damaged EB006- 8 board ?

Vdd ok

Tried everything suggested without any luck.

Will have to send EB006-8 back to Matrix again!
by Dr T JONES
Mon Jul 21, 2014 9:10 pm
Forum: E-blocks
Topic: Damaged EB006- 8 board ?
Replies: 14
Views: 4541

Re: Damaged EB006- 8 board ?

Im using C and assembler programmes not FLOWCODE.
by Dr T JONES
Mon Jul 21, 2014 9:08 pm
Forum: E-blocks
Topic: Damaged EB006- 8 board ?
Replies: 14
Views: 4541

Re: Damaged EB006- 8 board ?

The programmes work correctly on both as i have a different PIC board and both chips work with the programmes.

My problem is i can't test them anymore using the EB006-8 board and the output boards connected.
by Dr T JONES
Sat Jul 19, 2014 11:26 am
Forum: E-blocks
Topic: Damaged EB006- 8 board ?
Replies: 14
Views: 4541

Damaged EB006- 8 board ?

EB006 - 8 was working well with PIC16F88 then i changed the chip to 18F452 and tried programming this with certain new programmes without any success. I then swapped the chip back to the 16F88 and i can programme the chip (as checked on a breadboard) but PORTA and PORTB not working when connected to...
by Dr T JONES
Sun May 25, 2014 11:06 am
Forum: E-blocks
Topic: Getting Keypad EB014 working with Assembler
Replies: 1
Views: 1564

Re: Getting Keypad EB014 working with Assembler

After reading the datasheet for the PIC16F88 realised i hadn't set PORTA bits as digital inputs not analogue or CCP inputs, which isn't an issue with the PIC16F84.

All working now.
by Dr T JONES
Sun May 25, 2014 10:59 am
Forum: E-blocks
Topic: EB006 00 8 Programming Problems
Replies: 9
Views: 3518

Re: EB006 00 8 Programming Problems

Turns out the board was faulty, i have a replacement board now and all seems fine so far. Just hope this keeps working !!
by Dr T JONES
Thu Apr 24, 2014 1:09 pm
Forum: E-blocks
Topic: EB006 00 8 Programming Problems
Replies: 9
Views: 3518

Re: EB006 00 8 Programming Problems

Luckily we have two EB006 008 boards at the one site in college and have found one works fine but the other can not detect any chips and when you try and programme gives config 1 error. When i change the board to the other EB006 008 using the same chip and programme it works fine. I will call the co...
by Dr T JONES
Fri Apr 04, 2014 7:56 pm
Forum: E-blocks
Topic: EB006 00 8 Programming Problems
Replies: 9
Views: 3518

EB006 00 8 Programming Problems

We are having multiple problems with the two EB006 00 8 boards that we have, when we are trying to programme PIC chips 16F628A, 16F88 and 16F84 mainly. Multitude of problems from can not detect the chips, 'programming failed', 'no usb cable detected' even when it is connected. The confusing thing is...
by Dr T JONES
Tue Jan 28, 2014 3:03 pm
Forum: E-blocks
Topic: Getting Keypad EB014 working with Assembler
Replies: 1
Views: 1564

Getting Keypad EB014 working with Assembler

I have written an assembler program as per the PDF Keyboard Assembly Strategy on Matrixmultimedia website and only the first two keys for each column work i.e. 1, 4 or 2, 5 etc. I Set portB bit 0 and clear portB bits 1 and 2, then test using BTFSS PORTB,4 then 5,6 ,7 and if any are on output a numbe...
by Dr T JONES
Mon Oct 21, 2013 10:01 pm
Forum: E-blocks
Topic: Testing a programme with ZIF Add on Board
Replies: 2
Views: 1830

Re: Testing a programme with ZIF Add on Board

Ok thanks, pity this function isn't available.
by Dr T JONES
Mon Oct 21, 2013 3:13 pm
Forum: E-blocks
Topic: Testing a programme with ZIF Add on Board
Replies: 2
Views: 1830

Testing a programme with ZIF Add on Board

Just received new PIC Micro starter pack and have a ZIF Add on board connected to the EB006 Multiprogrammer. I can programme the PIC16F88 chip using the ZIF add on board but the programme does not run afterwards, untill i remove the PIC chip from the ZIF add on and remove the ZIF and put the chip di...