Search found 28 matches

by gonzogonzo
Sun Nov 10, 2019 10:18 am
Forum: Flowcode V8
Topic: Internal clock setting
Replies: 2
Views: 59

Re: Internal clock setting

Hi Benj,
thanks a lot for your reply !
by gonzogonzo
Fri Nov 08, 2019 5:28 pm
Forum: Flowcode V8
Topic: Internal clock setting
Replies: 2
Views: 59

Internal clock setting

Hi,
a short question: how setting internal clock frequency in a PIC like 16F887 or similar using flowcode?
Thanks
by gonzogonzo
Tue Aug 27, 2019 11:26 am
Forum: Flowcode V8
Topic: Help with ESP8266 TCP server and HTML
Replies: 8
Views: 548

Re: Help with ESP8266 TCP server and HTML

Hello LeighM,
yes this is the suggestion that served my purpose; now I understand how to use html together into Flowcode. A proper thanks to you and also to viktor_au goes for help me.
by gonzogonzo
Mon Aug 26, 2019 2:13 pm
Forum: Flowcode V8
Topic: Help with ESP8266 TCP server and HTML
Replies: 8
Views: 548

Re: Help with ESP8266 TCP server and HTML

Hi, I also am not sure I have understood what you are saying (as I have already told you I am not an expert in terms of networks and protocols: I just wanted to try to create a circuit to access with WIFI and PC); however I attach the program (I made some visual improvements in index.htm but it does...
by gonzogonzo
Mon Aug 26, 2019 10:21 am
Forum: Flowcode V8
Topic: Help with ESP8266 TCP server and HTML
Replies: 8
Views: 548

Re: Help with ESP8266 TCP server and HTML

Hello viktor_au, I have to apologize because I didn't post html of all the pages; I do it now. Summing up, everything works except the textbox part if I try to use parameters other than parameter 0; the strange thing is that the lines above the textbox part work and this makes me think of something ...
by gonzogonzo
Sun Aug 25, 2019 3:10 pm
Forum: Flowcode V8
Topic: Help with ESP8266 TCP server and HTML
Replies: 8
Views: 548

Re: Help with ESP8266 TCP server and HTML

I managed to make it work but only if I use the zero parameter with the others not; I attach html because it probably causes the malfunction; if anyone can help me ... Cattura.PNG <html> <head> <title>ESP8266 - DHT22: impostazioni</title> <style> body { background-color: black; text-align: center; c...
by gonzogonzo
Sun Aug 25, 2019 10:03 am
Forum: Flowcode V8
Topic: Help with ESP8266 TCP server and HTML
Replies: 8
Views: 548

Help with ESP8266 TCP server and HTML

Hello,
I'm trying to use ESP8266 as a TCP AP server and everything works but I have a problem with assigning the value of a textbox to a required parameter (use of GetInValue(x)) in html (I'm not an expert in this) in Flowcode; does anyone have a small example?
Thanks in advance
by gonzogonzo
Thu Apr 18, 2019 1:01 pm
Forum: Flowcode V8
Topic: DHT11 not measuring, SampleSensor stays '1' and show no reply on LCD
Replies: 21
Views: 1858

Re: DHT11 not measuring, SampleSensor stays '1' and show no reply on LCD

Hello Benj, after some short test i have DHT22 working with FREE compiler (2.X) and slower clock frequency at 11MHz (nops = 10); with PRO compiler (1.4x) working with slower frequency at 10MHz (nops= 24). Interesting option nops but i think that some delay_us at slower frequency are not possible wit...
by gonzogonzo
Wed Apr 17, 2019 3:44 pm
Forum: Flowcode V8
Topic: DHT11 not measuring, SampleSensor stays '1' and show no reply on LCD
Replies: 21
Views: 1858

Re: DHT11 not measuring, SampleSensor stays '1' and show no reply on LCD

Hi Benj,

sorry but i have think that You have working also in DHT22 and not only DHT11 and my test are only for DHT22; in any case, for DHT22, there is a dipendence from compiler version and from PIC clock to see working or not DHT22.

Thank again for your patience and for my poor english.
by gonzogonzo
Wed Apr 17, 2019 1:50 pm
Forum: Flowcode V8
Topic: Little problem with component bar
Replies: 2
Views: 432

Re: Little problem with component bar

Hi Benj,

when i see new version tell You my impression.

Thanks
by gonzogonzo
Wed Apr 17, 2019 1:48 pm
Forum: Flowcode V8
Topic: DHT11 not measuring, SampleSensor stays '1' and show no reply on LCD
Replies: 21
Views: 1858

Re: DHT11 not measuring, SampleSensor stays '1' and show no reply on LCD

Hi Benj,

after a quick test for me DHT22 NOT working if clock under 32MHz now also in PRO version XC8 (before working in PRO with 20MHz).

Thanks
by gonzogonzo
Wed Apr 17, 2019 7:38 am
Forum: Flowcode V8
Topic: Little problem with component bar
Replies: 2
Views: 432

Little problem with component bar

Hello, I have a small problem in Flowcode 8: after doing some updates, without having noticed anything, I saw that some of the usual groups have disappeared from the component bar. I couldn't figure out if it's something wanted or if something happened; Is there a way to return to view all component...
by gonzogonzo
Mon Apr 15, 2019 2:44 pm
Forum: Flowcode V8
Topic: UDP and SCADA
Replies: 0
Views: 294

UDP and SCADA

Hello,

is possible using SCADA for send and receving data over UDP? There is a very little example if it is possible?

Thanks in advance
by gonzogonzo
Mon Apr 15, 2019 2:38 pm
Forum: Flowcode V8
Topic: DHT11 not measuring, SampleSensor stays '1' and show no reply on LCD
Replies: 21
Views: 1858

Re: DHT11 not measuring, SampleSensor stays '1' and show no reply on LCD

Hello, In my experience with Flowcode there is a problem with DHT11 and DHT22: the operation is ok only with high clock frequencies (32MHz or higher). This problem is evident with the free version of the XC8 compiler as artificial delays are introduced that make it impossible to read the data correc...
by gonzogonzo
Sun Jul 15, 2018 9:34 am
Forum: Flowcode V7
Topic: GLCD with touch
Replies: 19
Views: 2362

Re: GLCD with touch

Hi medelec35 and Benj, sorry for my reply delay but i am not at home; my hardware use gLCD Ili9341 320X240 and touch XPT2046 and now i have made a prototype (with PIC) that work very well with software write in Flowcode V7 (only a little problem with touch solved with a sorte of antidebounce). Probl...
by gonzogonzo
Tue Jul 10, 2018 4:08 pm
Forum: Flowcode V7
Topic: GLCD with touch
Replies: 19
Views: 2362

Re: GLCD with touch

medelec35 wrote:I see what you mean,
I could not get the touch side to simulate either.

Thanks medelec35,
i am working on prototype...
by gonzogonzo
Mon Jul 09, 2018 11:58 am
Forum: Flowcode V7
Topic: GLCD with touch
Replies: 19
Views: 2362

Re: GLCD with touch

by gonzogonzo
Mon Jul 09, 2018 10:23 am
Forum: Flowcode V7
Topic: GLCD with touch
Replies: 19
Views: 2362

GLCD with touch

Hello, I would like to simulate a GLCD with touch but I do not understand how simulating touch; i have download example "GLCD4.3touch" and use and simulation GLCD is ok but touch is for for me a "black hole". There is someone can help me with refering to this example? Thank in ad...
by gonzogonzo
Wed Jan 17, 2018 8:07 pm
Forum: Flowcode V7
Topic: HDC1010 - 1080
Replies: 0
Views: 601

HDC1010 - 1080

Hi ,

there is someone that have used with success HDC 10XX TI sensor in flowcode?
If yes can provide a simple code example?

Thanks in any case
by gonzogonzo
Wed Aug 30, 2017 5:18 pm
Forum: Bug reports
Topic: Problem - bug after update Flowcode V7 with latest update 24/08/2017
Replies: 2
Views: 784

Re: Problem - bug after update Flowcode V7 with latest update 24/08/2017

Hello Benj,
i am not sure that is a problem with HID or nrf24 or Pic18f2550 but something in last update; without it all work perfect also in hardware.
In any case thank again.
by gonzogonzo
Wed Aug 30, 2017 11:30 am
Forum: Bug reports
Topic: Problem - bug after update Flowcode V7 with latest update 24/08/2017
Replies: 2
Views: 784

Problem - bug after update Flowcode V7 with latest update 24/08/2017

Hello, my project under Flowcode V7 before latest update 24/08/2017 works very well: it use 18F2550, HID and nrf24l01. After i have download update of 24/08/2017 and install it compiled ok but stopped to work: i suspect that is a problem with HID because Ben work around it a couple of time with some...
by gonzogonzo
Tue Aug 01, 2017 3:08 pm
Forum: Flowcode V7
Topic: Problem with receving on HID *SOLVED!*
Replies: 2
Views: 1192

Re: Problem with receving on HID

Hi Benj,

Now with Your patch HID compiling, sending and receving seem working ok.

Thank very much for Your support.
by gonzogonzo
Mon Jul 31, 2017 6:56 pm
Forum: Flowcode V7
Topic: Problem with receving on HID *SOLVED!*
Replies: 2
Views: 1192

Problem with receving on HID *SOLVED!*

Hello, after my last http://www.matrixtsl.com/mmforums/viewtopic.php?f=63&t=19085 post Benj solved problem of compiling HID component and my circuit work ok sending packet on HID but i am not to be able receving packet from HID; i am not sure if it is other bug or there is a relation. For this i...
by gonzogonzo
Mon Jul 31, 2017 3:25 pm
Forum: Flowcode V7
Topic: Error problem with HID after update since 7.2.1 *SOLVED!*
Replies: 4
Views: 1524

Re: Error problem with HID after update since 7.2.1

Hi Benj,

now, with new patch, compiling and HID work ok.
I suggest that You change name to patch because has old name and this can generate a little confusion.

Thanks very much.
by gonzogonzo
Fri Jul 28, 2017 11:56 am
Forum: Flowcode V7
Topic: Error problem with HID after update since 7.2.1 *SOLVED!*
Replies: 4
Views: 1524

Re: Error problem with HID after update since 7.2.1

Hello Benj,
yes it is exactly same problem; i hope that You can find solution at this.
Thanks