Search found 87 matches

by kennethnilsen69
Wed Dec 18, 2019 1:48 pm
Forum: Flowcode V7
Topic: Timer component
Replies: 3
Views: 509

Re: Timer component

the latest update fixed the problem with Nano but not on the EPIO40P16
by kennethnilsen69
Wed Dec 18, 2019 12:27 pm
Forum: Flowcode V7
Topic: Timer component
Replies: 3
Views: 509

Re: Timer component

for the Arduino Nano I can't use any Timer components. just by adding a Timer component on a blank project to Nano I get this error message: Launching the compiler... C:\Program Files (x86)\Flowcode 7\compilers\avr\batchfiles\avra.bat atmega328p "C:\Users\Kenneth\DOCUME~1\Arduino\TimerTestNano....
by kennethnilsen69
Wed Dec 18, 2019 11:09 am
Forum: Flowcode V7
Topic: Timer component
Replies: 3
Views: 509

Timer component

Hi I have problems if I want to use more than 4 Timer components. I can not make the 5 Timer to work. In the Timer component, up to 9 Timers are available

Are there any restrictions or is this a bug?

I use:
FC7 and a EPIO40P16
by kennethnilsen69
Fri Sep 07, 2018 10:41 am
Forum: Flowcode V7
Topic: ECIO40P16 and Internal CAN truble
Replies: 16
Views: 2774

Re: ECIO40P16 and Internal CAN truble

Sorry Benj but no difference with the latest update
by kennethnilsen69
Thu Sep 06, 2018 10:14 pm
Forum: Flowcode V7
Topic: ECIO40P16 and Internal CAN truble
Replies: 16
Views: 2774

Re: ECIO40P16 and Internal CAN truble

And if I swap around Internal 1 and 2 i get this (only software swap)

CAN1AndCAN2 Internal1 and 2 Swap.JPG
CAN1AndCAN2 Internal1 and 2 Swap.JPG (44.5 KiB) Viewed 2649 times


ECIO40P16_CAN_BT_And_eeprom_Test.fcfx
(33.72 KiB) Downloaded 72 times
by kennethnilsen69
Thu Sep 06, 2018 9:58 pm
Forum: Flowcode V7
Topic: ECIO40P16 and Internal CAN truble
Replies: 16
Views: 2774

Re: ECIO40P16 and Internal CAN truble

Hello, I believe I may have now fixed the problem. In the initialisation of the DMA the channel 2 pointers were referring to the channel 1 pins. Hopefully should all be resolved for you now. Please copy the attached file into your "Flowcode 7/CAL/PIC16BIT" folder and let us know how you g...
by kennethnilsen69
Thu Sep 06, 2018 9:35 pm
Forum: Flowcode V7
Topic: ECIO40P16 and Internal CAN truble
Replies: 16
Views: 2774

Re: ECIO40P16 and Internal CAN truble

Hello, Please can you confirm you are using FLowcode v7.3 and have applied the fixes from here. https://www.matrixtsl.com/mmforums/viewtopic.php?f=63&t=19743#p86234 There are some CAN related fixes in there. I'm just combing through the internal CAL code now to see if I can spot any problems. Y...
by kennethnilsen69
Thu Sep 06, 2018 2:27 pm
Forum: Flowcode V7
Topic: ECIO40P16 and Internal CAN truble
Replies: 16
Views: 2774

Re: ECIO40P16 and Internal CAN truble

There is also another problem:
If I initialise CAN2, SetTxIdent and SetTxData do not work on CAN1
by kennethnilsen69
Sat Sep 01, 2018 5:13 pm
Forum: Flowcode V7
Topic: ECIO40P16 and AT24C32 eeprom
Replies: 17
Views: 3225

Re: ECIO40P16 and AT24C32 eeprom

I have now moved it to D5 and D4 and here everything works :-)


Thanks for the help
by kennethnilsen69
Sat Sep 01, 2018 1:34 pm
Forum: Flowcode V7
Topic: ECIO40P16 and AT24C32 eeprom
Replies: 17
Views: 3225

Re: ECIO40P16 and AT24C32 eeprom

Now I have moved them over to 3.3 volts and I now measure 3.2 volts on B7 and B6.

But it does not help on the problem :-( It still does not work.

I have also tested the ports with LED diodes and they work as they should and are not damaged by 3.7v for just a few seconds :-)
by kennethnilsen69
Sat Sep 01, 2018 1:22 pm
Forum: Flowcode V7
Topic: ECIO40P16 and AT24C32 eeprom
Replies: 17
Views: 3225

Re: ECIO40P16 and AT24C32 eeprom

Even with pull-ups to 5V so there is only 3.7 volts on pin B7 and B6 so I do not think has been damaged by it.

I move them over to the 3.3v output but have my doubts that this is the reason why it does not work
by kennethnilsen69
Sat Sep 01, 2018 9:15 am
Forum: Flowcode V7
Topic: ECIO40P16 and AT24C32 eeprom
Replies: 17
Views: 3225

Re: ECIO40P16 and AT24C32 eeprom

pull-ups is now added but no luck. still not working. I have GND on PIN 4 VCC on PIN 8 (5v) SCL on PIN 6 with pull-up resistor of 4.7k to 5v (to ECIO40P16 Port RB6) SDA on PIN 5 with pull-up resistor of 4.7k to 5v (to ECIO40P16 Port RB7) A0-A2 and WP are not connected. they should then be GND intern...
by kennethnilsen69
Fri Aug 31, 2018 4:21 pm
Forum: Flowcode V7
Topic: ECIO40P16 and AT24C32 eeprom
Replies: 17
Views: 3225

Re: ECIO40P16 and AT24C32 eeprom

I will try to add pull-up resistors on SDA and SCL this weekend and let's see if it helps :-)
by kennethnilsen69
Fri Aug 31, 2018 4:13 pm
Forum: Flowcode V7
Topic: ECIO40P16 and AT24C32 eeprom
Replies: 17
Views: 3225

Re: ECIO40P16 and AT24C32 eeprom

Yes, I use B6 and B7 A0 A1 A2 and WP are not connected to GND because it is stated in the manual that they are If left unconnected, WP is internally pulled down to GND. And When the pins are not hardwired, the default A2, A1, and A0 are zero. But I Have not pull-up resistors on SDA and SCL. I can no...
by kennethnilsen69
Fri Aug 31, 2018 1:38 pm
Forum: Flowcode V7
Topic: ECIO40P16 and AT24C32 eeprom
Replies: 17
Views: 3225

Re: ECIO40P16 and AT24C32 eeprom

so what do I do now? I need help because the eeprom component does not work.
by kennethnilsen69
Fri Aug 31, 2018 1:13 pm
Forum: Flowcode V7
Topic: ECIO40P16 and AT24C32 eeprom
Replies: 17
Views: 3225

Re: ECIO40P16 and AT24C32 eeprom

Yes, I know about this but this does not help me anything Hi, The pin-out, and usable pins are shown in the Flowcode View->Chip window Information about ECIO40P16 can be found here ... http://www.matrixtsl.com/webshop/40-pin-dspic-33-ecio.html https://www.matrixtsl.com/resources/files/datasheets/ECI...
by kennethnilsen69
Fri Aug 31, 2018 11:37 am
Forum: Flowcode V7
Topic: ECIO40P16 and AT24C32 eeprom
Replies: 17
Views: 3225

Re: ECIO40P16 and AT24C32 eeprom

According to the chip pinout on the dsPIC33EP256MU806 chip, PIN 31 and 33 is SDA2 and SCL2
and PIN 43 and 44 is ASDA1 and ASCL1

Which Pinout Ports are this on ECIO40P16?. I can not find them

http://ww1.microchip.com/downloads/en/DeviceDoc/70616g.pdf
by kennethnilsen69
Fri Aug 31, 2018 11:12 am
Forum: Flowcode V7
Topic: ECIO40P16 and AT24C32 eeprom
Replies: 17
Views: 3225

Re: ECIO40P16 and AT24C32 eeprom

I have now updated the eeprom components with them from this post but it still does not work https://www.matrixtsl.com/mmforums/viewtopic.php?f=64&t=19707&p=86063&hilit=I2C+Spy#p86063 Remap is now gone and SDA and SCL can now be selected correctly Software mode is on but it still does no...
by kennethnilsen69
Fri Aug 31, 2018 10:32 am
Forum: Flowcode V7
Topic: ECIO40P16 and AT24C32 eeprom
Replies: 17
Views: 3225

ECIO40P16 and AT24C32 eeprom

I can not make it read or write to external eeprom. Slight strange behavior on the ReMap selections in flowcode 7.3.0.5. When I put SDL and SCL Remap Pin, it does not change SDA and SCL. I have to put SDA and SCL to the correct Pin myself. but it does not work anyway This is not the case with other ...
by kennethnilsen69
Thu Aug 30, 2018 1:18 pm
Forum: Flowcode V7
Topic: ECIO40P16 and Internal CAN truble
Replies: 16
Views: 2774

Re: ECIO40P16 and Internal CAN truble

Hi Benj, have you had time to look at it?
by kennethnilsen69
Tue Aug 28, 2018 11:59 am
Forum: Flowcode V7
Topic: ECIO40P16 and Internal CAN truble
Replies: 16
Views: 2774

Re: ECIO40P16 and Internal CAN truble

More testing shows that it is Internal 2 that is not working.

If I only switch on Internal 1 and 2 from CAN1 and CAN2 then it's always internal 2 that does not work
by kennethnilsen69
Tue Aug 28, 2018 11:53 am
Forum: Flowcode V7
Topic: ECIO40P16 and Internal CAN truble
Replies: 16
Views: 2774

Re: ECIO40P16 and Internal CAN truble

Thank you benj the c command worked well :-) C1CTRL1 = 0x0000; C2CTRL1 = 0x0000; It's not D7 and D6 that's the problem. It is CAN component. D7 and D6 work fine if I switch from CAN1 to CAN2 (Software only) just me who writes and explains a little wrong. I try again With this configuration, only CAN...
by kennethnilsen69
Tue Aug 28, 2018 8:50 am
Forum: Flowcode V7
Topic: ECIO40P16 and Internal CAN truble
Replies: 16
Views: 2774

Re: ECIO40P16 and Internal CAN truble

another problem: When I set component can1 (internal-1) bus rate to 1000 it works ok on bus rate 500. but when i add can2 (internal-2) bus rate 1000, bus2 does not work properly. Yes it seems that it works at 500 rate but gives out the wrong data (I get ID 0 and DLC 0 and no data) When I switch the ...
by kennethnilsen69
Mon Aug 27, 2018 2:47 pm
Forum: Flowcode V7
Topic: ECIO40P16 and Internal CAN truble
Replies: 16
Views: 2774

Re: ECIO40P16 and Internal CAN truble

I can confirm now this is the same problem as I have. But there is someone who can take the time to explain to me how I fix this I found this but do not know if it is the same. But could anyone explain this a little better. What file and what should I change? I need to go Bus Rate 500 Hi, Same as wi...
by kennethnilsen69
Sun Aug 26, 2018 10:32 pm
Forum: Flowcode V7
Topic: ECIO40P16 and Internal CAN truble
Replies: 16
Views: 2774

Re: ECIO40P16 and Internal CAN truble

I found this but do not know if it is the same. But could anyone explain this a little better. What file and what should I change? I need to go Bus Rate 500 Hi, Same as with FC6, Using standard setting the CAN transmits at half the required speed. To make it work on the bench I changed Register CxCT...