Search found 22 matches

by jgriffin
Wed Nov 19, 2008 3:30 am
Forum: E-blocks
Topic: EB005- LCD and assembly
Replies: 2
Views: 2060

EB005- LCD and assembly

Guys, I am attempting to display a character on the LCD using assembly language. The program use the following initialization codes: 0x33 0x32 0x2c 0x06 0x0c 0x01 0x02 This appears to work and I get a flashing cursor at postion zero. The following code is use to send a "H" to the display. ...
by jgriffin
Sat May 24, 2008 6:54 pm
Forum: E-blocks
Topic: LCD display issue
Replies: 5
Views: 3181

Re: LCD display issue

Thnaks guys,

But, why does the SAME program work on one set of Eblocks but not another?
by jgriffin
Sun May 18, 2008 3:11 am
Forum: E-blocks
Topic: LCD display issue
Replies: 5
Views: 3181

LCD display issue

Guys, I am having trouble displaying to the LCD. I have done this many times before without issue but it now does not work. I have upgraded to another version of Flowcode. The program has two blocks. START macro and PrintASCII macro. Everything is configured ok, power applied, contrast ok, connected...
by jgriffin
Thu Apr 10, 2008 4:04 am
Forum: Formula Flowcode
Topic: Formula Flowcode connection
Replies: 12
Views: 17006

Re: Formula Flowcode connection

Benji, I installed the new USB drivers and now the Formula Flowcode is recognized by the laptop. But I still have a problem. Now, I can write a program and simulate it fine. But, when I attempt to download it to the Formula Flowcode, all indications is that the program has been downloaded successful...
by jgriffin
Thu Apr 03, 2008 2:37 pm
Forum: Formula Flowcode
Topic: Formula Flowcode connection
Replies: 12
Views: 17006

Formula Flowcode connection

I am having a problem connecting the Formula Flowcode. I believe it is a USB driver issue. When I install the USB drives either dircetly, through PPP or reinstall Flowcode V3, everything indicates success. However, the device appears in the Device Manager in OTHER with a yellow question mark. I have...
by jgriffin
Tue Apr 01, 2008 9:38 pm
Forum: Flowcode V2 & V3
Topic: C-Code error using asm
Replies: 2
Views: 1389

Re: C-Code error using asm

Sean,

Got it. Thanks a million.

Jack
by jgriffin
Tue Apr 01, 2008 2:10 pm
Forum: Flowcode V2 & V3
Topic: C-Code error using asm
Replies: 2
Views: 1389

C-Code error using asm

I am attempting to use Flowcode (V3/PIC 16F877A) to demonstrate assembly language commands in a single C-Code block between BEGIN and END. The C-Code block contains the following: asm { bsf 3,5 movlw 000 mowf 0x85 bcf 3,5 movlw 0x00f mowf 005 } However, I get the following errors: C:\Temp\Flowcode1....
by jgriffin
Mon Sep 17, 2007 5:41 pm
Forum: Flowcode V2 & V3
Topic: Installing version 3.2.1
Replies: 3
Views: 1780

Thanks guys.

Jack
by jgriffin
Mon Sep 17, 2007 12:02 am
Forum: Flowcode V2 & V3
Topic: Installing version 3.2.1
Replies: 3
Views: 1780

Installing version 3.2.1

I currently have Flowcode version 3.2.0.36, full license. When I run the installer for 3.2.1, it indicates that I need to remove my current version of Flowcode V3 using the Add/Remove in Windows.

Will this remove my license? Do I click OK and continue with the install?

Thanks,

Jack
by jgriffin
Wed Jul 18, 2007 12:16 pm
Forum: Formula Flowcode
Topic: Flowcode error
Replies: 6
Views: 6109

Ben,

I saw those. However, if you copy and paste ithem into a Word document the quality is poor. Will the A4 size drawing mentioned on the page be available soon?

Thanks,

Jack
by jgriffin
Wed Jul 18, 2007 2:44 am
Forum: Formula Flowcode
Topic: Flowcode error
Replies: 6
Views: 6109

Ben, Thanks for the information. I installed the fix from Microsoft (http://support.microsoft.com/?id=896256) but it had no effect. However the fix from Passmark(http://www.passmark.com/forum/showpost.php?p=1176&postcount=15) solved the problem. No more errors. Thanks for the help. Is there any ...
by jgriffin
Sun Jul 15, 2007 7:04 pm
Forum: Formula Flowcode
Topic: Flowcode error
Replies: 6
Views: 6109

Flowcode error

Ben, I am using the Formula Flowcode with Flowcode. I have been successful accessing the LEDs on Port D and driving the buggy forward using PWM. I also had the speaker beeping. However, at times, I am getting an error when attempting to Compile to Chip. The error is: Error: Access Violation at 0x7C1...
by jgriffin
Thu Feb 15, 2007 4:04 pm
Forum: Flowcode V2 & V3
Topic: Compiling error
Replies: 5
Views: 3474

Attaching file

Ben,

Could you tell me how to attach a Flowcode file in a reply?

Thanks,

Jack
by jgriffin
Wed Feb 14, 2007 12:53 am
Forum: Flowcode V2 & V3
Topic: Compiling error
Replies: 5
Views: 3474

Compiling error

Ian, Steve, I have a student who is writing a clock routine that contiains three loops, seconds, minutes and hours. Display is to the LCD. His simulation works but when he tries to compile and download to the PIC he gets the following error. --------- Flowcode was unable to compile the flowcharts C ...
by jgriffin
Thu Jan 18, 2007 4:34 pm
Forum: Flowcode V2 & V3
Topic: Flowcode error
Replies: 3
Views: 2526

Steve,

I am teaching an online course and one of my students is having the problem. He does not know enough about Flowcode to give me any details. Is there a way to tell which module is missing?

The only components he should be using is the LED and Swich module.

Thanks,

Jack
by jgriffin
Thu Jan 18, 2007 3:21 am
Forum: Flowcode V2 & V3
Topic: Flowcode error
Replies: 3
Views: 2526

Flowcode error

The following error occurs when trying to configure the PIC 16F88 (USB multiprogrammer) in Flowcode. "Flowcode could not load one of the component in the file because it is not registered on this machine. Install the necessary components before opening this file" Currently using version 2....
by jgriffin
Wed Dec 20, 2006 6:30 pm
Forum: C and ASM Programming
Topic: Reading and writing to ports
Replies: 6
Views: 5499

Got IT!!

Steve, The minimum code below works . The problem was the A/D on Port A of the 877A. I noticed in several of the other post the reference to configuraing the A/D as digital I/O. Also, I used the Flowcode .asm file as a guide. By deleting code, I finally narrowered it down to the movlw D'7' ;turn off...
by jgriffin
Mon Dec 18, 2006 5:40 pm
Forum: C and ASM Programming
Topic: Reading and writing to ports
Replies: 6
Views: 5499

Thanks

Thanks so much for the reply. I am using MPLab 7.2 with the default radix set to HEX. A little more background may help. I have the switches set on the Multiprogrammer board to FAST and XTAL. I have written the same program in Flowcode and it works fine. I also set PPP to HS, WDT off, LVP off. I hav...
by jgriffin
Sun Dec 17, 2006 2:55 am
Forum: C and ASM Programming
Topic: Reading and writing to ports
Replies: 6
Views: 5499

Reading and writing to ports

I have a multiprogrammer board (PIC 16F877A) with the Switch board on PORTA and the LED board on PORT B. I want to turn on the LED assocated with the pressed switch. I have attempted several different programs without any success. The program below is the minimul that I thought should work. No luck....
by jgriffin
Sat Jul 08, 2006 3:27 pm
Forum: Flowcode V2 & V3
Topic: Connecting two Multiprogrammers via Internet Boards
Replies: 1
Views: 2122

Connecting two Multiprogrammers via Internet Boards

All, I am attempting to send data (1-byte) using TCP via a network from one Multiprogrammer board (Master) to another (Slave). I have read the documentation on the Internet board and Flowcode Macros. Using that information, I have written Master and Slave Flowcode programs. But, have not been able t...
by jgriffin
Tue Jul 04, 2006 5:00 pm
Forum: Flowcode V2 & V3
Topic: Flowcode Internet Board Tutorials
Replies: 2
Views: 2620

Thanks

Found the files.

Thanks,

Jack Griffin
by jgriffin
Tue Jul 04, 2006 2:44 am
Forum: Flowcode V2 & V3
Topic: Flowcode Internet Board Tutorials
Replies: 2
Views: 2620

Flowcode Internet Board Tutorials

Ian/Steve,

Can you direct me to any tutorials or sample Flowcode files using the Internet board. I was able to download and implement the Web Server example and would like to see "how its done".

Thanks,

Jack Griffin