Search found 11 matches

by andreeksteen
Thu Feb 06, 2020 1:08 pm
Forum: Flowcode V8
Topic: Pololu P-Star 45K50 Bootloader
Replies: 12
Views: 876

Re: Pololu P-Star 45K50 Bootloader

Hallo, Thank you SO-SO much for all your help. It now works perfectly, you are a star!! For anyone having issues with the Pololu P-Star Bootloader in Flowcode, here is a short summary of what Benj told me to do to get it working: 1: Install P-Load bootloader in your Flowcode8/Tools folder and rename...
by andreeksteen
Thu Feb 06, 2020 12:22 pm
Forum: Flowcode V8
Topic: Pololu P-Star 45K50 Bootloader
Replies: 12
Views: 876

Re: Pololu P-Star 45K50 Bootloader

Hallo,

I have done as you told me and then tried it again, twice, and both times this message came up.
by andreeksteen
Thu Feb 06, 2020 11:56 am
Forum: Flowcode V8
Topic: Pololu P-Star 45K50 Bootloader
Replies: 12
Views: 876

Re: Pololu P-Star 45K50 Bootloader

Hallo, I used the parameters you suggested: -t p-star -w "$(outdir)$(target).hex" In Flowcode it looks like its working fine, the LED's on the board flashed when it started the upload, but the program is not running on the board. I have tried and tested this program on both an Arduino Uno ...
by andreeksteen
Thu Feb 06, 2020 11:23 am
Forum: Flowcode V8
Topic: Pololu P-Star 45K50 Bootloader
Replies: 12
Views: 876

Re: Pololu P-Star 45K50 Bootloader

:oops: Now that is an embarrassing mistake!!! Sorry for that :oops:

I did what you said and it came back with 4 examples. Which one do I use and why?

Thank you for all your patience with me!!
by andreeksteen
Thu Feb 06, 2020 10:49 am
Forum: Flowcode V8
Topic: Pololu P-Star 45K50 Bootloader
Replies: 12
Views: 876

Re: Pololu P-Star 45K50 Bootloader

Hallo Benj,

I changed the parameters to --Help and the attached message is what I got. Is this what you were looking for?
by andreeksteen
Wed Feb 05, 2020 6:01 pm
Forum: Flowcode V8
Topic: Pololu P-Star 45K50 Bootloader
Replies: 12
Views: 876

Re: Pololu P-Star 45K50 Bootloader

I tried the options you offered, settling for the second one that you said would be better if I removed the spaces and just use Boot. Now it tells me that the chip is "unknown". Any advice on that?
by andreeksteen
Wed Feb 05, 2020 3:55 pm
Forum: Flowcode V8
Topic: Pololu P-Star 45K50 Bootloader
Replies: 12
Views: 876

Pololu P-Star 45K50 Bootloader

I need help to setup a third party bootloader in Flowcode 8 for the Pololu P-Star 45K50. First of all I downloaded the Pololu Bootloader Utility ( https://www.pololu.com/product/3156/resources ) and installed that in my Flowcode 8 Tools folder. Then I went into compiler options and in the Programmer...
by andreeksteen
Fri Jan 31, 2020 1:38 pm
Forum: Flowcode V8
Topic: PID control
Replies: 4
Views: 608

Re: PID control

Thank you guys so much for the help. Benj, thank you for pointing out my rooky mistake with the "no timer"! Now that I have that corrected the program runs perfectly on the Arduino. QMESAR, thank you for the advice about antiwind up and I will definitely do that if I do use the program in ...
by andreeksteen
Thu Jan 30, 2020 6:31 pm
Forum: Flowcode V8
Topic: PID control
Replies: 4
Views: 608

PID control

Please help me. I am new to Flowcode and I am having issues with my PID program that I want to use in an automated process. In Flowcode the simulation looks great and everything seems to be working. When I upload to the Adruino Uno R3 I do not get any PWM output. I tried finding the problem in my co...
by andreeksteen
Mon Jan 06, 2020 1:18 pm
Forum: Bug Reports
Topic: Bad mistake in FC8!
Replies: 48
Views: 4813

Re: Bad mistake in FC8!

Hallo Christina, Thank you so much for the great advice! I actually took it a step further: 1: Uninstall Flowcode 8 and all associated items (Pic8, Pic16, Pic32 and so on) 2: Deleted the entire registry entry "HKEY_CURRENT_USER \ Software \ MatrixTSL \ FlowcodeV8" as well as SCADA. 3: Then...
by andreeksteen
Mon Jan 06, 2020 10:41 am
Forum: Bug Reports
Topic: Bad mistake in FC8!
Replies: 48
Views: 4813

Re: Bad mistake in FC8!

I have been having the same issue with Flowcode 8.2 up to this morning. Now when I start Flowcode 8.2 is looks like it's starting, but then it crashes. I did the following with no success at all: 1: Uninstall Flowcode 8.2 completely and reinstall 2: Tried to start it in Safe mode, same problem there...