Search found 325 matches

by Ondra
Tue Aug 16, 2011 4:29 pm
Forum: Flowcode V4
Topic: Zigbee TX, RX Port From 1 to USART 2
Replies: 5
Views: 1308

Zigbee TX, RX Port From 1 to USART 2

Good day all.
I'm using a chip that has 2 USARTs. Using the zigbee componet, I would like to know how to set the component
to use USART 2.


Ondra
by Ondra
Tue Aug 09, 2011 6:13 pm
Forum: Flowcode V4
Topic: telegesis Zigbee wireless modules
Replies: 2
Views: 955

Re: telegesis Zigbee wireless modules

Thanks Benj.
by Ondra
Tue Aug 09, 2011 4:04 pm
Forum: Flowcode V4
Topic: telegesis Zigbee wireless modules
Replies: 2
Views: 955

telegesis Zigbee wireless modules

Good day. I would like to know if the FC v4.5 can work with or support the telegesis modules. And if not directly than what tweaks, if any, can be done to work with these units? I have include a link to the data sheet and "at command" set and structure PDF. http://telegesis.com/downloads/g...
by Ondra
Wed Aug 03, 2011 2:59 pm
Forum: Flowcode 4 Suggestions
Topic: wifi E-Block and accelerometer E-Block
Replies: 31
Views: 12526

Re: wifi E-Block and accelerometer E-Block

Good day all. I have an application where I want to use WiFi for my connectivity. I see there is an e-block for this application. The product description states that "The board is compatible with the wireless LAN Flowcode component." I just downloaded and installed the new 4.5v of flowcode...
by Ondra
Tue Jul 19, 2011 4:35 pm
Forum: Flowcode V4
Topic: I2C 24LC512 eeprom sim not working
Replies: 7
Views: 1548

Re: I2C 24LC512 eeprom sim not working

I got it Ben. Looking at the C code I saw this " Device_ID = Device_ID << 1;" Well using a scope I notice that the first bit was missing. For my device 1010 is the device ID what was being sent was 0101 as the first 4 bits So changing the address to 0xD7 or 0x54, I got the bit back and it ...
by Ondra
Tue Jul 19, 2011 4:05 pm
Forum: Flowcode V4
Topic: I2C 24LC512 eeprom sim not working
Replies: 7
Views: 1548

Re: I2C 24LC512 eeprom sim not working

After I sent the file I did realizes that I hadn't checked the use "Software Settings". though that was the option I was using. Have you got external pull up resistors connected to the SCL and SDA signals? Pullup resistor values of 10K or 2K are recommended depending on the I2C rate you ar...
by Ondra
Tue Jul 19, 2011 9:36 am
Forum: Flowcode V4
Topic: I2C 24LC512 eeprom sim not working
Replies: 7
Views: 1548

Re: I2C 24LC512 eeprom sim not working

Hi Ben I'm having no success with this. I have a couple of questions. My setup is a follows. I have a PIC18F6722 communicating through Port D 5 and 6 (which is the hardware SPI2 ports SDA2 and SCL2) using the I2C software emulation. I'm connected to a 24LC512 chip with pins A0 and A1 connected to VS...
by Ondra
Mon Jul 18, 2011 12:01 pm
Forum: Flowcode V4
Topic: I2C 24LC512 eeprom sim not working
Replies: 7
Views: 1548

Re: I2C 24LC512 eeprom sim not working

I did try the hardware and it not working. Knowing that the programs working eliminates
that from the problem I continue to look further thanks.

Ondra
by Ondra
Mon Jul 18, 2011 10:33 am
Forum: Flowcode V4
Topic: I2C 24LC512 eeprom sim not working
Replies: 7
Views: 1548

I2C 24LC512 eeprom sim not working

Good day all. I am working on a project that requires me to connect a 24LC512 eeprom to my PIC. I've boarded the hardware and now I need to test. I have the put together a program that increments a number 10 times and places it in an address location starting at address 10. I then have a loop that r...
by Ondra
Fri Feb 11, 2011 11:49 am
Forum: Flowcode V4
Topic: Custom interrupt on Port A0
Replies: 3
Views: 1039

Re: Custom interrupt on Port A0

Thanks Benj.

Ondra
by Ondra
Thu Feb 10, 2011 1:32 pm
Forum: Flowcode V4
Topic: Custom interrupt on Port A0
Replies: 3
Views: 1039

Custom interrupt on Port A0

Good day all. I a have created a program that uses a software USART on port A of a PIC18F2680 chip. I would like to know if it's possible to set an interrupt on the RX pin? In this case its RA0. If it's do-able would you be so kind and provide code or a code sample or point me in the right direction...
by Ondra
Fri Jan 28, 2011 1:42 pm
Forum: Flowcode V4
Topic: Hi Tech compiller error
Replies: 8
Views: 1949

Re: Hi Tech compiller error

Any thoughts on this Benj?

Ondra
by Ondra
Fri Jan 28, 2011 12:25 pm
Forum: Flowcode V4
Topic: RS232 Pass Through?
Replies: 10
Views: 2282

Re: RS232 Pass Through?

Benj.
Thank you very much.

Ondra
by Ondra
Thu Jan 27, 2011 4:30 pm
Forum: Flowcode V4
Topic: Hi Tech compiller error
Replies: 8
Views: 1949

Re: Hi Tech compiller error

I see these are warning not errors.
But that is the end of the list. I don't get a "compiled ok" at the end of the list.

Ondra
by Ondra
Thu Jan 27, 2011 4:25 pm
Forum: Flowcode V4
Topic: Hi Tech compiller error
Replies: 8
Views: 1949

Re: Hi Tech compiller error

Without the semi colon the error list looks like this: Pebble_Pic_IP_Acc_Brd.c: ^ (359) illegal conversion between pointer types (warning) ^ (359) illegal conversion between pointer types (warning) 7245: FCV_MATCH = FCI_COMPARE(FCL_RET_VAL,5,"s1aw",4,1); ^ (359) illegal conversion between ...
by Ondra
Thu Jan 27, 2011 4:10 pm
Forum: Flowcode V4
Topic: Hi Tech compiller error
Replies: 8
Views: 1949

Re: Hi Tech compiller error

Thanks Benj. I now get the following errors: ^ (162) #warning: "This interrupt has previously been enabled, so the macro <Inter_Counter> may never get called." (warning) Pebble_Pic_IP_Acc_Brd.c: FCM_TimeClock() 2884: FCM_LCD_Idx_Data_Out("System Startup"); ^ (359) illegal convers...
by Ondra
Thu Jan 27, 2011 1:23 pm
Forum: Flowcode V4
Topic: Hi Tech compiller error
Replies: 8
Views: 1949

Hi Tech compiller error

Good day all I need some help setting up and using the Hi-Tech compiler. When I tried to compile code using the Hi-tech compiler, code that compiles fine using the default "source boost", I get the following errors. can someone help me with this? Pebble_Pic_IP_Acc_Brd.c: FCM_TimeClock() 28...
by Ondra
Thu Jan 27, 2011 1:14 pm
Forum: Flowcode V4
Topic: RS232 Pass Through?
Replies: 10
Views: 2282

Re: RS232 Pass Through?

Thanks medelec35. I tried your suggestions and still the data stops flowing. Note the chip is still running the code. I used a timer to flash an LED. I see that the chip is still processing data it's just that the RS232 receive is not collecting the data. If I restart the chip only the rest of the d...
by Ondra
Tue Jan 25, 2011 3:05 pm
Forum: Flowcode V4
Topic: RS232 Pass Through?
Replies: 10
Views: 2282

Re: RS232 Pass Through?

HI Benj. I'm still trying to get this resolved. I have another question. What could be the cause of an RS232 RX lockup. And how can I overcome this? Also outside of the 3 byte buffer assigned to this chip, could you give me an example of software buffering I could do that may help to overcome what I...
by Ondra
Fri Jan 14, 2011 1:32 pm
Forum: Flowcode V4
Topic: RS232 Pass Through?
Replies: 10
Views: 2282

Re: RS232 Pass Through?

Does this meen that my code is good? I've been using 2 different terminal emulators. I checked the properties in Hyper terminal and it's clean. Has anyone tried to get something like this working? I tried something like this awhile back and gave up deciding to bit bang the communications instead. I ...
by Ondra
Thu Jan 13, 2011 3:16 pm
Forum: Flowcode V4
Topic: RS232 Pass Through?
Replies: 10
Views: 2282

Re: RS232 Pass Through?

First, thanks for your assistance Benj. I've tried possibly about 20 different way to get this working. I just tried your suggestion, and again the same problem. Rather than building a string then sending it, I tried passing each byte as it came in. As simple as it seems I could not get that to func...
by Ondra
Thu Jan 13, 2011 12:40 pm
Forum: Flowcode V4
Topic: RS232 Pass Through?
Replies: 10
Views: 2282

Re: RS232 Pass Through?

Good day, Steve, Benj and David. Has anyone had a look at this? Is there something obvious that stands out?
I really need some help on this.

Ondra.
by Ondra
Wed Jan 12, 2011 1:55 am
Forum: Flowcode V4
Topic: RS232 Pass Through?
Replies: 10
Views: 2282

RS232 Pass Through?

I have been trying for some time to get this attached program to work. I have 2 Pics connected via RS232. One PIC is connected to a PC. I want to be able to communicate to the second PIC through the first. I have attached the program I am testing with. The problem is; the data stops flowing when the...
by Ondra
Mon Dec 20, 2010 1:38 pm
Forum: Flowcode V4
Topic: Use of ReceiveRS232String in main loop
Replies: 5
Views: 1555

Re: Use of ReceiveRS232String in main loop

OK Benj, just to round out my thinking on this. Is a string each word in a sentence or would it be the entire sentence or phrase?

Ondra.
by Ondra
Mon Dec 20, 2010 1:24 pm
Forum: Flowcode V4
Topic: Use of ReceiveRS232String in main loop
Replies: 5
Views: 1555

Re: Use of ReceiveRS232String in main loop

Thanks Benj this looks good.

Ondra