Search found 325 matches

by Ondra
Fri Jul 06, 2012 11:57 am
Forum: Flowcode V5
Topic: integrating c code
Replies: 41
Views: 6997

Re: integrating c code

Thanks Ben. In the main project file the there are listed some common #includes: #include <system.h> #include <string.h> #include <stdio.h> #include <stdlib.h> Would these be already added by flowcode or should I include them as well? Also should I just leave all the files in the unziped folder and ...
by Ondra
Fri Jul 06, 2012 3:04 am
Forum: Flowcode V5
Topic: integrating c code
Replies: 41
Views: 6997

integrating c code

Good day all. I have a project where I'm looking for expanded internet capabilities. Doing some research. I found on the source boost web site a program I would like to integrate in to my current project. I'm hoping someone could give me some direction on how I would go about including the files tha...
by Ondra
Wed Mar 28, 2012 1:15 pm
Forum: General Programming
Topic: Calculating a Checksum
Replies: 19
Views: 5829

Re: Calculating a Checksum

Thanks Jonny. You were right about the RS232 component wrapping. I converted to string first, and yes I am getting the correct value. The issue seems to be that from somewhere a char is been added at the end of the packet over riding the check-sum. I lengthened the last loop that puts the data to th...
by Ondra
Tue Mar 27, 2012 3:16 pm
Forum: General Programming
Topic: Calculating a Checksum
Replies: 19
Views: 5829

Re: Calculating a Checksum

Thanks Jonny. although I'm a V5 user, this is done in V4. I made the change ( = -checkSum & 0xFF) over in V4 and it doesn't work. Another thing. I put an RS232 componet in the loop to print the result of the calculation through each loop. when the the loop gets to (I)73(0x49) the sum result is 2...
by Ondra
Tue Mar 27, 2012 1:21 pm
Forum: General Programming
Topic: Calculating a Checksum
Replies: 19
Views: 5829

Re: Calculating a Checksum

Thanks Jonny here is the macro that I have an issue with.
Have a look at the calulate check sum loop.
Thanks
by Ondra
Tue Mar 27, 2012 12:43 pm
Forum: General Programming
Topic: Calculating a Checksum
Replies: 19
Views: 5829

Re: Calculating a Checksum

Thanks Jonny.

JonnyW wrote:if the value is not cropped to an integer, the 'Twos compliment' part: 256 - temp_calc will cause a problem.


could you explain.

Ondra
by Ondra
Tue Mar 27, 2012 11:15 am
Forum: General Programming
Topic: Calculating a Checksum
Replies: 19
Views: 5829

Re: Calculating a Checksum

Thanks Ben. In the example it look to me that you are adding the values held in a byte array into an int. In theory this looks like it should work. But on the chip it doesn't. When I sum the bytes into the int it keeps overflowing. Simulating your example If I place larger byte values, ex.0xF2 I get...
by Ondra
Mon Mar 26, 2012 10:01 pm
Forum: General Programming
Topic: Calculating a Checksum
Replies: 19
Views: 5829

Re: Calculating a Checksum

Hi Ben. I'm using your example code in my program. The issue I'm having is that when the number get large say above 255. It seams the result rolls over and I get the wrong value. For example here is a list of numbers: - 8, 82, 78, 73, 48, 48, 48, 48, 49, 49, 69, 56. I'm printing the calculated resul...
by Ondra
Thu Mar 15, 2012 2:45 pm
Forum: Flowcode V4
Topic: W/R an 80kb fille to/from external eeprom
Replies: 1
Views: 671

W/R an 80kb fille to/from external eeprom

Good day all. I'm needing a technique for reading and writing an 80kb file to and from external eeprom memory. Has anyone done this? If so, can you add some in-site as to how this can be accomplished; and with this, ensuring the integrity of the file. I'm OK, with writing and reading strings to exte...
by Ondra
Wed Mar 07, 2012 2:04 pm
Forum: Flowcode V4
Topic: Zigbee Connect_to_name Bug?
Replies: 2
Views: 861

Re: Zigbee Connect_to_name Bug?

Hi Ben. I'm not to sure this post is being looked into. I changed the content and title of a previous post I had submitted. Resubmitting it as this one.
I really need someone to look in to this so I can move on with my project. Thanks for you assistance.

Ondra
by Ondra
Mon Mar 05, 2012 5:02 pm
Forum: Flowcode V4
Topic: Zigbee Connect_to_name Bug?
Replies: 2
Views: 861

Re:Zigbee Connect_to_name Bug?

Hi Ben. I was wondering if the changes you suggested in a previous post might have something to do with this issue. link to the post below.
viewtopic.php?f=29&t=10352

Ondra
by Ondra
Mon Mar 05, 2012 4:53 am
Forum: Flowcode V4
Topic: Zigbee Connect_to_name Bug?
Replies: 2
Views: 861

Zigbee Connect_to_name Bug?

Good day all. I have a setup using 2 zigbee devices. The Node is connecting and communicating. With verbose checked, I performed a scan network and got the following values: - "OKATND77EA0013A200406AB7200B0011E700000200C105101E". Based on the above, the coordinator is seeing the Node. I th...
by Ondra
Fri Mar 02, 2012 5:09 pm
Forum: Flowcode V4
Topic: Zigbee re-coding Device name
Replies: 3
Views: 1056

Re: Zigbee re-coding Device name

Hi Ben when I change the code I can see the values are being written. What I don't see is an Ok Response from the module.
Ondra
by Ondra
Fri Mar 02, 2012 3:41 pm
Forum: Flowcode V4
Topic: Zigbee re-coding Device name
Replies: 3
Views: 1056

Re: Zigbee re-coding Device name

The string is made up of numbers and letter. If there is a 0 in the string will this cause a problem?

Ondra
by Ondra
Fri Mar 02, 2012 3:20 pm
Forum: Flowcode V4
Topic: Zigbee sending <CR> after AT command
Replies: 2
Views: 941

Re: Zigbee sending <CR> after AT command

Any particular format?

Ondra
by Ondra
Fri Mar 02, 2012 12:13 pm
Forum: Flowcode V4
Topic: Zigbee sending <CR> after AT command
Replies: 2
Views: 941

Zigbee sending <CR> after AT command

Good day all.
When sending AT command to the XBee module do you have to send a Carriage return after each command?

Ondra
by Ondra
Fri Mar 02, 2012 12:05 pm
Forum: Flowcode V4
Topic: Zigbee re-coding Device name
Replies: 3
Views: 1056

Zigbee re-coding Device name

Good day all. On the Zigbee properties page you have the option to include a "device name". I am using serial a numbering method where the serial number is stored in the eeprom when the device is programmed. When the device runs. I would like to take this value and use it for the device na...
by Ondra
Mon Feb 27, 2012 5:24 pm
Forum: Flowcode V4
Topic: Saving and storing a file to eeprom
Replies: 2
Views: 1062

Re: Saving and storing a file to eeprom

Thanks Ben
I'm not sure how I would implement this in Flowcode. I will look into it.
Any tutorials on the web or other wise that may help?

Ondra
by Ondra
Mon Feb 27, 2012 5:17 pm
Forum: Flowcode V4
Topic: Array of Strings
Replies: 4
Views: 1164

Re: Array of Strings

Thanks Ben.
by Ondra
Mon Feb 27, 2012 4:42 pm
Forum: Flowcode V4
Topic: Zigbee read name from buffer
Replies: 1
Views: 689

Zigbee read name from buffer

Good day.
Zigbee's - "Read_name_from_buffer" macro allows you to read the name one byte at a time. When indexing through the bytes what is the terminator for the end of the name? Is a '0' as it is with strings?

Ondra
by Ondra
Mon Feb 27, 2012 4:33 pm
Forum: Flowcode V4
Topic: Saving and storing a file to eeprom
Replies: 2
Views: 1062

Saving and storing a file to eeprom

Good day all. I would like to know what would be a good approach to storing, verifying the integrity then reading back a 128k file on an external eeprom chip. The file will be read through the RS232 port of the chip. The eeprom is connected via SPI.

Ondra
by Ondra
Mon Feb 27, 2012 4:26 pm
Forum: Flowcode V4
Topic: Array of Strings
Replies: 4
Views: 1164

Array of Strings

Good day all I like to know if it is possible to create an array of strings and could you give an example of how this would be done. Also how would could you go about storing/indexing this data in eeprom. example of what I would like to do. Names[0] = "Steven" Names[1] = "Rick" N...
by Ondra
Mon Feb 20, 2012 2:17 pm
Forum: Flowcode V5
Topic: finding Errors: - Illegal symbol name: %
Replies: 7
Views: 2746

Re: finding Errors: - Illegal symbol name: %

Looking at "Customize Component Code" there aren't any bold names to indicate any changes to the original. And no I'm not using any custom or supplementary code.
How do I go about restoring the original code?

Ondra
by Ondra
Sun Feb 19, 2012 9:26 pm
Forum: Flowcode V5
Topic: V5 crashing no access to program later.
Replies: 7
Views: 2750

Re: V5 crashing no access to program later.

Hi Jonny. Is this issue resolved in the latest update.

Ondra
by Ondra
Sun Feb 19, 2012 9:22 pm
Forum: Flowcode V4
Topic: LCD not working at frequence High speed
Replies: 7
Views: 3089

Re: LCD not working at frequence High speed

Thanks Martin. I tried the recommendations given by Ben. I also tried playing with other values. Nothing worked. I was running at 40Mz. I went with 40 to try to overcome an issue of characters being dropped from my Zigbee connection. I implemented some error checking on the RX data side. Changed the...