Formula Flowcode connection

For Formula Flowcode Micromouse users to discuss projects, flowcharts, and any other issues related to the Formula Flowcode Micromouse.

Moderator: Benj

jgriffin
Posts: 22
Joined: Sat Jan 07, 2006 6:47 pm
Location: USA
Contact:

Formula Flowcode connection

Postby jgriffin » Thu Apr 03, 2008 2:37 pm

I am having a problem connecting the Formula Flowcode. I believe it is a USB driver issue. When I install the USB drives either dircetly, through PPP or reinstall Flowcode V3, everything indicates success. However, the device appears in the Device Manager in OTHER with a yellow question mark. I have downloaded the lastest version of all software and re-installed them without success.

The Formula Flowcode has power. When you connect the USB cable you get two quick beeps rather than the normal two beeps. If you attempt to program the device you get an error message asking you to check the power and press the reset button.

Any ideas?

Thanks,

Jack

User avatar
Benj
Matrix Staff
Posts: 14216
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4355 times
Been thanked: 4095 times
Contact:

Re: Formula Flowcode connection

Postby Benj » Thu Apr 03, 2008 3:33 pm

Hello Jack

Please can you try the following drivers from this location
http://www.matrixmultimedia.com/softwar ... rivers.zip

Then if these are still failing then please let me know some of your system specs eg which OS, RAM, Firewall, Antivirus, HD space etc.

jgriffin
Posts: 22
Joined: Sat Jan 07, 2006 6:47 pm
Location: USA
Contact:

Re: Formula Flowcode connection

Postby jgriffin » Thu Apr 10, 2008 4:04 am

Benji,

I installed the new USB drivers and now the Formula Flowcode is recognized by the laptop.

But I still have a problem. Now, I can write a program and simulate it fine. But, when I attempt to download it to the Formula Flowcode, all indications is that the program has been downloaded successfully. However, at the end of the download, two beeps are heard and the Formula Flowcode USB drives are disconnected and the program does not work. Pressing the reset button re-actives the USB drives.

Any suggestions?

Thanks,

Jack

User avatar
Benj
Matrix Staff
Posts: 14216
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4355 times
Been thanked: 4095 times
Contact:

Re: Formula Flowcode connection

Postby Benj » Thu Apr 10, 2008 9:19 am

Hello Jack

It may be that you have the wait for switch function activated. When the buggy is either disconnected from the PC or when the buggy is out of the bootloader mode eg when the PC cannot see the buggy try pressing one of the buttons at the front of the buggy. This should allow the program to start running. You can control this functionality via the properties of the Formula Flowcode component.

aru1989
Posts: 8
Joined: Thu Jan 05, 2012 9:18 am
Has thanked: 5 times
Contact:

Re: Formula Flowcode connection

Postby aru1989 » Thu Jan 05, 2012 10:07 am

I am also having the same issue. I have installed the flowcode and drivers. I have even downloaded a program to the buggy and made it work. But exactly. Means it was said in the tutorial that when it is switched on it blinks 2 led's and once the program is downloaded to the chip the led's will stop blinking.
But in my case only one Led lit constantly.

Now when i tried to download another program for the 2nd time, it says to 'please connect the buggy and reset'. And this time no led's was blinking. Only the led near to the usb was blinking.

I like have ur word on this.

User avatar
DavidA
Matrix Staff
Posts: 1056
Joined: Fri Apr 23, 2010 2:18 pm
Location: Matrix Multimedia Ltd
Has thanked: 58 times
Been thanked: 274 times
Contact:

Re: Formula Flowcode connection

Postby DavidA » Thu Jan 05, 2012 1:27 pm

Hello,

You can tell if your Buggy drivers are working properly by following these instructions.

Firstly start the BuggyProg Tool by browsing to the Tools section within the Flowcode directory (normally C:\Program Files\Matrix Multimedia\Flowcode V4\Tools) and opening the BuggyProg.exe file.

Next open up device manager by right clicking My Computer and selecting properties, Clicking on the Hardware Tab and Clicking the Device manager button.

Once in the device manager expand the section named Universal Serial Bus Controllers and plug in the buggy via USB. If the drivers have been installed correctly then you should see the following.

http://www.matrixmultimedia.com/images/ECIO1.bmp (this is one for ECIO but the buggy works in the exact same way)

If you do not see the item in the BuggyProg software then right click the device in device manager and select uninstall. Then unplug and replug the buggy from the USB and reinstall the most recent drivers from our website.

http://www.matrixmultimedia.com/lc_index.php?p=17

If both the device manager and the EBuggyProg can see the buggy but you are still unable to reprogram then right click the buggy in the device manager and goto the power management tab. In here untick the box that allows Windows to power down the device and click OK.
These users thanked the author DavidA for the post:
aru1989 (Fri Jan 06, 2012 5:01 pm)
Rating: 5.26%
 

aru1989
Posts: 8
Joined: Thu Jan 05, 2012 9:18 am
Has thanked: 5 times
Contact:

Re: Formula Flowcode connection

Postby aru1989 » Fri Jan 06, 2012 2:11 pm

Thanks a lot for the quick reply.
Yes I have tried the steps u have told. But i couldnt find 'BuggyProg.exe' file. Instead I can see only something called 'PICkit2' folder and there is no such file inside that folder too. (I have attached the pic called 'PIC2' with this reply)
And when I connect the buggy to the PC via USB it doesn't show it's name on the device manager.
So is this a problem with the drivers?
Anyway I have downloaded the Buggy driver from the site u have mentioned.
Could u pls tell me among the 3 drivers which one do i have to install?
I have also attached the pic of the buggy driver too in order to make sure its the same drivers u meant.

Thanks in advance for the help.
Attachments
PIC2.PNG
PIC2.PNG (89.37 KiB) Viewed 14007 times
Buggydriver.PNG
Buggydriver.PNG (96.61 KiB) Viewed 14007 times

User avatar
DavidA
Matrix Staff
Posts: 1056
Joined: Fri Apr 23, 2010 2:18 pm
Location: Matrix Multimedia Ltd
Has thanked: 58 times
Been thanked: 274 times
Contact:

Re: Formula Flowcode connection

Postby DavidA » Fri Jan 06, 2012 4:14 pm

Hello,

In Flowcode V3 the BuggyProg.exe is in the root of the Flowcode directory, not in the "tools" section. C:\Program Files\Matrix Multimedia\Flowcode V3\

From the looks of your installation path you are using Windows 7 32bit (this may be wrong and should be checked by going to Control Panel >> System)

Thus you will need the "dpinst_x86.exe" driver
These users thanked the author DavidA for the post:
aru1989 (Fri Jan 06, 2012 5:07 pm)
Rating: 5.26%
 

aru1989
Posts: 8
Joined: Thu Jan 05, 2012 9:18 am
Has thanked: 5 times
Contact:

Re: Formula Flowcode connection

Postby aru1989 » Fri Jan 06, 2012 5:07 pm

Ok now I get the BuggyProg.exe file and I tried it. It too says that the buggy has not found.
I will install the new driver. Thanks a lot

Does the "dpinst_x86.exe" driver works for every OS?
Especially for Windows Xp? Because I like to use it through my laptop also which has XP.

User avatar
DavidA
Matrix Staff
Posts: 1056
Joined: Fri Apr 23, 2010 2:18 pm
Location: Matrix Multimedia Ltd
Has thanked: 58 times
Been thanked: 274 times
Contact:

Re: Formula Flowcode connection

Postby DavidA » Fri Jan 06, 2012 5:17 pm

Hello,

yes the dpinst_x86 will work for all versions of windows XP upwards.
These users thanked the author DavidA for the post:
aru1989 (Fri Jan 06, 2012 11:03 pm)
Rating: 5.26%
 

aru1989
Posts: 8
Joined: Thu Jan 05, 2012 9:18 am
Has thanked: 5 times
Contact:

Re: Formula Flowcode connection

Postby aru1989 » Fri Jan 06, 2012 10:55 pm

Hi David,

I installed the new drivers successfully. But when I plugged the buggy, it ask me to insert the CD. But after that it ask me to select from two buggy hardware of 2 different location; c:\windows\inf\oem46.inf & c:\windows\inf\oem48.inf.
What should i do in this case?

I have uninstalled the previous version as u told in ur's first reply.
Please help me.

User avatar
DavidA
Matrix Staff
Posts: 1056
Joined: Fri Apr 23, 2010 2:18 pm
Location: Matrix Multimedia Ltd
Has thanked: 58 times
Been thanked: 274 times
Contact:

Re: Formula Flowcode connection

Postby DavidA » Mon Jan 09, 2012 4:52 pm

PMs sent and problem solved hopefully :)
These users thanked the author DavidA for the post:
aru1989 (Mon Jan 09, 2012 5:10 pm)
Rating: 5.26%
 

aru1989
Posts: 8
Joined: Thu Jan 05, 2012 9:18 am
Has thanked: 5 times
Contact:

Re: Formula Flowcode connection

Postby aru1989 » Mon Jan 09, 2012 5:13 pm

Yes David, :D
Once again thanks for ur help. :)