Timming issues Flowcode to target 16F684

For E-blocks user to discuss using E-blocks and programming for them.

Moderators: Benj, Mods

Collimare
Posts: 19
Joined: Thu Mar 08, 2012 9:34 pm
Been thanked: 2 times
Contact:

Timming issues Flowcode to target 16F684

Postby Collimare » Tue Jun 05, 2012 10:06 pm

I have downloaded the following code into the target and I have a programmed LED 1 second on time that is 5 - 6 seconds at the target.

What do I need to do to to get them to equal. Thanks, Howard
Attachments
Test16F684.fcf
(6 KiB) Downloaded 138 times

User avatar
DavidA
Matrix Staff
Posts: 1056
Joined: Fri Apr 23, 2010 2:18 pm
Location: Matrix Multimedia Ltd
Has thanked: 58 times
Been thanked: 274 times
Contact:

Re: Timming issues Flowcode to target 16F684

Postby DavidA » Wed Jun 06, 2012 8:41 am

please see this post by medelec, it gives some good advice on clock settings:

If you are still struggling post back.

viewtopic.php?f=26&t=6936

User avatar
Enamul
Posts: 1772
Joined: Mon Mar 05, 2012 11:34 pm
Location: Nottingham, UK
Has thanked: 271 times
Been thanked: 814 times
Contact:

Re: Timming issues Flowcode to target 16F684

Postby Enamul » Tue Jul 17, 2012 1:05 am

Hi Collimare,
You have to use 19.66MHz crystal for the attached program but if you want to use other than that..you have to change that in Build>General options tab>Clock speed and also in Configure Chip you have to set correspondingly.

I have attached here a picture of configure...
Enamul
Attachments
Test16F684.fcf
(6.5 KiB) Downloaded 126 times
16f684.jpg
16f684.jpg (36.63 KiB) Viewed 2135 times
Enamul
University of Nottingham
enamul4mm@gmail.com