ECIO28 and ECIO40P drivers trouble - Win10

For E-blocks user to discuss using E-blocks and programming for them.

Moderators: Benj, Mods

User avatar
Zamphy
Posts: 14
Joined: Sat Sep 26, 2015 11:04 pm
Has thanked: 12 times
Been thanked: 1 time
Contact:

ECIO28 and ECIO40P drivers trouble - Win10

Postby Zamphy » Tue Nov 07, 2017 9:05 pm

Hi to all !
I´m trying to use the ECIO40P and ECIO28P modules with FC7.2.1, more especifically by the MLoader 3.4.1.0.
I tried with Windows 10 Pro and Windows 8 (both 64 bits) with the exact same final results.

First, I installed the more recent avaluable drivers............................................................................................. (see 7 and 8

It seems ok............................................................................................................................................. (see 1 and 2)
althought I didn´t disable the driver signing, and got
a “The USB/VID…. requires an additional instalation ” message.............................................................................. (see 3).

Then I connected an ECIO40P module to USB port, launched Mloader, and it was apparently recognized.............................(see 4).

Second, I tried to load a previous done MC7 test-file to ECIO40, but after “Send” button, I got a frustrating
“Data Validation Failure” error message......................................................................................................... (see 5).

Oddly, I had access to erase it...................................................................................................................... (see 6).

I tried older drivers versions, but they not even begins the installation.
Please, any clue to fix this situation.
Again, Thanks to all.
Attachments
ecio_picts.jpg
ecio_picts.jpg (55.93 KiB) Viewed 1689 times

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 8236
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Has thanked: 2358 times
Been thanked: 3347 times
Contact:

Re: ECIO28 and ECIO40P drivers trouble - Win10

Postby medelec35 » Wed Nov 08, 2017 10:07 am

Hi
Have you tried the drivers from here?

I have not long got a new 64bit windows 10 PC
I will need to install ECIO drivers when I get home tonight.
Will can post on here how I got on.
In the past I have used the drives from the above link with no issues.
That was also with 64bit windows.

Martin
These users thanked the author medelec35 for the post:
Zamphy (Thu Nov 09, 2017 8:13 pm)
Rating: 5.88%
 
Martin

If you read a post that is useful, please show appreciation by clicking on thumbs up Icon.

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 8236
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Has thanked: 2358 times
Been thanked: 3347 times
Contact:

Re: ECIO28 and ECIO40P drivers trouble - Win10

Postby medelec35 » Thu Nov 09, 2017 6:50 pm

I thought I would first try the drivers from the Matrix Web shop
Installed without any issue on my 64 Bit windows 10 Home Version 10.0.15063 Build 15063.
Created a simple flasher to test my ECIO40. Programmed and ran with no issues.
So it looks like the signed version that's on the main website is the same version as on the forums.

Martin
These users thanked the author medelec35 for the post (total 2):
Zamphy (Thu Nov 09, 2017 8:14 pm) • Benj (Fri Nov 10, 2017 12:18 am)
Rating: 11.76%
 
Martin

If you read a post that is useful, please show appreciation by clicking on thumbs up Icon.

User avatar
Zamphy
Posts: 14
Joined: Sat Sep 26, 2015 11:04 pm
Has thanked: 12 times
Been thanked: 1 time
Contact:

Re: ECIO28 and ECIO40P drivers trouble - Win10

Postby Zamphy » Thu Nov 09, 2017 8:12 pm

Hi. You´re spherically right.
End of Trouble with the clue of these drivers.
Really it worked fluently on Windows 10 !! I really appreciate that !
Good luck on your way.

ecio_ok.jpg
ecio_ok.jpg (95.38 KiB) Viewed 1658 times
These users thanked the author Zamphy for the post:
Benj (Fri Nov 10, 2017 12:18 am)
Rating: 5.88%