BL0080 problem

For E-blocks user to discuss using E-blocks and programming for them.

Moderators: Benj, Mods

User avatar
fotios
Posts: 398
Joined: Mon Feb 08, 2010 10:17 am
Location: Greece
Has thanked: 80 times
Been thanked: 97 times
Contact:

BL0080 problem

Postby fotios » Wed May 16, 2018 7:54 am

Hi everyone
I just checked the new E-blocks2 BL0080 PIC multi-programmer with the BL0114 combo board.
I compiled a small fcf just to check the 4X20 LCD display of BL0114.
With the stocked P16F18877 the code is normally compiled without errors and the LCD works as in the code.
I replaced the P16F18877 with a P16F1937, after with a P16F1939 and later with a P16F1789 and in all cases, during compiling, I received this message from the compiler:

Code: Select all

File sent with 1 warnings:
  1: Flash memory not verified - may be due to code protect

The code is not compiled in any of the 3 micros.
Here the simple fcf:
LCDtest.fcfx
(10.51 KiB) Downloaded 29 times

Thanks for any help
Best Regards FOTIS ANAGNOSTOU

User avatar
fotios
Posts: 398
Joined: Mon Feb 08, 2010 10:17 am
Location: Greece
Has thanked: 80 times
Been thanked: 97 times
Contact:

Re: BL0080 problem

Postby fotios » Wed May 16, 2018 11:23 am

Please note that:
I have compiled with success in the past an FCF code for 4X20 LCD display, using the FC v7 and as target either a P16F1939 or a P16F1789 but as a programmer I used my old EB-006 board.
I think the problem is on the side of BL0080 and not on BL0114.
Thanks
Best Regards FOTIS ANAGNOSTOU

User avatar
Benj
Matrix Staff
Posts: 13989
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4253 times
Been thanked: 4008 times
Contact:

Re: BL0080 problem

Postby Benj » Wed May 16, 2018 12:52 pm

Hmm it looks like the 16F1937 chip is being detected and erased but the program is not being loaded.

Investigating this now as it certainly used to work.

User avatar
fotios
Posts: 398
Joined: Mon Feb 08, 2010 10:17 am
Location: Greece
Has thanked: 80 times
Been thanked: 97 times
Contact:

Re: BL0080 problem

Postby fotios » Fri May 25, 2018 7:35 pm

Hi Ben
Any good news to solve the BL0080 problem?
Thanks
Best Regards FOTIS ANAGNOSTOU

User avatar
fotios
Posts: 398
Joined: Mon Feb 08, 2010 10:17 am
Location: Greece
Has thanked: 80 times
Been thanked: 97 times
Contact:

Re: BL0080 problem

Postby fotios » Fri Jun 01, 2018 10:27 am

Hi Ben
After updating the FC7 LCD component with the new LCD.fcpx, neither BL0080 works right now.
Please note that I had no problem with it and P16F18877 so far.
See how it prints
IMG_20180601_121419.jpg
IMG_20180601_121419.jpg (168.09 KiB) Viewed 1130 times

Here my simple fcf to test LCD
LCDtest.fcfx
(10.56 KiB) Downloaded 52 times
Best Regards FOTIS ANAGNOSTOU

User avatar
Benj
Matrix Staff
Posts: 13989
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4253 times
Been thanked: 4008 times
Contact:

Re: BL0080 problem

Postby Benj » Fri Jun 01, 2018 11:32 am

Hello,

Sorry for the problems. I've reverted the LCD component back to how it was originally and this has fixed the problem but causes the problem to re-appear on the ST-ARM.

Here is the original component file to allow you to switch back to get the PIC working again.
LCD.fcpx
(7.54 KiB) Downloaded 21 times
These users thanked the author Benj for the post:
fotios (Fri Jun 01, 2018 11:38 am)
Rating: 5.88%
 

User avatar
Benj
Matrix Staff
Posts: 13989
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4253 times
Been thanked: 4008 times
Contact:

Re: BL0080 problem

Postby Benj » Mon Jun 04, 2018 12:32 pm

New universal fix posted here.
viewtopic.php?f=2&t=20040&start=25#p88651
These users thanked the author Benj for the post:
fotios (Mon Jun 04, 2018 7:17 pm)
Rating: 5.88%