Multi programmer EB 006-00-7

For E-blocks user to discuss using E-blocks and programming for them.

Moderators: Benj, Mods

greenant
Posts: 10
Joined: Mon Sep 18, 2017 8:35 pm
Has thanked: 3 times
Contact:

Multi programmer EB 006-00-7

Postby greenant » Sun Feb 24, 2019 10:03 am

I using Flowcode6 pro under windows10, Up to a week ago my programmer was working fine. Yesterday I tried to compile a program to a chip, but when the compiler reached file send I got the message device not recognised. Pressing reset doesnot help. In the hardware configuration on my PC the programmer is recognised.What can be the problem.

User avatar
Benj
Matrix Staff
Posts: 14075
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4297 times
Been thanked: 4051 times
Contact:

Re: Multi programmer EB 006-00-7

Postby Benj » Mon Feb 25, 2019 6:07 pm

Hello,

Here are some questions on things to look out for.

Have you inserted the microcontroller correctly?
Is there only one Microcontroller inserted?
Have you tried a different microcontroller to ensure the inserted micro is not damaged?
Have you checked the jumper settings are correct?
How are you powering the board? USB or PSU?
Do you have anything external connected to the board, specifically PortB pins 6 and 7 or anything potentially power hungry?

greenant
Posts: 10
Joined: Mon Sep 18, 2017 8:35 pm
Has thanked: 3 times
Contact:

Re: Multi programmer EB 006-00-7

Postby greenant » Tue Feb 26, 2019 12:19 pm

Hey benj
All questions =Yes
I am using PSU and nothing is connected to the programmer.
Driver = Windows/SYS/drivers/mchpusb64.sy
Hope you can help me,

User avatar
Benj
Matrix Staff
Posts: 14075
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4297 times
Been thanked: 4051 times
Contact:

Re: Multi programmer EB 006-00-7

Postby Benj » Tue Feb 26, 2019 12:39 pm

What Microcontroller device are you using?

greenant
Posts: 10
Joined: Mon Sep 18, 2017 8:35 pm
Has thanked: 3 times
Contact:

Re: Multi programmer EB 006-00-7

Postby greenant » Tue Feb 26, 2019 4:25 pm

I am using Pic 16F628A and i tried also PIc 16F 877A both running on 4Mhz set for intosc i/o by both chips same result.

User avatar
Benj
Matrix Staff
Posts: 14075
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4297 times
Been thanked: 4051 times
Contact:

Re: Multi programmer EB 006-00-7

Postby Benj » Tue Feb 26, 2019 4:49 pm

Are you using a 12V power supply? This is required for the PIC device to enter programming mode.

The v7 board is now pretty old maybe one or more of the electrolytic caps have dried out and died?
These users thanked the author Benj for the post:
greenant (Tue Feb 26, 2019 6:01 pm)
Rating: 5.56%
 

greenant
Posts: 10
Joined: Mon Sep 18, 2017 8:35 pm
Has thanked: 3 times
Contact:

Re: Multi programmer EB 006-00-7

Postby greenant » Tue Feb 26, 2019 6:00 pm

I am using a 12VDC power supply. the board is 5or6 years old so may be it is out of order.
thank you for your help, I think I will buy a new programmer.regards.