E-blocks 2 RFID Board (BL0197)

For E-blocks user to discuss using E-blocks and programming for them.

Moderators: Benj, Mods

VladimirRepin
Posts: 26
Joined: Tue Sep 18, 2018 5:22 pm
Has thanked: 1 time
Been thanked: 3 times
Contact:

E-blocks 2 RFID Board (BL0197)

Postby VladimirRepin » Mon Jul 15, 2019 4:27 pm

Hi,

There is a problem with the RFID BL0197 component. This component is not initialized.
The component was connected to the BL0011 Board to B and C ports.

I used the RFID (EB052, RWD MICODE) component in Flowcode 8.2 and tried to set up different ports (B and C) in the connection setup. I set the TX to pin 0, RX to 1 and CTS to 4 (as in E blocks 2 datasheet).

I also tried using RFID (MFRC522) component but it didn't work. Port connection settings are different from that in the datasheet., so I do not think that use this component is correct.

How to use these settings in the right way?
Attachments
Screenshot_4.png
Screenshot_4.png (343.6 KiB) Viewed 425 times

User avatar
Benj
Matrix Staff
Posts: 14243
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4369 times
Been thanked: 4103 times
Contact:

Re: E-blocks 2 RFID Board (BL0197)

Postby Benj » Mon Jul 15, 2019 5:21 pm

Hello,

Here is a program you can try.

Connect a combo board to Ports A and B or an BL0169 LCD to Port B and connect the RFID board to Port C only.

EB2RFID.fcfx
(11.69 KiB) Downloaded 23 times
These users thanked the author Benj for the post:
VladimirRepin (Tue Jul 16, 2019 11:45 am)
Rating: 5.26%
 

VladimirRepin
Posts: 26
Joined: Tue Sep 18, 2018 5:22 pm
Has thanked: 1 time
Been thanked: 3 times
Contact:

Re: E-blocks 2 RFID Board (BL0197)

Postby VladimirRepin » Tue Jul 16, 2019 11:44 am

Thanks, it really works.

I think the problem was that I set TX to 0 and RX to 1, but I had to do the opposite (TX to 1 and RX to 0).