EB020 CPLD Board and windows 7 64-bit?

For E-blocks user to discuss using E-blocks and programming for them.

Moderators: Benj, Mods

barc0de
Posts: 5
Joined: Wed Dec 09, 2009 6:48 pm
Contact:

EB020 CPLD Board and windows 7 64-bit?

Postby barc0de » Sun Dec 13, 2009 10:46 pm

Hi, I don't suppose you have any experimental drivers supporting win7 64bit? I have bought a EB020 CPLD board and cannot currently use it for my uni work.

I don't mind beta testing any if you have.

Cheers,

Damien

User avatar
Benj
Matrix Staff
Posts: 14223
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4363 times
Been thanked: 4096 times
Contact:

Re: EB020 CPLD Board and windows 7 64-bit?

Postby Benj » Mon Dec 14, 2009 10:50 am

Hello Damien

I will look into this for you as I am also running Win 7 64-bit. Illl let you know how I get on.

barc0de
Posts: 5
Joined: Wed Dec 09, 2009 6:48 pm
Contact:

Re: EB020 CPLD Board and windows 7 64-bit?

Postby barc0de » Mon Dec 14, 2009 4:43 pm

Benj wrote:Hello Damien

I will look into this for you as I am also running Win 7 64-bit. Illl let you know how I get on.


That would be great. I don't suppose you would have a time frame as my work has already begun and it is due early December.

As I said I don't mind testing out experimental/beta drivers.

Cheers,

Damien

barc0de
Posts: 5
Joined: Wed Dec 09, 2009 6:48 pm
Contact:

Re: EB020 CPLD Board and windows 7 64-bit?

Postby barc0de » Mon Jan 04, 2010 7:42 pm

Have you got any news regarding the drivers Ben?

Regards.

User avatar
Benj
Matrix Staff
Posts: 14223
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4363 times
Been thanked: 4096 times
Contact:

Re: EB020 CPLD Board and windows 7 64-bit?

Postby Benj » Tue Jan 05, 2010 10:21 am

Hello

Sorry this slipped my mind completely. Many apologies.

I have managed to dig out some 64-bit drivers that should be compatible with the EB020. Please give these beta drivers a go, I will also try them out tonight and let you know how I get on.
Attachments
EB020 Beta Drivers.zip
(93.96 KiB) Downloaded 139 times

barc0de
Posts: 5
Joined: Wed Dec 09, 2009 6:48 pm
Contact:

Re: EB020 CPLD Board and windows 7 64-bit?

Postby barc0de » Tue Jan 05, 2010 8:52 pm

Hi Ben,

I don't know if you have had any luck but i've installed the driver and can configure it (Putting windows 7 into test mode and signing the driver so it can be loaded by windows). But when I install the ECP printer port and try to set it's resource settings manually, all of the preset I/O ranges selectable in the Matrix driver are all occupied by the PCI bus on my machine. I'm not sure what to do from here. Any suggestions?

Cheers

Damo

barc0de
Posts: 5
Joined: Wed Dec 09, 2009 6:48 pm
Contact:

Re: EB020 CPLD Board and windows 7 64-bit?

Postby barc0de » Sun Jan 10, 2010 11:40 am

Hello again,
I've managed to get it all working under Virtual PC 2009 (Win7's XP Mode). Thanks for your assistance Ben with the drivers. I would test any new revisions you might have if you like.

Kind Regards,

Damien

gegg
Posts: 1
Joined: Mon Aug 27, 2018 1:06 pm
Contact:

Re: EB020 CPLD Board and windows 7 64-bit?

Postby gegg » Mon Aug 27, 2018 1:15 pm

Hi, I am new on the forum but use EB020 for over 6 years now in my class. We are upgrading the PC's (finally) to WIN10 but encountered the above problem. I've tried you beta driver, but no use. WIN 10 has no virtual XP as far as I know. Do you have a solution ?

Thanks,
Geert.