Page 1 of 1

call stack window missing

Posted: Mon Nov 17, 2008 2:15 pm
by achillis1
Sometimes it happens that when I press the "step into" or "step over" button the call stack and sometimes the variable window gets out of the screen!!!
I select "view" and the variable and call stack options are ticked.
To find the 2 windows I must open flowcode in a small window in order to see the call stack a little further than the main window of flowcode.
I do not know if this is a bug or some mistake I do!
Best Regards.

Re: call stack window missing

Posted: Mon Nov 17, 2008 3:36 pm
by Steve
Yes - this is a bug I am aware of and will fix in v4.

Re: call stack window missing

Posted: Sun Feb 08, 2009 5:59 pm
by medelec35
I Have a similar problem, but its with variables window. OS= Vista home Premium. This bug for me is only present on Flowcode V3.6.11.53,
it is not present on V3.4.7.8
When using stepping (F8 key) using V3.6.11.53 the variables window either totally disappeared, or was infinitely wide, so as you dragged variables window to the left, the window just redrawn filling whole width of screen again. Also when stepping, and bug is present, it took seconds to step from one symbol to the next.
Whereas in V3.4.7.8 it was instant.

Re: call stack window missing

Posted: Mon Feb 09, 2009 6:03 pm
by Benj

I experienced similar problems when running XP with a corrupted registry. I created a new user account in Windows and then logged in as that user. The problem in Flowcode had vanished and confirmed that it was a corrupted registry to blame. Not sure if there is much you can do without reinstalling windows as registry repair is dodgy at best esp with all these third party providers trying to get a piece of the action.

If the new user account works for you then at least you have confirmed that the problem is something to do with your current user registry.

Let us know how you get on.

Re: call stack window missing

Posted: Tue Feb 10, 2009 10:24 am
by medelec35
Thanks for letting me know. I have installed on another vista account, and all is working.

However I what I have found the the account with the problem, is a bit strange.

If I click on a file with .fcf extension, then it loads Flowcode, I have the problem with the variables windows again.
However If I run Flowcode 1st, then use file menu in Flowcode to load the same .fcf file, then there is no problem with variables window.
Does that info give any clues to which part of reg is corrupt?

Re: call stack window missing

Posted: Tue Feb 10, 2009 12:02 pm
by Steve
I don't think it is due to registry corruption, but the problem is due to the wrong data being stored in the registry.

WARNING: the following information involves directly editing the registry. You can seriously mess-up your installation of Windows and/or other programs by editing the registry in this way. If you are not 100% confident about editing the registry, then I strongly recommend you stop reading this post now! I've got to say this because we cannot be held responsible for any mistakes that may occur when you edit your registry.

If you are happy to manually edit the registry, then to fix the problem you should close Flowcode, then navigate to the following registry location:

Code: Select all


And delete the following 2 entries:

Code: Select all


When you restart Flowcode, the windows should be visible.

If this does not work, then you should open Flowcode, make sure the window is not maximized and then position it on screen so that all 4 edges of the window are visible and there is a gap of at least 5cm between the right edge of Flowcode and the right edge of the screen. Then close down Flowcode and then perform the registry edits as described. Reloading Flowcode and keeping the main window position as it is should allow the other windows to display correctly.

Re: call stack window missing

Posted: Tue Feb 10, 2009 2:35 pm
by medelec35
Seems it not as simple as that.
I deleted registry entries as instructed. Loaded Flowcode form start menu.
Variable and call stack windows loaded normally: FIG. 1

Closed Flowcode, Reopened Flowcode via start menu, all OK so-far.
here is Reg entries, with Flowcode working normally: FIG. 2

Now I close Flowcode again, and recheck reg entries to make sure still the same.
I double click on a fcf file, then the following happens: FIG. 3

Note: When this happens you cannot click on the left edge of variables window to resize, it just disappears until Flowcode is reloaded.
Here is reg entry every time a .fcf file is click on to open Flowcode: FIG. 4

(137.46 KiB) Downloaded 3070 times

Re: call stack window missing

Posted: Tue Feb 10, 2009 2:41 pm
by Steve
Thanks for the extra info. I will try to make it work better in v4.

Re: call stack window missing

Posted: Tue Feb 10, 2009 2:58 pm
by medelec35
Thanks Steve. One thing I did forget to mention, If click onto start and run Flowcode from there after the problem has shown up, i.e Reg entries are is Fig. 4
Although the variable window is now huge, I Can actually adjust the size so its back to normal. Where as I cannot adjust its size as explained in previous post, If Flowcode is opened by clicking on to a CF file.
I am trying to give you as much detail as possible, help you assess what has gone wrong.
But for me its not the end of the world, since Flowcode has enable me to program a pic chip, with software which would have been well out of my league, in such a short space of time .
I Cant wait until V4.. Out soon I hope 8)