Error in USBSlave_code.c after update to v3.6.11.53

Forum for problems or queries regarding the Flowcode application and compiler usage.

Moderators: Benj, Mods

kersing
Valued Contributor
Valued Contributor
Posts: 1873
Joined: Wed Aug 27, 2008 10:31 pm
Location: Netherlands
Has thanked: 530 times
Been thanked: 1040 times
Contact:

Error in USBSlave_code.c after update to v3.6.11.53

Postby kersing » Mon Mar 02, 2009 10:16 pm

Hi,

After updating Flowcode (for PIC) to 3.6.11.53 using the 3.4/3.5 updater code using the USB Slave component does not compile. The error is caused by a typo on line 375 of USBDlave_code.c, it reads '#els' and should be '#else'.

Best regards,

Jac
“Integrity is doing the right thing, even when no one is watching.”

― C.S. Lewis

User avatar
Steve
Matrix Staff
Posts: 3071
Joined: Tue Jan 03, 2006 3:59 pm
Has thanked: 87 times
Been thanked: 387 times
Contact:

Re: Error in USBSlave_code.c after update to v3.6.11.53

Postby Steve » Tue Mar 03, 2009 9:13 am

Hi Jac,

Thanks very much for spotting this. I hope it did not cause you too much of a headache!

I'll make sure there is an FAQ put up about this.

User avatar
Benj
Matrix Staff
Posts: 14151
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4330 times
Been thanked: 4080 times
Contact:

Re: Error in USBSlave_code.c after update to v3.6.11.53

Postby Benj » Wed Mar 04, 2009 2:12 pm

Hello Jac

Sorry about this. I have now fixed all three sets of files to allow the components to work correctly. The problem only appears when the enumertaion wait setting is activated inside the USB component.

Details can be found here on our FAQ.
http://www.matrixmultimedia.com/support ... .php?t=548