Installation on Vista error(version 3)

Forum for problems or queries regarding the Flowcode application and compiler usage.

Moderators: Benj, Mods

User avatar
achillis1
Posts: 347
Joined: Thu Oct 09, 2008 9:19 am
Has thanked: 92 times
Been thanked: 8 times
Contact:

Installation on Vista error(version 3)

Postby achillis1 » Wed Nov 18, 2009 5:46 am

Hello,
I have installed my flowcode version 3 on windows Vista ultimate and some errors just poped out. I will attach the errors.
After that I installed SP1 for flowcode and now is V3.4.7.48 I do not know if this solves the errors.
Also the attachment is for only one error. There also were errors for tcp-ip stack and e.t.c I do not remember exactly now! I think it was for all peripherals(bluetooth, usb...)
Thank you in advance,
Best Regards,
Achillis.
Attachments
flow error.jpg
flow error.jpg (108.39 KiB) Viewed 5183 times

User avatar
achillis1
Posts: 347
Joined: Thu Oct 09, 2008 9:19 am
Has thanked: 92 times
Been thanked: 8 times
Contact:

Re: Installation on Vista error(version 3)

Postby achillis1 » Wed Nov 18, 2009 6:09 am

Hello,
I have tried to install the usb PACK on Vista and the following errors appeared, I will upload attachments.
The usb components do not work.
Thank you.
Attachments
flow error4.jpg
flow error4.jpg (77.39 KiB) Viewed 5178 times
flow error3.jpg
flow error3.jpg (71.29 KiB) Viewed 5178 times
flow error2.jpg
flow error2.jpg (71.15 KiB) Viewed 5178 times

User avatar
Steve
Matrix Staff
Posts: 3071
Joined: Tue Jan 03, 2006 3:59 pm
Has thanked: 87 times
Been thanked: 387 times
Contact:

Re: Installation on Vista error(version 3)

Postby Steve » Wed Nov 18, 2009 7:58 am

I've seen this error, but I can't remember its cause. It could be that certain windows libraries are not present on the PC, or it could be that you need to install

One thing to try is to upgrade Flowcode V3 to the latest version (i.e. v3.6) - this might fix the problem.

User avatar
achillis1
Posts: 347
Joined: Thu Oct 09, 2008 9:19 am
Has thanked: 92 times
Been thanked: 8 times
Contact:

Re: Installation on Vista error(version 3)

Postby achillis1 » Wed Nov 18, 2009 2:54 pm

Hello,
Thank you Steve for your reply. I have installed the Flowcode update and that installed automatically the USB components. Yet still flowcode could not compile my flowcharts.
I am attaching the errors. After that I installed again the USB pack and had the above error again. Then I just moved the USB serial component macro(usb initialise) out of my loop and compiled again. This time flowcode did more time to write "succes" but it did-with errors. The first attachment will describe the errors from the successful compilation. After that I tested the ECIO with a VB application that reads the COM port and it works!!!!

Now comes the bizzard! After that I moved in the loop the macro for initialisation of the USB serial and the compilation was successfull but the ECIO could not connect on my COM port.
So I took the macro out of the loop, compiled again and...voila! ECIO connected to COM port!!!
1.Is it a bug?
2.What about the error codes at the second screen shot? Will they make any problems?

Also Steve, the problem that I had to take the macro out of the loop or in(I think at some cases) appeared on me several times before(on Windows XP) and it was regarding the LCD component. A part of the compiler message was like this: "If your flowchart containes any C code please revise.....".

Hope that some information above is helpful!
Thank you,
Best Regards,
Achillis.
Attachments
flow error6.jpg
flow error6.jpg (194.16 KiB) Viewed 5159 times
flow error5.jpg
flow error5.jpg (95.79 KiB) Viewed 5159 times

User avatar
Steve
Matrix Staff
Posts: 3071
Joined: Tue Jan 03, 2006 3:59 pm
Has thanked: 87 times
Been thanked: 387 times
Contact:

Re: Installation on Vista error(version 3)

Postby Steve » Wed Nov 18, 2009 3:12 pm

You should post your FCF and C files for us to have a look at.

User avatar
achillis1
Posts: 347
Joined: Thu Oct 09, 2008 9:19 am
Has thanked: 92 times
Been thanked: 8 times
Contact:

Re: Installation on Vista error(version 3)

Postby achillis1 » Wed Nov 18, 2009 3:41 pm

Thank you.
Attachments
succes_afterSomeDelay.fcf
succeded after some seconds
(4.5 KiB) Downloaded 197 times
(failure_ttt).fcf
failed to compile
(4 KiB) Downloaded 187 times
flowcode 08-11-2009 for RFID.fcf
failed to compile
(17.17 KiB) Downloaded 198 times

User avatar
Benj
Matrix Staff
Posts: 14151
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4330 times
Been thanked: 4080 times
Contact:

Re: Installation on Vista error(version 3)

Postby Benj » Thu Nov 19, 2009 9:31 am

Hello Achillis

The failure_ttt program is not compiling because it is an empty program. You have added a USB component but not referenced it anywhere in the program so the code for this has not been added. However there is a call from the interrupt service routine to service the USB which is causing the compilation error. If you either remove the component or add some code to the program then it will compile ok.

The 08-11-2009 program has the same problem only it is the RFID component that is now causing the problems.

You should generally always remove all unused components from your program.

User avatar
achillis1
Posts: 347
Joined: Thu Oct 09, 2008 9:19 am
Has thanked: 92 times
Been thanked: 8 times
Contact:

Re: Installation on Vista error(version 3)

Postby achillis1 » Fri Nov 20, 2009 4:55 pm

Hello,

Removed the unused components and seems to be compiling OK!
Thank you a lot for your remarks.

What about the warning message: "Warning unreferenced functions removed:
FCD_USBSerial0_GetDefines in: C:\Users\matrices\Desktop\temp\temp.c
FCD_USBSerial0_SendByte in: C:\Users\matrices\Desktop\temp\temp.c
FCD_USBSerial0_SendString in: C:\Users\matrices\Desktop\temp\temp.c
FCD_USBSerial0_ReadString in: C:\Users\matrices\Desktop\temp\temp.c
usb_get_state in: C:\Program Files\Matrix Multimedia\Flowcode V3\BoostC\include\USB\pic_usb.c
usb_cdc_putc in: C:\Program Files\Matrix Multimedia\Flowcode V3\BoostC\include\USB\usb_cdc_class.c
usb_cdc_tx_empty in: C:\Program Files\Matrix Multimedia\Flowcode V3\BoostC\include\USB\usb_cdc_class.c
usb_cdc_print_str in: C:\Program Files\Matrix Multimedia\Flowcode V3\BoostC\include\USB\usb_cdc_class.c
MX_USBSERIAL_Dummy_Function in: C:\Users\matrices\Desktop\temp\temp.c "
This is from a succesfull compilation, will be a problem afterwards? I will attach the appropriate fcf file.

Thank you in advance,
Best Regards,
Achillis
Attachments
temp.fcf
(4.5 KiB) Downloaded 203 times

User avatar
Steve
Matrix Staff
Posts: 3071
Joined: Tue Jan 03, 2006 3:59 pm
Has thanked: 87 times
Been thanked: 387 times
Contact:

Re: Installation on Vista error(version 3)

Postby Steve » Thu Nov 26, 2009 9:41 am

You can safely ignore these warnings.