Arduino Uno, no ejecuta programa

Foro para hablantes de español que deseen escribir en su lengua materna.

Moderator: Benj

User avatar
badir79
Posts: 12
Joined: Mon Oct 29, 2012 10:44 pm
Has thanked: 3 times
Been thanked: 2 times
Contact:

Arduino Uno, no ejecuta programa

Postby badir79 » Sun Jun 08, 2014 11:41 pm

Buenas tardes!
Estoy tratando de programar un Arduino Uno R3 (Atmega 328p - 16MHz) directamente desde Flowcode V4/AVR.

Aparentemente el programa se carga bien, adjunto el log.

Pero una vez cargado, el programa no ejecuta ninguna opción, sospecho que el problema se puede encontrar en la configuración de los fuses, pero no estoy seguro de las palabras de configuración correctas que debo usar.

Si alguien puede ayudarme les agradezco mucho...

Saludos,

**********************************************************************************************************************************************************************************************************
Launching the compiler...
C:\Program Files\Matrix Multimedia\Flowcode AVR V4\Tools\MX_bats\avra.bat atmega328p "C:\Users\\Desktop\FLOWCO~1\led_on_off.elf" "C:\Users\\Desktop\FLOWCO~1\led_on_off.c" "C:\Users\\Desktop\FLOWCO~1\led_on_off.lst"

C:\Users\\Desktop\Flowcode - ARDUINO>"C:\PROGRA~1\MATRIX~1\FLOWCO~1\Tools\MX_bats\..\bin\avr-gcc.exe" -mmcu=atmega328p -Os -funsigned-char -o "C:\Users\\Desktop\FLOWCO~1\led_on_off.elf" "C:\Users\\Desktop\FLOWCO~1\led_on_off.c" -lm

C:\Users\\Desktop\Flowcode - ARDUINO>"C:\PROGRA~1\MATRIX~1\FLOWCO~1\Tools\MX_bats\..\bin\avr-objdump.exe" -S "C:\Users\\Desktop\FLOWCO~1\led_on_off.elf" 1>"C:\Users\Desktop\FLOWCO~1\led_on_off.lst"

C:\Users\\Desktop\Flowcode - ARDUINO>"C:\PROGRA~1\MATRIX~1\FLOWCO~1\Tools\MX_bats\..\bin\avr-size.exe" -B -d "C:\Users\\Desktop\FLOWCO~1\led_on_off.elf"
text data bss dec hex filename
248 0 22 270 10e C:\Users\\Desktop\FLOWCO~1\led_on_off.elf

Compilation successful!

Return code = 0

Launching the linker/assembler...
C:\Program Files\Matrix Multimedia\Flowcode AVR V4\Tools\MX_bats\avrb.bat "C:\Users\\Desktop\FLOWCO~1\led_on_off.elf" "C:\Users\\Desktop\FLOWCO~1\led_on_off.hex" "C:\Users\\Desktop\FLOWCO~1\led_on_off.cof"

C:\Users\Someone\Desktop\Flowcode - ARDUINO>"C:\PROGRA~1\MATRIX~1\FLOWCO~1\Tools\MX_bats\..\bin\avr-objcopy" -O ihex -R .eeprom "C:\Users\Someone\Desktop\FLOWCO~1\led_on_off.elf" "C:\Users\Someone\Desktop\FLOWCO~1\led_on_off.hex"

HEX file creation successful!

C:\Users\Someone\Desktop\Flowcode - ARDUINO>"C:\PROGRA~1\MATRIX~1\FLOWCO~1\Tools\MX_bats\..\bin\avr-objcopy" -O coff-avr -R .eeprom "C:\Users\Someone\Desktop\FLOWCO~1\led_on_off.elf" "C:\Users\Magda\Desktop\FLOWCO~1\led_on_off.cof"

COFF file creation successful!

Return code = 0

Launching the programmer...
C:\Program Files\Matrix Multimedia\Flowcode AVR V4\Tools\MX_bats\avrc_arduinoA.bat m328p stk500 com3 115200 "led_on_off.hex

C:\Users\Someone\DesktopFlowcode - ARDUINO>"C:\PROGRA~1\MATRIX~1\FLOWCO~1\Tools\MX_bats\..\AVRDUDEusb\avrdude.exe" -p m328p -P com3 -b 115200 -c stk500 -U flash:w:"led_on_off.hex
avrdude.exe: successfully opened stk500v1 device -- please use -c stk500v1

avrdude.exe: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% -0.00s

avrdude.exe: Device signature = 0x1e950f
avrdude.exe: NOTE: FLASH memory has been specified, an erase cycle will be performed
To disable this feature, specify the -D option.
avrdude.exe: erasing chip
avrdude.exe: reading input file "led_on_off.hex "
avrdude.exe: input file led_on_off.hex auto detected as Intel Hex
avrdude.exe: writing flash (248 bytes):

Writing | ################################################## | 100% 0.05s

avrdude.exe: 248 bytes of flash written
avrdude.exe: verifying flash memory against led_on_off.hex :
avrdude.exe: load data flash data from input file led_on_off.hex :
avrdude.exe: input file led_on_off.hex auto detected as Intel Hex
avrdude.exe: input file led_on_off.hex contains 248 bytes
avrdude.exe: reading on-chip flash data:

Reading | ################################################## | 100% 0.03s

avrdude.exe: verifying ...
avrdude.exe: 248 bytes of flash verified

avrdude.exe: safemode: Fuses OK

avrdude.exe done. Thank you.


Programming successful!

Return code = 0

FINISHED

**********************************************************************************************************************************************************************************************************

dazz
Posts: 1314
Joined: Sun Jan 15, 2012 3:15 pm
Has thanked: 514 times
Been thanked: 467 times
Contact:

Re: Arduino Uno, no ejecuta programa

Postby dazz » Thu Jun 19, 2014 12:13 pm

¡Hola
Puede publicar su organigrama, ya que el problema puede estar allí, no hay fusibles para establecer con un arduino

saludo

Hi
can you post your flowchart, as the issue may lie there , there are no fuses to set with an arduino

Regards
Dazz
To sign up to the V5 forum follow this link http://www.matrixmultimedia.com/forum_upgrades.php