Illegal redefinition of symbol: MX_UART_RTS_PORT

Moderator: Benj

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 8440
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Has thanked: 2412 times
Been thanked: 3451 times
Contact:

Illegal redefinition of symbol: MX_UART_RTS_PORT

Postby medelec35 » Fri Jan 27, 2012 9:48 pm

This is cause by a bug in the FC5_PIC_RS232.c file.
If 64bit windows go to C:\Program Files (x86)\Flowcode\v5\Components
or
If 32bit windows go to C:\Program Files\Flowcode\v5\Components
Make a copy of FC5_PIC_RS232.c
then replace original with attached file.
Hopefully flowchart that had the above error will compile successfully.

Martin
Attachments
FC5_PIC_RS232.c
(9.82 KiB) Downloaded 151 times
These users thanked the author medelec35 for the post (total 2):
JonnyW (Fri Jan 27, 2012 9:58 pm) • Steve (Mon Jan 30, 2012 9:43 am)
Rating: 10.53%
 
Martin

If you read a post that is useful, please show appreciation by clicking on thumbs up Icon.

Ondra
Posts: 325
Joined: Wed Aug 29, 2007 7:33 pm
Been thanked: 2 times
Contact:

Re: Illegal redefinition of symbol: MX_UART_RTS_PORT

Postby Ondra » Sat Jan 28, 2012 1:20 am

It compiled Thank. I haven't tested it on the board yet.
Thanks again for your help.

Ondra

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 8440
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Has thanked: 2412 times
Been thanked: 3451 times
Contact:

Re: Illegal redefinition of symbol: MX_UART_RTS_PORT

Postby medelec35 » Sat Jan 28, 2012 11:43 pm

Your welcome.
Since I have not tested it on hardware. Hopefully it will work.

Thanks for letting us know. :)

Martin
Martin

If you read a post that is useful, please show appreciation by clicking on thumbs up Icon.

jgu1
Posts: 1104
Joined: Tue Oct 06, 2009 9:39 am
Has thanked: 1010 times
Been thanked: 255 times
Contact:

Re: Illegal redefinition of symbol: MX_UART_RTS_PORT

Postby jgu1 » Thu Feb 02, 2012 8:46 am

Hello!

Now I discover again that there is an error or a change. Would not it be a good idea, every time there is a correction and place it in the forum for fix. Or is there something I have misunderstood or overlooked :?:

Best regard

Jorgen.

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 8440
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Has thanked: 2412 times
Been thanked: 3451 times
Contact:

Re: Illegal redefinition of symbol: MX_UART_RTS_PORT

Postby medelec35 » Thu Feb 02, 2012 11:12 am

Hi Jorgen,
This error was first reported here:
viewtopic.php?f=29&t=10105&p=31765&#p31758
To keep all errors together, so don't have to keep searching, I posted fix in this 'Flowcode V5 Issues' thread along with other fixes.
I also posted a link to here on the thread error was first reported.

I guess its now down to MM from that point.
I thought this way was the way you wanted it to work?

Unless I misread your post?
These users thanked the author medelec35 for the post:
jgu1 (Thu Feb 02, 2012 5:38 pm)
Rating: 5.26%
 
Martin

If you read a post that is useful, please show appreciation by clicking on thumbs up Icon.

jgu1
Posts: 1104
Joined: Tue Oct 06, 2009 9:39 am
Has thanked: 1010 times
Been thanked: 255 times
Contact:

Re: Illegal redefinition of symbol: MX_UART_RTS_PORT

Postby jgu1 » Thu Feb 02, 2012 5:42 pm

Hi Martin! :D

Yes something like that. I think it would be easier if all the fix´s is ​​in the same place. Or finally MM wil make a total update for V.5

Thank you very much.

Jorgen

User avatar
Steve
Matrix Staff
Posts: 3073
Joined: Tue Jan 03, 2006 3:59 pm
Has thanked: 87 times
Been thanked: 387 times
Contact:

Re: Illegal redefinition of symbol: MX_UART_RTS_PORT

Postby Steve » Thu Feb 02, 2012 6:41 pm

We will be posting a patch soon. In the meantime we will post quick fixes and workarounds here.

Please keep the issues coming in!
These users thanked the author Steve for the post:
jgu1 (Thu Feb 02, 2012 9:02 pm)
Rating: 5.26%