pIC18F26K80 mystery

For Flowcode users to discuss projects, flowcharts, and any other issues related to Flowcode 6.

Moderator: Benj

User avatar
JLeith
Posts: 519
Joined: Wed Nov 14, 2012 7:49 pm
Location: British Columbia Canada
Has thanked: 143 times
Been thanked: 24 times
Contact:

pIC18F26K80 mystery

Postby JLeith » Sat Aug 24, 2019 3:01 am

Hello
Have a odd experiment with my PIC18F26K80 ?
I'm having trouble with RC5 ?
I'm using C5 as a Output for my MOSI connection to a NFR905 and I can't get it to work.
I'm sending C5 a Logic 1 (on) and then 5 sec send Logic 0.

I have a LED on my bread board and C5 will not trigger.

Now from the documents it looks like C5 should work. When I put a LED on the Flowcode C5 it lights. But not on the Bread Board.

My picture C5 is the flowcode listing
My picture R5 & C5 is from the Pic18 Documents

R5 indicates Analog where C5 doesn't

Hope someone has worked with the PIC18F16K80 and can shed some light on Issue.

John
Attachments
R5 & C5.png
R5 & C5.png (11 KiB) Viewed 221 times
C5.png
C5.png (6.78 KiB) Viewed 221 times

User avatar
Benj
Matrix Staff
Posts: 14157
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4330 times
Been thanked: 4080 times
Contact:

Re: pIC18F26K80 mystery

Postby Benj » Wed Aug 28, 2019 4:18 pm

Hi John,

Is it just pin C5 that's not working? Have you confirms that the device is actually running. It could be that your current configuration settings are maybe not correct and the MCU is not running? I can't see much that would stop the pin from working correctly as an output.

Can you post your program and also comment on how you are clocking the MCU and driving the MCLR etc.

User avatar
JLeith
Posts: 519
Joined: Wed Nov 14, 2012 7:49 pm
Location: British Columbia Canada
Has thanked: 143 times
Been thanked: 24 times
Contact:

Re: pIC18F26K80 mystery

Postby JLeith » Fri Aug 30, 2019 5:46 pm

Hello Benj
Thank you for helping me figure how to make the PIC18F26K80 work.

I looked and almost every possible PIC 16 & 18 that would work in Flowcode and The PIC18F26K80 has the most Ram and my design has reached such a need.

I think the answer is the PIC18 is lacking the I/O ports that work with the NFR905 ?

I did the LED 1sec timer that Martin suggested and it worked.

I can load the pic and it will run and displays the Text of "Ready" but the NFR905 does not function on the selected ports?

I did a simple I/O study by Study macro that would do a On / Off state of the NFR905 ports and found they don't support I/O action. I tried to change them but could not make the NFR905 work.

I checked and the NFR905 worked in the Master state so the NFR905 is working. I double checked the connection 6 or 7 times.

The PIC16F1938 worked when my design was fundamental with Ram Size. I was hoping to include Spring and Summer selections so I didn't need to take apart my Spring programmed box and load the Summer. Then my vision for Spring & Summer ran into Ram problems as I discovered the OLED displays.

Maybe there is a way to set the Ports in the PIC18F26K80 to I/O. Or a PIC that has RAM that is more then the PIC16F1983 Ram 1024.

I have attached the Development design and the current flowcode.

Another thought is the OLED module might be using a lot more RAM then a LCD in my past designs.

The PIC18F26K80 SRAM 3648 saves my Hex with 80% still available Nice Memory but not enough I/O ports I think

John
Attachments
Team with OLED Aug 29 2019.fcfx
(102.15 KiB) Downloaded 9 times
PIC18F26K80 905 and OLED Design.jpg
PIC18F26K80 905 and OLED Design.jpg (80.68 KiB) Viewed 147 times