Coding sending to hardware issues

For Formula AllCode users to discuss projects, programs, and any other issues related to the Formula AllCode robotics platform.

Moderators: Benj, Mods

gidi1181
Posts: 8
Joined: Mon Jan 22, 2018 6:31 am
Has thanked: 1 time
Been thanked: 1 time
Contact:

Coding sending to hardware issues

Postby gidi1181 » Mon Jan 22, 2018 6:51 am

Dear Matrix,

I have problem in interface between all code bugg with my C# code. I have debug my code successfully and never see the result in LCD display on All code bugg. Please support me to run the code in all code bugg.

Thanks ad Regads,
Gideon.

User avatar
Benj
Matrix Staff
Posts: 14151
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4330 times
Been thanked: 4080 times
Contact:

Re: Coding sending to hardware issues

Postby Benj » Mon Jan 22, 2018 11:42 am

Hi Gideon,

Can you attach your C# program so we can have a look for you, you might need to zip the files up into a .zip or .rar archive.

Also have you tried the C# examples on our website and are they working as expected?
These users thanked the author Benj for the post:
gidi1181 (Tue Jan 23, 2018 5:20 am)
Rating: 5.56%
 

gidi1181
Posts: 8
Joined: Mon Jan 22, 2018 6:31 am
Has thanked: 1 time
Been thanked: 1 time
Contact:

Re: Coding sending to hardware issues

Postby gidi1181 » Tue Jan 23, 2018 5:36 am

Hello Benj,

Am using your code only from matrix website. But the issue is am not able see the output. The code is following

Code: Select all

using System;
using System.Runtime.InteropServices;

namespace FormulaAllCode
{
    class Program
    {
        static void Main(string[] args)
        {
            //Assign Port Number - Remember to change this to match your Formula AllCode port number
            char PortNumber = (char) 24;

            //Open Port
            FA_DLL.FA_ComOpen(PortNumber);

            //Send Play Note Command
            FA_DLL.FA_PlayNote(PortNumber, 500, 100);
            FA_DLL.FA_PlayNote(PortNumber, 100, 100);
            FA_DLL.FA_PlayNote(PortNumber, 600, 100);

            //Print String on LCD
            FA_DLL.FA_LCDClear(PortNumber);
            FA_DLL.FA_LCDPrintString(PortNumber, 19, 8, "Formula AllCode");
            FA_DLL.FA_LCDPrintString(PortNumber, 34, 16, "C# Example");

            //Close Port
            FA_DLL.FA_ComClose(PortNumber);
        }
    }
}

Formula all code is connected thru Bluetooth and outgoing port number is 24.

User avatar
Benj
Matrix Staff
Posts: 14151
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4330 times
Been thanked: 4080 times
Contact:

Re: Coding sending to hardware issues

Postby Benj » Tue Jan 23, 2018 6:34 pm

Hello,

When you switch on the Formula AllCode do you get a screen saying battery level followed by a screen saying MODE = API?

If you do get this then there should be a version number at the top right of the display. What's your version number? V3 is the latest.

If you do not get this then you will need to reflash the Formula AllCode using mLoader and the latest v3 firmware available on the AllCode resources page of the website.

gidi1181
Posts: 8
Joined: Mon Jan 22, 2018 6:31 am
Has thanked: 1 time
Been thanked: 1 time
Contact:

Re: Coding sending to hardware issues

Postby gidi1181 » Tue Jan 30, 2018 6:31 am

Hello Benj,

Thank u for great support. I have update my formula all code as per your instruction.
Now its working in scratch successfully. And am facing more problem while install Visual studio 2015 for C# coding. Any other tool is there for C# coding instead of Visual stdio.

gidi1181
Posts: 8
Joined: Mon Jan 22, 2018 6:31 am
Has thanked: 1 time
Been thanked: 1 time
Contact:

Re: Coding sending to hardware issues

Postby gidi1181 » Sat Feb 03, 2018 5:57 am

Hello Benj,

There is a problem occurs for C++ debug in formula all code. The error is attached for your reference. Kindly provide me the solution for this issue asap.
Attachments
C++Error.png
C++Error.png (244.7 KiB) Viewed 3557 times

User avatar
Benj
Matrix Staff
Posts: 14151
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4330 times
Been thanked: 4080 times
Contact:

Re: Coding sending to hardware issues

Postby Benj » Mon Feb 05, 2018 11:35 am

Hello,

Some potential fixes here for you.
https://stackoverflow.com/questions/442 ... 17-c-error

gidi1181
Posts: 8
Joined: Mon Jan 22, 2018 6:31 am
Has thanked: 1 time
Been thanked: 1 time
Contact:

Re: Coding sending to hardware issues

Postby gidi1181 » Mon Feb 05, 2018 1:16 pm

Hello,

Thank you for your continuous support. I need the coding for maze, follow line and play music in formula all code using scratch and python. Can you support me???

User avatar
Benj
Matrix Staff
Posts: 14151
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4330 times
Been thanked: 4080 times
Contact:

Re: Coding sending to hardware issues

Postby Benj » Mon Feb 05, 2018 6:24 pm

Hello,

Thank you for your continuous support


You're very welcome.

I need the coding for maze, follow line and play music in formula all code using scratch and python.


Yes I can help, but no I won't do the work for you. Have a go, see where you get and then come back and ask questions on the specific problems you have.

Also remember Google is your friend and can often lead you down different avenues that you would never have thought of. For example tried and tested algorithms for line following and maze solving should be extremely numerous and well documented.