Page 1 of 1

Problem getting V2 PIC board detected by computer.

Posted: Sun May 21, 2006 10:11 pm
by WayUpHere

I have a Version 2 PIC dev board, the on with the parallel port on it. However, when all is connected and powered up, all the programs I've tried using throw up an error message saying that they cannot detect the development board, suggesting that the power isn't on.

It's been a short while, I've had a lot on my plate lately so cannot recall the exact error message wording.
But the board is definately powered, the parallel cable is securely plugged in - but still no go.

It's bugging me quite a lot - ages ago I paid a rather large amount for this board. So I'd really rather not just revert to some cheapo kit from somewhere else.

Does anybody have any advice? I've googled elsewhere, but no luck so far.

Thank you!

Posted: Mon May 22, 2006 9:08 am
by Steve

Sorry to hear of the problem. Have you ever had it working on this PC or has it never worked?

One thing I'd suggest is going into the options screen of PPPv3 and either "autodetecting" the board or specifying it as a v2 dev board. Once you have done this, try autodetecting the PIC from the config screen.

If all of this fails, you could try re-installing the latest PPPv3 from our website. Make sure you select the optional "parallel-port driver" during the installation, and restart your PC after a successful install.

If you are still having problems, let us know and we'll try some other things.

Posted: Mon May 22, 2006 9:34 am
by Ian

Note as well that Matrix Products such as Flowcode, C for PICs and ASM for PICs all use different Config slots - i.e. they all save the options and configurations separately so you will need to check and set the board options in each one.


Posted: Mon May 22, 2006 11:46 pm
by WayUpHere
I haven't had it working before on this particular PC. I must have had it wokring on a previous one, as there is a pic plugged into the board with a program counting 4 leds up in binary. So I know the board is powered and working.

Currently I don't own a copy of matrix multimedia's flowcode/C IDE suite, so can't test with it - the demo's don't allow the user to save anything.

I retested very briefly (busy day, only now getting a chance to have a look at it) the PPPv3 program. When this program is opened, the first thing I see is an error message stating

"Can't load zntport.sys"

I'd imagine this would have a major effect on the port control. ;)
I faintly recall ages ago, trying to find out more about this .sys file...
Of course, I've tried uninstalling and reinstalling the PPPv3 program, but always I get this message.

To the other fellow: I've tried all that port config stuff (there were some other online articles regarding them), but none of it worked I recall.

Basically the next step is finding out why the zntport.sys can't be loaded. I searched and it's sitting pretty at: C:\WINNT\system32\drivers

Presumably there is an errant directory listing inside the PPPv3 program - but unfortunately there's not an option for giving a new one under 'preferences'.

Posted: Tue May 23, 2006 9:05 am
by Steve
It sounds like it could be a user-rights issue. The installation of PPPv3 needs to occur under full admin rights, but a restricted user should be able to run it fine after that.

I'll leave this one to Ian, as he has more experience with this kind of thing...

Posted: Tue May 23, 2006 4:13 pm
by WayUpHere
Hmm. Well, the program was installed by me onto my own PC, so I know for sure that it was installed while I was logged in as admin.

I've checked the 'security' tab in 'Properties' for both PPPv3.exe and the zntport.sys file. They both have, for administrator, full control enabled (excluding 'special permissions' - which I've never really seen enabled for anthing I think); and for the 'Users' group only 'Read & Execute' and 'Read' are enabled.

Unfortunately I can't even test this on other PCs around the house - because (technological progress!) they all completely lack the big D-type parallel port in the first place.

Would I be needing to find some registry entry to alter?

Posted: Tue May 23, 2006 5:23 pm
by Steve
Ok, we can rule out admin rights issues.

From what you've said, I guess it's all down to the ZNTPORT process not running.

I'd suggest you uninstall PPPv3 and then reinstall the latest version from our website. When you do this, make sure you select the "parallel port driver" option (i.e. the zntport process) - by default, the installation does *not* install this because most of our boards are now USB and don't need it.

Please let me know how you get on.

Posted: Tue May 23, 2006 7:13 pm
by WayUpHere
Hi again.

I uninstalled the current PPPv3 (v3.6) and installed the current PPPv3.7, making absolutely sure to select 'install parallel port driver' from the list during the install.

Unfortunately, the problem still exists. Still can't load zntport.sys.

I wondered perhaps it might be because of a firewall issue - but I just set the program control for the PPP to trusted for everything in my Zonealarm free Personal Edition, but that didn't change anything.

I'm completely stumped.

Posted: Wed May 24, 2006 9:58 am
by Steve
I'm stumped as well. Have you tried to start the zntport process manually?

I have contacted the manufacturers of ntport to see if they have any ideas. They do have a more recent version (v2.7), but I've been unable to install this myself because I've lost things that are needed for the upgrade.

You could possibly try to install the evaluation version, which is aavailable on their website here:

It has a nag screen, but should be fully-functional apart from that. You will need to replace both ntport.dll (in the PPP directory) and zntport.sys (in the windows\system32 directory).

Posted: Wed May 24, 2006 4:31 pm
by Steve
I've now got the latest drivers. Send me an email and I'll reply with the new version - hopefully this will provide a fix.

Posted: Wed May 24, 2006 4:33 pm
by Ian
Hi WayupThere,

Can you email me at about this.
I have a ZNTPORT install exe that may help get ZNTPORT set up, or at least rule out it being install issues.

Posted: Wed May 24, 2006 6:27 pm
by WayUpHere

Thanks to Steve who sent me some updated drivers, the issue is now completely resolved.

There are no more error messages, and the PPPv3 now recognises the existence of my v2.1 PIC Dev board, and successfully auto-detects the type of PIC I have installed in that board.

Posted: Wed Jan 10, 2007 12:28 pm
by Benj
The driver to fix this problem is available from the Support FAQ section.