FC8 ICD4 MPLABX-v5.10 read device problem

For questions and comments on programming in general. And for any items that don't fit into the forums below.

Moderators: Benj, Mods

stefan.erni
Posts: 496
Joined: Fri Aug 19, 2016 2:09 pm
Location: switzerland
Has thanked: 156 times
Been thanked: 142 times
Contact:

FC8 ICD4 MPLABX-v5.10 read device problem

Postby stefan.erni » Mon Jan 21, 2019 11:32 am

Hi Ben

I try to connect FC8 with the ICD4 of microchip. One of the problems is that the device ID is lost when I program the pic with FC8. Afterwards, the ICD4 no longer connects to "Target"

viewtopic.php?f=78&t=20724

regards

Stefan

User avatar
Benj
Matrix Staff
Posts: 14130
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4325 times
Been thanked: 4070 times
Contact:

Re: FC8 ICD4 MPLABX-v5.10 read device problem

Postby Benj » Mon Jan 21, 2019 12:12 pm

Hi Stefan,

The ID words shouldn't be writable so maybe you're just setting a code protect bit in your configuration settings which is stopping them being read back?

Without a project for reference I'm just guessing.

stefan.erni
Posts: 496
Joined: Fri Aug 19, 2016 2:09 pm
Location: switzerland
Has thanked: 156 times
Been thanked: 142 times
Contact:

Re: FC8 ICD4 MPLABX-v5.10 read device problem

Postby stefan.erni » Mon Jan 21, 2019 3:15 pm

Hi Ben

The ICD4 and FC8 is working nice and very fast.....

With a little detour. There is an error because of the ID (serienumber). After this, the ICD4 deletes everything and it flashes the chip complet new.


I used this parameters in FC8:
Powered externally
Location:
C:\Program Files (x86)\Microchip\MPLABX\v5.10\mplab_platform\mplab_ipe\ipecmd.ex
Parameters:
/P$(chip) /F"$(outdir)$(target).hex" /TPICD4 /M /OL

from here is the errormessage(more a warning)

***********************************************************
Connecting to MPLAB ICD 4...
Currently loaded versions:
Application version............01.05.12
Boot version...................01.00.00
FPGA version...................01.00.00
Script version.................00.02.65
Script build number............69cc1f643c
. .

Target voltage detected
Target device PIC32MZ2048ECG100 found.
Device Revision Id = 0xA5
. . . . . . . . . . . . . . .

Reception on endpoint 129 failed (err = -10121)
Unable to read the device serial number.
A communication error with the debug tool has occurred. The tool will attempt to recover momentarily.
*****************************************************
. . . .

Erasing...
The following memory area(s) will be programmed:
program memory: start address = 0x1d000000, end address = 0x1d0167ff
configuration memory
boot config memory
Programming/Verify complete
ICD4 Program Report
21-Jan-2019, 14:27:30
Device Type:PIC32MZ2048ECG100
Program Succeeded.
Operation Succeeded


FINISHED

stefan.erni
Posts: 496
Joined: Fri Aug 19, 2016 2:09 pm
Location: switzerland
Has thanked: 156 times
Been thanked: 142 times
Contact:

Re: FC8 ICD4 MPLABX-v5.10 read device problem

Postby stefan.erni » Thu Jan 24, 2019 3:54 pm

Hi Ben

If I use the Mplab x ipe to erase the PIC, it's working nice to flash to chip and it's faster
It's compile an flash in 18 Sec. The second time need 27 Sec. That's not a big problem.

The biger problem is to read the Device ID with the FC8. Is this possible to do with FC8?




Info read device id for PIC
https://www.mouser.com/ds/2/268/60001191D-752781.pdf
Memory locations 0x1FC54020 and 0x1FC54024 contain a unique device serial number (see Section 34.0 “Special Features”).



Message:
----------------------------------------------------------------------- first time after erase
Target voltage detected
Target device PIC32MZ2048EFG100 found.
Device Revision Id = 0xA1
Serial Number:
Num0 = 397799f4
Num1 = 25bfd880

----------------------------------------------------------------------- second time after erase

Target voltage detected
Target device PIC32MZ2048EFG100 found.
Device Revision Id = 0xA1
. . . . . . . . . . . . . .

Reception on endpoint 129 failed (err = -10121)
Unable to read the device serial number.
A communication error with the debug tool has occurred. The tool will attempt to recover momentarily.

User avatar
Benj
Matrix Staff
Posts: 14130
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4325 times
Been thanked: 4070 times
Contact:

Re: FC8 ICD4 MPLABX-v5.10 read device problem

Postby Benj » Thu Jan 24, 2019 4:23 pm

Hello Stefan,

The biger problem is to read the Device ID with the FC8. Is this possible to do with FC8?


I'm afraid that during the programming stage we are in the hands of the Microchip IPE software e.g. there is nothing the Flowcode team can do to fix this problem.

Maybe try a newer version of MPLABX IPE if there is one available or let Microchip know of the problem and they may be able to fix it in the next release.

stefan.erni
Posts: 496
Joined: Fri Aug 19, 2016 2:09 pm
Location: switzerland
Has thanked: 156 times
Been thanked: 142 times
Contact:

Re: FC8 ICD4 MPLABX-v5.10 read device problem

Postby stefan.erni » Thu Jan 24, 2019 5:32 pm

Hi Ben

The ipe is very new.....
What I like to do is that my recorder's send a unic ID to the computer and save to the sd-card. I don't need to change the flashing part.
So I just thought of sending and saving the device id. Then all recorders have the same software.

Device ID.PNG
Device ID.PNG (23.74 KiB) Viewed 1152 times
These users thanked the author stefan.erni for the post:
Benj (Thu Jan 24, 2019 6:15 pm)
Rating: 5.56%