no data transmission at I2C and 32MX150F128B

An area to discuss 32-bit PIC specific problems and examples

Moderator: Benj

Pascal_2016
Posts: 60
Joined: Wed Aug 31, 2016 4:48 pm
Been thanked: 2 times
Contact:

no data transmission at I2C and 32MX150F128B

Postby Pascal_2016 » Sun Sep 03, 2017 1:17 pm

Hello, Forum

my Microcontroler is 32MX150F128B

My program should select data from a 24A256 I2C EEPROM and read in.

The high-loaded program runs without mistake in Flowcode 6 with a 33FJ128GP802 and 24F16KA102

The same program does not run on 32MX150F128B in Flowcode 7. If I exchange the processor 32MX150F128B with 33F128GP802 the Pin are compatible and use Flowcode 6 runs the circuit with the same code perfectly.

The interface RS232 runs in Flowcode 7 and the flashing frequency of 1 hertz is also correct.

Maybe someone can help me fix the problem in Flowcode 7.

Many thanks beforehand
Attachments
32MX150F128B_I2C_EEPROM.fcfx
(124.46 KiB) Downloaded 40 times

User avatar
QMESAR
Valued Contributor
Valued Contributor
Posts: 1082
Joined: Sun Oct 05, 2014 3:20 pm
Has thanked: 333 times
Been thanked: 542 times
Contact:

Re: no data transmission at I2C and 32MX150F128B

Postby QMESAR » Thu Sep 07, 2017 11:48 am

Hi.
As you do not mention the Oscillator frequency you use it is hard to judge however the PIC32 is tricky with its Clock configuration and your problem sure does indicate some error in this direction.
I took a quick look and the Peripheral clock/4 you are using is suspect for me (keep in mind this is just a general speculation)
it would help if you will inform us is with

(1) are using internal or external oscillator(if external what frequency?)
(2) What is the clock speed you intend to have

take care as both these has a direct influence on the I2C ,SPI and other peripherals
These users thanked the author QMESAR for the post:
LeighM (Thu Sep 07, 2017 11:51 am)
Rating: 5.88%
 

Pascal_2016
Posts: 60
Joined: Wed Aug 31, 2016 4:48 pm
Been thanked: 2 times
Contact:

Re: no data transmission at I2C and 32MX150F128B

Postby Pascal_2016 » Sat Sep 09, 2017 6:08 pm

Hello

I work with the internal oscillator 8.0 MHz. The 10-MHz Peripheral clock is the only tact with uart, properly runs.