Flowcode 8 I2C slave Macro

For Flowcode users to discuss projects, flowcharts, and any other issues related to Flowcode 8.

Moderator: Benj

davidkilshaw
Posts: 18
Joined: Thu Dec 20, 2012 12:31 pm
Has thanked: 2 times
Contact:

Flowcode 8 I2C slave Macro

Postby davidkilshaw » Sun Oct 21, 2018 6:36 pm

I am using a 16F18325 Pic to try and create a PWM waveform based on an I2C number received.

I have no issue with driving the PWM but am struggling getting the I2c slave macro to function. Everything looks fine in emulation in flowcode but the pic just fails to see any signals on the I2C port.

To prove the hardare is working i have also tried in I2C master macro and this works fine.

I beginning to think there is an issue with Flowcode 8 or am i missing something

Thanks in advance

Dave Kilshaw
Last edited by davidkilshaw on Tue Oct 23, 2018 1:16 pm, edited 1 time in total.

kersing
Valued Contributor
Valued Contributor
Posts: 1878
Joined: Wed Aug 27, 2008 10:31 pm
Location: Netherlands
Has thanked: 534 times
Been thanked: 1043 times
Contact:

Re: Flowcode 8 I2C slave Macro

Postby kersing » Sun Oct 21, 2018 7:14 pm

Could you post a minimal flowchart demonstrating the issue you are experiencing?
These users thanked the author kersing for the post:
davidkilshaw (Mon Oct 22, 2018 12:53 pm)
Rating: 5.26%
 
“Integrity is doing the right thing, even when no one is watching.”

― C.S. Lewis

davidkilshaw
Posts: 18
Joined: Thu Dec 20, 2012 12:31 pm
Has thanked: 2 times
Contact:

Re: Flowcode 8 I2C slave Macro

Postby davidkilshaw » Mon Oct 22, 2018 10:46 am

see flowcode project attached
thanks
Attachments
2._I2C_Slave_LEDs.fcfx
(11.27 KiB) Downloaded 47 times