PWM signal < 10 HZ

For Flowcode users to discuss projects, flowcharts, and any other issues related to Flowcode 8.

Moderator: Benj

xelites
Posts: 44
Joined: Thu Nov 06, 2014 9:47 am
Been thanked: 7 times
Contact:

PWM signal < 10 HZ

Postby xelites » Sat Aug 10, 2019 10:54 am

Who can help me thanks, I have to generate a PWM signal with a base at 20HZ or 10 HZ and variable from 0 to 100% ... the original component of the micro does not make me go below 1000HZ. Thanks sorry the trouble.

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 8600
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Has thanked: 2469 times
Been thanked: 3557 times
Contact:

Re: PWM signal < 10 HZ

Postby medelec35 » Sat Aug 10, 2019 11:19 am

Hi xelites,
I have answered a similar question here
Martin

If you read a post that is useful, please show appreciation by clicking on thumbs up Icon.

xelites
Posts: 44
Joined: Thu Nov 06, 2014 9:47 am
Been thanked: 7 times
Contact:

Re: PWM signal < 10 HZ

Postby xelites » Sat Aug 10, 2019 11:48 am

I see medelec, but the page link after not present server 404 error ! i not find example ... :(

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 8600
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Has thanked: 2469 times
Been thanked: 3557 times
Contact:

Re: PWM signal < 10 HZ

Postby medelec35 » Sat Aug 10, 2019 1:13 pm

Hi xelites,
Sorry I did not know the link is broken.
I can create an example flowchart for you.
What would be your preferred frequency?
Martin

If you read a post that is useful, please show appreciation by clicking on thumbs up Icon.

xelites
Posts: 44
Joined: Thu Nov 06, 2014 9:47 am
Been thanked: 7 times
Contact:

Re: PWM signal < 10 HZ

Postby xelites » Sat Aug 10, 2019 3:26 pm

Thank you. I use the 18F67K22 and I have to emulate a PWM with a base frequency of 20 HZ. Thanks again

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 8600
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Has thanked: 2469 times
Been thanked: 3557 times
Contact:

Re: PWM signal < 10 HZ

Postby medelec35 » Sat Aug 10, 2019 8:44 pm

No problem.
Are you using internal or external osc and at what frequency?
If you are not fussed, then I created a quick example with internal OSC at 16MHz
It may be best to complete a 1sec flasher test to make sure chip is running at the correct osc speed.
Attachments
Bit Bang PWM1.fcfx
(11.22 KiB) Downloaded 46 times
These users thanked the author medelec35 for the post:
jgu1 (Mon Aug 12, 2019 5:35 am)
Rating: 5%
 
Martin

If you read a post that is useful, please show appreciation by clicking on thumbs up Icon.

xelites
Posts: 44
Joined: Thu Nov 06, 2014 9:47 am
Been thanked: 7 times
Contact:

Re: PWM signal < 10 HZ

Postby xelites » Sun Aug 11, 2019 9:11 am

I used ext osc. a 16 MHz PLL active a 4X ( 64MHz ).
To day i try your example

xelites
Posts: 44
Joined: Thu Nov 06, 2014 9:47 am
Been thanked: 7 times
Contact:

Re: PWM signal < 10 HZ

Postby xelites » Sun Aug 11, 2019 10:31 am

Medelec but what version do you have of FC8? tells me you have compiled it with a newer version of 8.1 ... and that may not work! :)

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 8600
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Has thanked: 2469 times
Been thanked: 3557 times
Contact:

Re: PWM signal < 10 HZ

Postby medelec35 » Sun Aug 11, 2019 10:57 am

Hi
I'm running 8.2.0.12 in which patch was downloaded from here
What I do every so often is while I have a flowchart open, Select Help, Check for updates.
Change Files in-use to Full database

So long as you are running 8.2 there will be no issues with not working due to version differences
These users thanked the author medelec35 for the post:
DrElmer (Thu Sep 05, 2019 2:48 am)
Rating: 5%
 
Martin

If you read a post that is useful, please show appreciation by clicking on thumbs up Icon.