LEDs and LED Array not simulating correctly 8.2.1.13

For Flowcode users to discuss projects, flowcharts, and any other issues related to Flowcode 8.

Moderator: Benj

User avatar
Benj
Matrix Staff
Posts: 14422
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4495 times
Been thanked: 4179 times
Contact:

LEDs and LED Array not simulating correctly 8.2.1.13

Postby Benj » Tue Sep 17, 2019 10:07 am

Hello,

We have had reports that the LED and LED array aren't simulating correctly in the latest 8.2.1.13 release.

We have managed to find and fix the problem, all you have to do is replace the main Flowcode executable with the attached file here.

Simply open the attached zip archive and extract the contained exe file into your "C:\Program Files (x86)\Flowcode 8\" directory.

Then run Flowcode as normal and the problem should be resolved.

Update file is located here.

https://www.matrixtsl.com/temp/FlowcodeV8.2.1.14.zip
These users thanked the author Benj for the post (total 3):
medelec35 (Tue Sep 17, 2019 10:37 am) • astro1234 (Tue Sep 17, 2019 2:30 pm) • jgu1 (Tue Sep 17, 2019 6:56 pm)
Rating: 15.79%
 

SimonDelarue
Posts: 1
Joined: Wed Oct 02, 2019 9:06 am
Contact:

Re: LEDs and LED Array not simulating correctly 8.2.1.13

Postby SimonDelarue » Wed Oct 02, 2019 5:05 pm

Hi Benj

We are experiencing this problem at our school. So I would like to download the *.zip file. When I try to download it I get the following error.

We cannot find http://www.matrixtsl.com/temp/FlowcodeV8.2.1.14.zip

There's nothing here... but what you seek may still exist elsewhere... try these links to find what you are looking for or use the Search bar at the top of the page.

Could you please re-upload the file or provide a new link?

Kind regards

Simon Delarue

User avatar
Benj
Matrix Staff
Posts: 14422
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4495 times
Been thanked: 4179 times
Contact:

Re: LEDs and LED Array not simulating correctly 8.2.1.13

Postby Benj » Wed Oct 02, 2019 5:48 pm

Hello Simon,

Thanks for letting us know, the file should be available again in the specified location now.

MJU
Posts: 430
Joined: Wed Nov 07, 2007 6:51 pm
Location: Antwerp Belgium
Has thanked: 105 times
Been thanked: 94 times
Contact:

Re: LEDs and LED Array not simulating correctly 8.2.1.13

Postby MJU » Wed Oct 09, 2019 12:35 am

Benj wrote:Hello Simon,

Thanks for letting us know, the file should be available again in the specified location now.


Hey thanks, do we replace the existing flowcode.exe with this one?
My FC8 doesn't find the updates automatically. I have version: 8.2.0.12

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 8473
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Has thanked: 2433 times
Been thanked: 3483 times
Contact:

Re: LEDs and LED Array not simulating correctly 8.2.1.13

Postby medelec35 » Wed Oct 09, 2019 7:27 am

Hi MJU,
Currently, only non-exe files can be updated within Flowcode via Help, Check for updates.
To upgrade, you will need to uninstall 8.2.0, and download 8.2.1 from here
Then it's up to you if you download 8.2.1.13 from the zip file on the first post.
I would suggest after installing the latest version, you run the Help, Check for updates.
It's just preference but I change Files in-use to Full database.
These users thanked the author medelec35 for the post (total 2):
Benj (Mon Oct 14, 2019 4:43 pm) • MJU (Tue Oct 15, 2019 5:35 pm)
Rating: 10.53%
 
Martin

If you read a post that is useful, please show appreciation by clicking on thumbs up Icon.

MJU
Posts: 430
Joined: Wed Nov 07, 2007 6:51 pm
Location: Antwerp Belgium
Has thanked: 105 times
Been thanked: 94 times
Contact:

Re: LEDs and LED Array not simulating correctly 8.2.1.13

Postby MJU » Wed Oct 09, 2019 5:10 pm

Thank you medelec35!

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 8473
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Has thanked: 2433 times
Been thanked: 3483 times
Contact:

Re: LEDs and LED Array not simulating correctly 8.2.1.13

Postby medelec35 » Thu Oct 10, 2019 5:48 am

You're welcome.
These users thanked the author medelec35 for the post:
MJU (Tue Oct 15, 2019 5:35 pm)
Rating: 5.26%
 
Martin

If you read a post that is useful, please show appreciation by clicking on thumbs up Icon.

dannyvanneijenhoff
Posts: 54
Joined: Thu Feb 07, 2008 7:59 am
Has thanked: 11 times
Been thanked: 8 times
Contact:

Re: LEDs and LED Array not simulating correctly 8.2.1.13

Postby dannyvanneijenhoff » Mon Nov 25, 2019 3:54 pm

Hello

After this "update".
I get 2 errors with starting the programm, and choosing another micro is not possible.

power up.JPG
power up.JPG (10.99 KiB) Viewed 865 times


speed.JPG
speed.JPG (15.63 KiB) Viewed 865 times


I have an pro version

Thanks
BR Danny

User avatar
Benj
Matrix Staff
Posts: 14422
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4495 times
Been thanked: 4179 times
Contact:

Re: LEDs and LED Array not simulating correctly 8.2.1.13

Postby Benj » Tue Nov 26, 2019 2:58 pm

Hello,

Can you attach your Project file or send it to me via PM so we can investigate for you.

dannyvanneijenhoff
Posts: 54
Joined: Thu Feb 07, 2008 7:59 am
Has thanked: 11 times
Been thanked: 8 times
Contact:

Re: LEDs and LED Array not simulating correctly 8.2.1.13

Postby dannyvanneijenhoff » Wed Nov 27, 2019 9:03 am

Could also not open an new project.

Did remove the "old" FC8, i am not sure which version i was using.
I did use Help, Check for updates in help 2 times.
And did an reinstal of 8.2, and now everything is working, including the LED's in the 2d dashboard panel :)


But like Martin said, this is the path i should have taken:
Currently, only non-exe files can be updated within Flowcode via Help, Check for updates.
To upgrade, you will need to uninstall 8.2.0, and download 8.2.1 from here
Then it's up to you if you download 8.2.1.13 from the zip file on the first post.
I would suggest after installing the latest version, you run the Help, Check for updates.
These users thanked the author dannyvanneijenhoff for the post:
Benj (Wed Nov 27, 2019 10:34 am)
Rating: 5.26%