FC6 Crash During Simulation

For Flowcode users to discuss projects, flowcharts, and any other issues related to Flowcode 6.

Moderator: Benj

User avatar
Jay Dee
Posts: 352
Joined: Tue Aug 18, 2009 6:42 pm
Has thanked: 116 times
Been thanked: 134 times
Contact:

FC6 Crash During Simulation

Postby Jay Dee » Sat Nov 02, 2013 12:40 pm

Hi,
When running a simulation, I'll momentarily see in the Simulation debugger 'Unknown or Missing Variable : MyVar' for all the variables.
Shortly after I get the following error.
'Flowcode has encountered a problem from which is it unable to recover. Please save your work and then close and restart flowcode'

Some times I can exit the pop-up to save, other times its stuck in a loop.
It seems to happen with the simulation slider at any speed, not as often but it can happen when I manually step through the program quickly.

Running on Win XP pro SP3 - AMD 64x2 2GHz 1GB ram
FC PIC Pro v6.0.3.0
Standard ECIO 40P

I can work around it at the moment since I mostly in hardware and just roughing a first version in FC.
Regards, John.
EDIT: I found a few uninitialised variables so sorted those but it still seems to do it...hmm
Attachments
TECI_FUEL_USAGE.fcfx
(19.46 KiB) Downloaded 72 times
These users thanked the author Jay Dee for the post:
Benj (Tue Nov 05, 2013 10:43 pm)
Rating: 5.26%
 

User avatar
Benj
Matrix Staff
Posts: 14298
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4394 times
Been thanked: 4123 times
Contact:

Re: FC6 Crash During Simulation

Postby Benj » Tue Nov 05, 2013 10:46 pm

Hello,

Working ok for me on my laptop, I'll retry on my office PC as it's good at replicating bugs.

Out of interest what open gl version do you have (Help -> About) and are you using the open gl in hardware or software mode (Edit -> Global Options)?