PIC18F2420 not sending STRING via UART

For Flowcode users to discuss projects, flowcharts, and any other issues related to Flowcode 6.

Moderator: Benj

Dirk Bubley
Posts: 89
Joined: Fri Feb 02, 2007 3:54 pm
Location: Germany
Has thanked: 9 times
Been thanked: 8 times
Contact:

PIC18F2420 not sending STRING via UART

Postby Dirk Bubley » Thu Nov 23, 2017 8:05 pm

Hello community,

I found a strange things with the Serial hardware UART of a PIC18F2420.

If I want to sent a string lets say "Hallo" out of the UART at the chip nothing happens. No bytes comming out (SentString funktion)

If I sent a byte or group of Bytes the with SentChar funktion the UART works correctly.

If I test the string situation in simulation it works correctly too.

Is there a know issue with this subject???

BR
Dirk

User avatar
LeighM
Matrix Staff
Posts: 1962
Joined: Tue Jan 17, 2012 10:07 am
Has thanked: 474 times
Been thanked: 674 times
Contact:

Re: PIC18F2420 not sending STRING via UART

Postby LeighM » Fri Nov 24, 2017 10:23 am

In Project Options-> Configure try setting "Extended CPU Enable" to "Disabled"
These users thanked the author LeighM for the post:
medelec35 (Mon Nov 27, 2017 9:44 am)
Rating: 5.26%
 

Dirk Bubley
Posts: 89
Joined: Fri Feb 02, 2007 3:54 pm
Location: Germany
Has thanked: 9 times
Been thanked: 8 times
Contact:

Re: PIC18F2420 not sending STRING via UART

Postby Dirk Bubley » Sun Nov 26, 2017 10:47 pm

Hi Leigh,

many thanks!! Yor solution works.

Great Support. :D

BR

Dirk
These users thanked the author Dirk Bubley for the post:
Benj (Mon Nov 27, 2017 11:10 am)
Rating: 5.26%