Disappearing Window

Moderator: Benj

chipfryer27
Posts: 164
Joined: Fri Jun 06, 2014 3:53 pm
Has thanked: 99 times
Been thanked: 63 times
Contact:

Disappearing Window

Postby chipfryer27 » Sun Dec 30, 2018 7:42 pm

Hi

This is similar to another thread regarding displays. Like them, the problem is only with v8 no other software (or Flowcode version). It does not happen all the time but often enough for it to be troublesome.

I'm running W8.1.

With v8 running and I open another window within Flowcode (say Build>Project Options) the new window immediately disappears. If I click on the Main Flowcode area the window reappears again but if I try and click on it, it disappears again. Like in a loop I have much "fun" until I need to forcibly stop Flowcode from running. Starting it again cures for a while.

Other times, when I click on the main window in the hope of the other reappearing, it does but appears / disappears like a strobe.

Windows tells me I am up to date and I'm using a laptop with bog standard drivers. Nothing fancy here. As mentioned it is only v8 I have problems with.

Regards

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 8420
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Has thanked: 2404 times
Been thanked: 3437 times
Contact:

Re: Disappearing Window

Postby medelec35 » Mon Dec 31, 2018 12:47 am

Hi, I believe V8 suffers from focus issues which I have reported.
Hopefully will be sorted with the next update?

However for your issue have you upgraded to the latest version, i.e 8.1.1.11?
If not, you can upgrade from hereas your issue should have been resolved with the latest fix.
These users thanked the author medelec35 for the post:
chipfryer27 (Mon Dec 31, 2018 2:19 am)
Rating: 5.26%
 
Martin

If you read a post that is useful, please show appreciation by clicking on thumbs up Icon.

chipfryer27
Posts: 164
Joined: Fri Jun 06, 2014 3:53 pm
Has thanked: 99 times
Been thanked: 63 times
Contact:

Re: Disappearing Window

Postby chipfryer27 » Mon Dec 31, 2018 2:18 am

Hi

Not long after I posted I discovered that upgrade whilst on the Matrix site. Since downloading it I haven't seen the issue return but as it is intermittent I was going to wait a day before updating my post. I didn't get it every session but I would get it every day. It also helped a little bit with another issue I'm having but didn't solve that one.

Thanks for your help (again), it is always appreciated. Due to work / travel I don't always get the chance to access the forum but I'm binge viewing now :)

Regards
These users thanked the author chipfryer27 for the post:
medelec35 (Mon Dec 31, 2018 1:06 pm)
Rating: 5.26%
 

chad
Posts: 131
Joined: Sun Nov 04, 2018 7:13 pm
Has thanked: 23 times
Been thanked: 28 times
Contact:

Re: Disappearing Window

Postby chad » Mon Dec 31, 2018 9:49 am

I ran into this tonight as well. I think it has to do with weather or not the flowcode window is maximized or not. If it is maximized it seems to be ok. If it is in windowed mode I have to play hide and seek with the dialog box.

chad

chipfryer27
Posts: 164
Joined: Fri Jun 06, 2014 3:53 pm
Has thanked: 99 times
Been thanked: 63 times
Contact:

Re: Disappearing Window

Postby chipfryer27 » Mon Dec 31, 2018 10:40 am

Hi Chad

Did you try the update as Medelec suggested?

My version of Flowcode didn't tell me about the update, I found it on the website. Once updated I haven't yet had the issue return. Usually my window is running "slightly" minimised.

Regards

chad
Posts: 131
Joined: Sun Nov 04, 2018 7:13 pm
Has thanked: 23 times
Been thanked: 28 times
Contact:

Re: Disappearing Window

Postby chad » Mon Dec 31, 2018 12:30 pm

Hi chip,

Yeah, I am running the latest. I thought it was fixed but tonight while making a new embedded project the bug happened again.
It isn't a big deal to me, I have bigger problems with FC than that. It has only failed for me once post update.

Chad

chipfryer27
Posts: 164
Joined: Fri Jun 06, 2014 3:53 pm
Has thanked: 99 times
Been thanked: 63 times
Contact:

Re: Disappearing Window

Postby chipfryer27 » Tue Jan 01, 2019 5:55 pm

Hi

Just a quick update.

Since I manually updated (to v8.1.1.11) I have not had my issue return. I have opened multiple session of v8 and many sub-windows with no disappearing act.

For me I think my issue is resolved.

Regards and Happy New Year

EDIT >
It has been a week now and the issue has not returned :)
These users thanked the author chipfryer27 for the post:
Benj (Mon Jan 07, 2019 6:29 pm)
Rating: 5.26%
 

johnsondav
Posts: 186
Joined: Thu Jun 28, 2012 7:29 pm
Location: Durham
Has thanked: 92 times
Been thanked: 181 times
Contact:

Re: Disappearing Window

Postby johnsondav » Sat Jan 19, 2019 2:37 pm

Hi Everyone

Well, I though I must be going daft. probably am, but where has all my display gone? They have for some reason disappeared from the 'Displays' and can now only be accessed via 'Misc' menu through the search option. This is very odd as I have done nothing to the settings. :(

FC8_Displays_Gone.png
FC8_Displays_Gone.png (131.4 KiB) Viewed 1436 times


I am using FC8.1.1.11 Built Dec 14 2018
Windows 10 1803 Pro OS 17134.523

If I remember correctly, FC8 did tell me that an update was available, although not for any display packs, before this problem occurred!
Hmmm.
Any suggestions would be greatly appreciated.

johnsondav
Posts: 186
Joined: Thu Jun 28, 2012 7:29 pm
Location: Durham
Has thanked: 92 times
Been thanked: 181 times
Contact:

Re: Disappearing Window

Postby johnsondav » Sat Jan 19, 2019 2:46 pm

Well, I take that back. I have solved my own problem. There appears to be a miss-match when doing 'In Use' only updates. I have just done a full system update (using the up-date feature of FC8) and the problem has gone away. Yeh. :D

FC8_Displays.png
FC8_Displays.png (129.44 KiB) Viewed 1434 times


Dave
These users thanked the author johnsondav for the post:
Benj (Thu Jan 24, 2019 11:11 pm)
Rating: 5.26%
 

chipfryer27
Posts: 164
Joined: Fri Jun 06, 2014 3:53 pm
Has thanked: 99 times
Been thanked: 63 times
Contact:

Re: Disappearing Window

Postby chipfryer27 » Sat Jan 19, 2019 6:52 pm

Hi

That caught me out too, the option for File-in-Use vs Full Database when updating :)
These users thanked the author chipfryer27 for the post (total 2):
johnsondav (Mon Jan 21, 2019 12:01 pm) • Benj (Thu Jan 24, 2019 11:11 pm)
Rating: 10.53%
 

User avatar
Benj
Matrix Staff
Posts: 14313
Joined: Mon Oct 16, 2006 10:48 am
Location: Matrix TS Ltd
Has thanked: 4405 times
Been thanked: 4128 times
Contact:

Re: Disappearing Window

Postby Benj » Thu Jan 24, 2019 11:14 pm

Hello,

Sorry for any confusion and glad you're all sorted again now..

We are currently having a bit of a clean up of the components and groupings which is what caused the displays to disappear. There is likely more changes to come in the next couple of weeks but hopefully we can make this as painless as possible for everyone.