EB008 Quad 7 Segment Display Board examples

For E-blocks user to discuss using E-blocks and programming for them.

Moderators: Benj, Mods

User avatar
Steve001
Valued Contributor
Valued Contributor
Posts: 1104
Joined: Wed Dec 31, 2008 3:37 pm
Has thanked: 453 times
Been thanked: 505 times
Contact:

EB008 Quad 7 Segment Display Board examples

Postby Steve001 » Fri Mar 04, 2011 9:21 pm

when trying to open the test files i am getting the follwoing error ?

can anybody advise please

Steve
Attachments
error.JPG
(187.73 KiB) Downloaded 3657 times
Success always occurs in private and failure in full view.

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 8542
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Has thanked: 2456 times
Been thanked: 3528 times
Contact:

Re: EB008 Quad 7 Segment Display Board examples

Postby medelec35 » Fri Mar 04, 2011 10:58 pm

Hi Steve,
There are two things you can try.
1) In view, Global options, set the overriding language to English.

2) If That don't work then download the full install of latest version (V4.3.7.63), as the update patch I believe had a bug.

Alternately you could post the flowchart you are experiencing problem with, and I can try it on my PC.
These users thanked the author medelec35 for the post:
Steve001 (Sat Jun 18, 2011 7:44 pm)
Rating: 5.26%
 
Martin

If you read a post that is useful, please show appreciation by clicking on thumbs up Icon.

User avatar
Steve001
Valued Contributor
Valued Contributor
Posts: 1104
Joined: Wed Dec 31, 2008 3:37 pm
Has thanked: 453 times
Been thanked: 505 times
Contact:

Re: EB008 Quad 7 Segment Display Board examples

Postby Steve001 » Sat Mar 05, 2011 7:51 am

Hi medelec,

my flowcode is forced to english as i was getting errors saying " cannot detect language defalting to english"
the files are the ones downloaded from the test files section
will check my version of flowcode later on. I have flowcode 4 and the update

steve
Attachments
7-seg'88.fcf
(4.5 KiB) Downloaded 241 times
7_seg.fcf
(4.5 KiB) Downloaded 233 times
Success always occurs in private and failure in full view.

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 8542
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Has thanked: 2456 times
Been thanked: 3528 times
Contact:

Re: EB008 Quad 7 Segment Display Board examples

Postby medelec35 » Sat Mar 05, 2011 10:12 am

Files you have posted appear to be corrupt. They don't load on my PC either.
So your Flowcode Could be OK.
I have downloaded same examples from:
http://www.matrixmultimedia.com/eblock_datasheets.php
and attached them to this post.
They load OK on my PC

The odd thing is, If they are same files, I wonder why there is a size difference between these two and your two?

For more pratical exaples of 7segment displays see:
viewtopic.php?f=29&t=7795&p=20772
and
viewtopic.php?f=23&t=7737&p=20644
These examples use timer0 interrupt to light each LED Component in turn.
Attachments
7_seg-fc4.fcf
(8 KiB) Downloaded 243 times
7-seg'88-fc4.fcf
(8 KiB) Downloaded 231 times
Martin

If you read a post that is useful, please show appreciation by clicking on thumbs up Icon.

User avatar
Steve001
Valued Contributor
Valued Contributor
Posts: 1104
Joined: Wed Dec 31, 2008 3:37 pm
Has thanked: 453 times
Been thanked: 505 times
Contact:

Re: EB008 Quad 7 Segment Display Board examples

Postby Steve001 » Sun Mar 06, 2011 8:05 pm

mmmm get the same error with those test files matey ?

the link that you gave me is the link that i downloaded them from in the first place
i am using flowcode 4 ver v4.3.7.63

steve
Success always occurs in private and failure in full view.

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 8542
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Has thanked: 2456 times
Been thanked: 3528 times
Contact:

Re: EB008 Quad 7 Segment Display Board examples

Postby medelec35 » Sun Mar 06, 2011 9:01 pm

some how files are getting corrupt, after they are saved on your pc.
A virus perhaps?
One very good free anti-virus from Microsoft is called Microsoft Security Essentials. Download from here:
http://www.microsoft.com/security_essentials/
Also gets rid of spyware.
You can see the size difference, Which is concerning.

I have downloaded the same file you did from my previous post, and that loaded fine.
I have heard of some servers changing files as they are saved. You saving directly on to your C drive?
I will leave matrix to help you further, as I don't believe I can.
Martin

If you read a post that is useful, please show appreciation by clicking on thumbs up Icon.

User avatar
Steve
Matrix Staff
Posts: 3103
Joined: Tue Jan 03, 2006 3:59 pm
Has thanked: 89 times
Been thanked: 391 times
Contact:

Re: EB008 Quad 7 Segment Display Board examples

Postby Steve » Mon Mar 07, 2011 11:55 am

The latest release of the PICmicro variant is "v4.3.8.64". Perhaps using this will solve the problem?

EDIT: ignore this, I made a mistake. The latest available version is the V4.3.7 that you have.

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 8542
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Has thanked: 2456 times
Been thanked: 3528 times
Contact:

Re: EB008 Quad 7 Segment Display Board examples

Postby medelec35 » Mon Mar 07, 2011 12:55 pm

Steve. The odd thing about these files which are all downloaded from the same location is:
Files I uploaded Reported and actual file size = 8K
Files Steve001uploaded Reported = 8K and actual file size = 4.5K
I seem to remember some one else had similar problem, when using a server?
Martin

If you read a post that is useful, please show appreciation by clicking on thumbs up Icon.

User avatar
Steve
Matrix Staff
Posts: 3103
Joined: Tue Jan 03, 2006 3:59 pm
Has thanked: 89 times
Been thanked: 391 times
Contact:

Re: EB008 Quad 7 Segment Display Board examples

Postby Steve » Mon Mar 07, 2011 1:11 pm

Possibly it's a browser cache issue.

User avatar
Steve001
Valued Contributor
Valued Contributor
Posts: 1104
Joined: Wed Dec 31, 2008 3:37 pm
Has thanked: 453 times
Been thanked: 505 times
Contact:

Re: EB008 Quad 7 Segment Display Board examples

Postby Steve001 » Tue Mar 08, 2011 1:45 pm

i am not using a server as such, but using a nas system called naslite
had no issues with it so far with flowcode they seam to work well together :-)

i have downloaded both files that medelec uploaded to my desktop and if i right click on them they are 8K on disk but 4.5k in size ?

steve
Success always occurs in private and failure in full view.

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 8542
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Has thanked: 2456 times
Been thanked: 3528 times
Contact:

Re: EB008 Quad 7 Segment Display Board examples

Postby medelec35 » Tue Mar 08, 2011 2:41 pm

I have sent you the two 7seg demos and the interrupt demo via email given to me via PM.
You can see the size difference (shown within brackets) of files you posted(4.5K) and files I posted(8K)
Yet on your PC they are all wrong size at 4.5K
Have you tried emptying browser cache as steve though it may be that.
Or you could try a different browser.
Martin

If you read a post that is useful, please show appreciation by clicking on thumbs up Icon.

User avatar
Steve001
Valued Contributor
Valued Contributor
Posts: 1104
Joined: Wed Dec 31, 2008 3:37 pm
Has thanked: 453 times
Been thanked: 505 times
Contact:

Re: EB008 Quad 7 Segment Display Board examples

Postby Steve001 » Tue Mar 08, 2011 9:54 pm

got those thanks, my internet history is set to clear all on exit anyway.
I am using I.E 8 will try wifeys laptop later as she uses google crome.( permision pending ) :lol:
and let you know how i get on

steve
Success always occurs in private and failure in full view.

User avatar
Steve001
Valued Contributor
Valued Contributor
Posts: 1104
Joined: Wed Dec 31, 2008 3:37 pm
Has thanked: 453 times
Been thanked: 505 times
Contact:

Re: EB008 Quad 7 Segment Display Board examples

Postby Steve001 » Sun Mar 13, 2011 11:26 am

still had problems with ones downloaded using google crome ?

ones from medelec are working fine. .. thanks matey

steve
Success always occurs in private and failure in full view.

User avatar
medelec35
Valued Contributor
Valued Contributor
Posts: 8542
Joined: Sat May 05, 2007 2:27 pm
Location: Northamptonshire, UK
Has thanked: 2456 times
Been thanked: 3528 times
Contact:

Re: EB008 Quad 7 Segment Display Board examples

Postby medelec35 » Sun Mar 13, 2011 2:01 pm

Your welcome.
Until you can resolve the downloading issue, let me know if you want any more files from this website, and I will forward them to you.

Martin.
Martin

If you read a post that is useful, please show appreciation by clicking on thumbs up Icon.

User avatar
Steve001
Valued Contributor
Valued Contributor
Posts: 1104
Joined: Wed Dec 31, 2008 3:37 pm
Has thanked: 453 times
Been thanked: 505 times
Contact:

Re: EB008 Quad 7 Segment Display Board examples

Postby Steve001 » Wed Mar 23, 2011 8:31 am

cheers for that . had no isssues before have downloaded a few from the test files page

steve
Success always occurs in private and failure in full view.

User avatar
Steve001
Valued Contributor
Valued Contributor
Posts: 1104
Joined: Wed Dec 31, 2008 3:37 pm
Has thanked: 453 times
Been thanked: 505 times
Contact:

Re: EB008 Quad 7 Segment Display Board examples

Postby Steve001 » Sat Jul 23, 2011 9:00 am

Since removing 64 bit internet explorer 8 and going back to normal internet explorer that issue seams to have gone away .

dont know if that was the issue or not but seams to work now . :D

steve
Success always occurs in private and failure in full view.