assembley for pic micro's V4

For C and ASSEMBLY users to post questions and code snippets for programming in C and ASSEMBLY. And for any other C or ASM course related questions.

Moderators: Benj, Mods

User avatar
Steve001
Valued Contributor
Valued Contributor
Posts: 1104
Joined: Wed Dec 31, 2008 3:37 pm
Has thanked: 453 times
Been thanked: 505 times
Contact:

assembley for pic micro's V4

Postby Steve001 » Fri Jul 15, 2011 11:46 am

having some problems opening the tutorials . please see attached pic.

if i naviagte to where the .tut files are located i can click on them and open them.
but if i use assembley for pic micro's V4 i get the error ? :-(

steve
Attachments
error.jpg
(75.68 KiB) Downloaded 1997 times
Success always occurs in private and failure in full view.

User avatar
Steve001
Valued Contributor
Valued Contributor
Posts: 1104
Joined: Wed Dec 31, 2008 3:37 pm
Has thanked: 453 times
Been thanked: 505 times
Contact:

Re: assembley for pic micro's V4

Postby Steve001 » Fri Jul 15, 2011 12:52 pm

having problems further down now :-(

the "Full Listing / Ide Button" marked with a red * dosn't open the ide ? ( Unless its just a pic to show you what it looks like )
I can open IDE by naviagting to it . . See Screen 1 pic

but to open to open wher is Tut 3 ? See screen2 pic if i open programs there is no ASM Files in there ?

there is a tut3 is that it ? see screen 3 pic

steve :?
Attachments
screen3.jpg
(84.51 KiB) Downloaded 1990 times
screen2.jpg
(68.32 KiB) Downloaded 1990 times
screen1.jpg
screen1.jpg (199.74 KiB) Viewed 3980 times
Success always occurs in private and failure in full view.

User avatar
DavidA
Matrix Staff
Posts: 1060
Joined: Fri Apr 23, 2010 2:18 pm
Location: Matrix Multimedia Ltd
Has thanked: 58 times
Been thanked: 275 times
Contact:

Re: assembley for pic micro's V4

Postby DavidA » Fri Jul 15, 2011 2:55 pm

Hi Steve,

From the looks of it you are using a 64bit machine, there are problems with 64bit machines and ASM for PICs, however there are fixes available.

Please check this FAQ topic: http://www.matrixmultimedia.com/support ... ?f=9&t=678
These users thanked the author DavidA for the post:
Steve001 (Fri Jul 15, 2011 4:41 pm)
Rating: 5.26%
 

User avatar
Steve001
Valued Contributor
Valued Contributor
Posts: 1104
Joined: Wed Dec 31, 2008 3:37 pm
Has thanked: 453 times
Been thanked: 505 times
Contact:

Re: assembley for pic micro's V4

Postby Steve001 » Fri Jul 15, 2011 4:41 pm

thanks for that will have a go later
i am using 64 bit win 7

steve :D
Success always occurs in private and failure in full view.

User avatar
Steve001
Valued Contributor
Valued Contributor
Posts: 1104
Joined: Wed Dec 31, 2008 3:37 pm
Has thanked: 453 times
Been thanked: 505 times
Contact:

Re: assembley for pic micro's V4

Postby Steve001 » Fri Jul 15, 2011 6:47 pm

Hi David,

that update is sort of workig now, but can you point me to where the asm files are located please ?
as i have to open asmide the long way . the button (on screen1) not working

steve
Success always occurs in private and failure in full view.