Search found 18 matches

Return

by Crenwick
Mon Oct 24, 2011 3:46 pm
Jump to forum
Jump to topic

Re: Enabling I2C component on a 16F887

Problem solved !

I had also a DS1307 in circuit and it seems to be a bad one ...

But I can't explain why it worked with the 18f4455 :?:

I'm happy, now I can go further :D

Thanks
by Crenwick
Tue Jan 17, 2012 8:18 pm
Jump to forum
Jump to topic

Re: V5 Upgrade ?

Well, I filled in 1. Select Flowcode Variant: PIC 2. Select License Type: Professional 3. Company / Username: The exact name I used with my license. 4. Email Address: Idem as above 5. Discount code : Not filled in 6. Previous CD code : My license code I received via Email after activation. After thi...
by Crenwick
Sat Sep 28, 2013 1:20 pm
Jump to forum
Jump to topic

Re: Help to create a gLCD_KS0108 variant

Hello all !

So I installed FC 6.0.2 and was able to compile the new fcpx component ;-)

And it works like a charm :-)

Only thing I had to do is change CS3 pin from PortC6 to PortC7 (maybe a pull up or so ?)


Regards,
by Crenwick
Thu Apr 17, 2014 7:49 am
Jump to forum
Jump to topic

Re: Registering Flowcode on Windows XP

STibor wrote:hello,
If you do not mind, I'd like to use the licensed real name.

Thank you!


If you want to go fast just send a PM to someone from the staff :wink:

For me, problem was solved two hours later and I had just to reactivate FC to see my name :D
by Crenwick
Thu Apr 17, 2014 4:02 pm
Jump to forum
Jump to topic

Re: EB-006-00-9 Driver issue

Problem found ! :D What I did is : 1. plug in my V7 board 2. Goto device manager and uninstalled the Pic Micro Programmer device with remove of his drivers !!! 3. Plug out the V7 board 4. Plug in the V9 board And tadaaa, board is WORKING :D :D :D I also did the same thing on my laptop (where I had a...
by Crenwick
Mon Apr 28, 2014 11:00 am
Jump to forum
Jump to topic

Re: EB-006-00-9 Driver issue

Hi, Sorry I have no more 16F84A in house. Can you recompile for 16F88 or 16F628 then I can test your HEX. The driver I used for V9 is http://www.matrixmultimedia.com/resources/getresource.php?id=744 And the mloader is the one loaded with FC6.0.7 but also tested with http://www.matrixmultimedia.com/r...
by Crenwick
Mon Apr 28, 2014 12:48 pm
Jump to forum
Jump to topic

Re: EB-006-00-9 Driver issue

One remark about the power supply ! I tested now the board in USB and Extenal Power mode. The power supply is the one supplied by Matrix and is adjustable (3/4.5/6/7.5/9/13.5V). When I tested my project (True RMS Voltage sensor with 16F887/EB005LCD/EB004LED/EB007SWITCHES+breadboard) I also followed ...
by Crenwick
Tue Apr 29, 2014 4:11 pm
Jump to forum
Jump to topic

Re: EB-006-00-9 Driver issue

I'm using a 9V PSU for the reason I explain above (bridge rectifier drops 1.2V) and 7805 became unstable when PSU at 7.5V input.

This will not make a difference I think because L1 is connected to VCC (5V) from the 7805. Maybe connect L1 to Vregin ?
by Crenwick
Thu May 01, 2014 3:51 pm
Jump to forum
Jump to topic

Re: EB-006-00-9 Driver issue

Hello, Looks like we may be able to switch off the charge pump using mLoader and only bring it back on when programming. This means that if you power up the board the charge pump will be active but after using Flowcode/mLoader to program it will be disabled leaving the cap free to sit at a much mor...
by Crenwick
Fri May 02, 2014 1:59 pm
Jump to forum
Jump to topic

Re: EB-006-00-9 Driver issue

Ben, As test purpose I just disconnected L1 and put a stable 15V over C18. Programming is then OK, so it has for sure to do with pwm out and time to raise. In my last post I said that the Vpp raised to 9V so I also tried with 9V over C18 and the error comes back (9V seems to be to low). Maybe worth ...
by Crenwick
Wed May 07, 2014 11:34 am
Jump to forum
Jump to topic

Re: EB-006-00-9 Driver issue

Hi Ben, PICkit is back :wink: I used the last Reflash procedure you send me (with PC-Loader). So here are my testings in a little table. I tested one time without ZIF adapter and one time with. 16F1937 seems to have a very strange behavior with/without ZIF ?? One remark also is when programming the ...
by Crenwick
Fri May 16, 2014 10:21 am
Jump to forum
Jump to topic

Re: Program Wont Compile to HEX

Have a check in Compiler options/Compiler if the parameters are

For location:

C:\Program Files (x86)\Flowcode\v5\Tools\boostc\boostc_pic18_flowcode.exe

For parameters :

-v -t PIC%p "%f.c"


I think you set the "Programmer" params of PICkit in the Compilers params :wink:
by Crenwick
Fri May 16, 2014 12:08 pm
Jump to forum
Jump to topic

Re: Program Wont Compile to HEX

kersing wrote:Hi John,

It looks like you are missing spaces in both the location and parameters. Also, are you using 64 bit windows? If not remove " (x86)" from the location.

Jac


+1 with Jac :wink:
by Crenwick
Mon Jun 02, 2014 3:39 pm
Jump to forum
Jump to topic

Re: EB006 V9 internal EEPROM programming error

Hi Ben,

I allways use the #pragma DATA _EEPROM, in the Supplementary Code block.

If you explain me where I can find the "new "initial values" property" then I can test it here.

Sorry, but I didn't find any documentation about this new feature :?

Regards,
by Crenwick
Mon Jun 02, 2014 4:12 pm
Jump to forum
Jump to topic

Re: EB006 V9 internal EEPROM programming error

Hello,

I just tested the component and it's easy to use but unfortunately gives the same error.

With PicKit its' fine :wink:

Regards,
by Crenwick
Thu Jun 05, 2014 7:00 pm
Jump to forum
Jump to topic

Re: Writing values in internal EEPROM

PERFECT !

That's great & fast service Ben !

Many thank's,

PS : Tested and working :wink:
by Crenwick
Mon Jun 02, 2014 8:13 am
Jump to forum
Jump to topic

Re: DS3231 - RTC Time Keeper

Hi Jordy, I find the problem :wink: Each time you configure the SQW rate you set also bit 7 (adding 0x80) who is disabling oscillator when on Vbat. Actual Macro, case 2: { //Comment: //Enable Square Wave Output //Frequency = 1Hz FCD_005f1_I2C_Master1__TransmitByte( 0x80 ); break; } case 3: { //Comme...
by Crenwick
Fri May 09, 2014 11:38 am
Jump to forum
Jump to topic

Re: EB-006-00-9 Driver issue

I found the cause of board failing to program, and it was not a fault with mLoader or EB006v9 With the 2 second mLoader version, 16F1937 now programs just fine. Martin So we he have the same results :wink: The only thing I can't understand is that my ZIF adapter doesn't work with 16F1937 on the V9 ...