Search found 57 matches

Return

by Lagoda
Mon Oct 09, 2017 4:17 pm
Jump to forum
Jump to topic

Re: How can I to set general I / O ports as an interrupt source?

The PIC32MZ device only supports both edges as part of the IOC interrupt, it is a limitation of the silicon not Flowcode.

Oops!

This avoided my attention. I'm sorry. :oops:

I hope this MCU isn't will cause more surprises for me.

Thank you very much.

Best Regards,

Lagoda
by Lagoda
Thu Dec 07, 2017 1:33 pm
Jump to forum
Jump to topic

Re: PIC32MZ2048EFM144 Modbus Problem

Hi Ben,

Hurray! :D

The repaired version is works perfectly.

Thanks for your quick help.

Lagoda
by Lagoda
Thu Dec 07, 2017 1:48 pm
Jump to forum
Jump to topic

Re: PIC32MZ2048EFM144 UART problem (incorrect remap pins) (SOLVED)

Hi Ben,

Super! :D

I tried just a few pins, but they worked.

Thank you very much.

Lagoda
by Lagoda
Sun Nov 26, 2017 6:20 pm
Jump to forum
Jump to topic

Re: PIC32MZ2048EFM144 UART problem

:D I found the cause of the mistake! The Rx input of the UART6 I set in the Flowcode to the RD5 pin, but in fact the RB6 was activating. When I checked the content of the U6RXR register I found 0x05 instead of 0x06. I corrected the value to 0x06 in source C and then it worked. Unfortunately I do not...
by Lagoda
Wed Dec 13, 2017 3:38 pm
Jump to forum
Jump to topic

Re: PIC32MZ2048EFM144 UART Interrupt

:D Joy and happiness!!! :D

The improved version that you have created works perfectly.

The UART bridge now works in my circuitboard, but I do not know what it was. :o

Thanks again for your help.

Lagoda
by Lagoda
Wed Dec 13, 2017 12:45 pm
Jump to forum
Jump to topic

Re: PIC32MZ2048EFM144 UART Interrupt

Hi Ben, Works well with the test program. :) I have created an UART bridge on the target panel between the GSM module and an RS232 interface with UART RX interrupt. Unfortunately, it does not work in this program. Maybe I did something wrong. I'll check it out. Thanks for the quick fix. I'll let you...
by Lagoda
Thu Feb 08, 2018 1:51 pm
Jump to forum
Jump to topic

Re: Flowkit 2 Debugging Speed [Solved]

Hi Leigh, Thank you for quick responding to the problem. I tried to use FlowKit 2 on several machines, 1. on a laptop under WINDOWS 7 with Flowcode 7.3.0.6 + Patch 2. on a gamer machine under WINDOWS 10 under a newly installed Flowcode 7.3.0.6 + Patch 3. and a medium-sized desktop on WINDOWS 7 opera...
by Lagoda
Sun Feb 25, 2018 2:52 pm
Jump to forum
Jump to topic

Bug in the Data Recorder (SOLVED:Use the Data Recorder in ICT mode)

Hi Everyone,
I found this bug in Flowcode 7.3.0.6 during simulation.
I think the pictures say everything from the problem.

Best Regards,
Lagoda
by Lagoda
Mon Feb 26, 2018 5:59 pm
Jump to forum
Jump to topic

Re: Bug in the Data Recorder

Hello Ben,

I understand the cause of the problem.
Thank you again for the answer.

Lagoda
by Lagoda
Mon Feb 26, 2018 10:12 pm
Jump to forum
Jump to topic

Port mapping bug in the ICT module.

Hi Ben, I've written about this topic in the following post: http://www.matrixtsl.com/mmforums/viewtopic.php?f=2&t=19766 Unfortunately, it did not improve with 7.3.0.7 update, so I'll re-issue this problem. I would like to use ICT function of FlowKit2. In the Flowcode 7.3.0.5 or higher version, ...
by Lagoda
Wed Feb 28, 2018 12:31 pm
Jump to forum
Jump to topic

Re: A little cosmetic mistake. PIC32MZ

Hi Ben, I think this tag is more logical for 16-bit ports (H and L) than the PIC32 example. That's why I wrote a cosmetic mistake. PORTS.jpg If the ports of the PIC32 family are deliberately marked on this way, this is fine for me. But why do you use two types of marking within Flowcode? Best Regard...
by Lagoda
Wed Feb 28, 2018 1:42 pm
Jump to forum
Jump to topic

Re: A little cosmetic mistake. PIC32MZ

Hi Ben,

Once you have a lot of time ... :)

I just wanted to report it, it does not cause any problems.

Thank you very much for the answer.

Best Regards,

Lagoda
by Lagoda
Wed Dec 05, 2018 11:12 pm
Jump to forum
Jump to topic

Re: PIC24 Internal CLocking

Hi Leo,

I think the System Clock speed of the processor can not be higher than 32MHz, because in the PLL system block has a divider, that always divided by 3 the clock signal from 96 MHz output.

Kind regards,

Lagoda
by Lagoda
Thu Feb 07, 2019 1:04 pm
Jump to forum
Jump to topic

Re: Selecting a 2.048V reference voltage in PIC16F15324

Hi,


I didn't update, because it was up to date.
by Lagoda
Tue Feb 19, 2019 6:01 pm
Jump to forum
Jump to topic

Re: The PIC16F15344 PWM component can only be set to 8-bit mode.

Hi Ben,

I also tried Channel 3 and Channel 4, but they don't work either.

Lagoda
by Lagoda
Thu Feb 21, 2019 12:17 pm
Jump to forum
Jump to topic

Re: The PIC16F15344 PWM component can only be set to 8-bit mode.

Hi Ben,

In my C file, this line looks like this:

#define MX_PWM_NEW_TMR_CONF

(If I overwrite CONF2 then it works. :) )
by Lagoda
Fri Feb 22, 2019 1:39 pm
Jump to forum
Jump to topic

Re: The PIC16F15344 PWM component can only be set to 8-bit mode.

Hello Ben,


I think you have quite a lot of parallel tasks now.
Fixing this problem is not urgent for me, because I manually fix the wrong part in the C file and it will work. (I already know what to change. :D )

Thanks for the help.
Have a nice weekend!

Lagoda
by Lagoda
Thu Apr 11, 2019 10:18 am
Jump to forum
Jump to topic

Re: Flowcode V8 update on an offline machine

Hi Leigh, No, I copied files under C:\Program Files (x86)\Flowcode v8. :roll: :lol: Now I copied the directories as described and works. The C: ProgramData\ MatrixTSL\FlowcodeV8 is a hidden directory and it was not visible on my computer by default. Thanks for the quick response. Best Regards, Lagoda
by Lagoda
Tue Jul 30, 2019 10:34 pm
Jump to forum
Jump to topic

Re: 18F67K40 UART Problem

Hi, According to the MPLAB Code Configurator: " External clock frequency is greater than recommended value(20MHz) " You may have to try with a lower frequency. But this is just an idea. Unfortunately the MCLR pin can only be input port. MCLR Disabled.png Lagoda Using MPLABX, I created a te...
by Lagoda
Tue Jul 30, 2019 1:05 pm
Jump to forum
Jump to topic

Re: 18F67K40 UART Problem

Hi, Seokgi

The clock signal of target circuit is it working ?
I think, if the clock source is an HS quartz crystal connected to the OSC1 and OSC2 pins, then the OSC2 output must be enabled in the Project Option / Configure window.

Best Regards,

Lagoda
by Lagoda
Thu Aug 01, 2019 2:51 pm
Jump to forum
Jump to topic

Re: 18F67K40 UART Problem

OK.
Then you are sure that your circuit is not faulty.

Have you ever tried to set the HighVoltage programming mode in Configuration Settings? (This is now set to LV in your test program.)
What type of programming tool do you use?

Lagoda
by Lagoda
Tue Aug 06, 2019 2:33 pm
Jump to forum
Jump to topic

Re: PIC32 UART port Remap Pins setup

Hi Ben, Thanks for the quick response. You're right, the assignment of UART Channels and port banks is OK. I thought there was a bug in the Flowcode8 because if I change the Channel of UART, the port information in the Connection table will not be updated. If then click on the RX Remap Pin or TX Rem...
by Lagoda
Tue Aug 06, 2019 10:19 pm
Jump to forum
Jump to topic

Re: Pic32MZ2048EFG100 UART is 4 times to slow

Hi Stefan and Ben,

I have the same problem with the PIC32MZ EFM.
My target board is Microchip Curiosity.
I attached a little test program what I used for the check.

Best Regards,

Lagoda
by Lagoda
Wed Aug 21, 2019 9:55 am
Jump to forum
Jump to topic

Re: 18F67K40 UART Problem

Try this test program. Port C6 is the output of UART TX.

Is it working?

Lagoda
by Lagoda
Thu Aug 22, 2019 5:53 pm
Jump to forum
Jump to topic

Re: 18F67K40 UART Problem

Hi Seokgi, I set the transmission speed to 115200 baud. I think have you seen that. I'm sorry it doesn't work. I would like to use this MCU in the future. Just an idea (This is what I do when any peripheral is not working properly.): Create a very simple program in Flowcode that handles the peripher...