Search found 288 matches

by Lord Grezington
Fri Oct 16, 2020 4:41 pm
Forum: Flowcode V8
Topic: Compiling issues
Replies: 2
Views: 353

Compiling issues

Hello All I was out at the customer this week and installed flowcode onto the laptop with a program I did from the office desktop. I then got compiling errors, and to get rid of them I had to cut back the code by a very large proportion. So much so that I could only demponstrate the bare basic's of ...
by Lord Grezington
Mon Sep 21, 2020 5:57 am
Forum: Flowcode V8
Topic: PWM issues
Replies: 5
Views: 461

Re: PWM issues

Thank you QMesar

I have done what I can with attempting to vary the perieods and frequencies with no luck. I think what I will try next is use the high speed PWM peripherals on the dsPIC33EP32MC504 with C (rather than the PWM component) to see if the issue persists.

Thanks
by Lord Grezington
Sat Sep 19, 2020 2:33 pm
Forum: Flowcode V8
Topic: PWM issues
Replies: 5
Views: 461

PWM issues

Hello All I am trying to use the PWM outputs form the dsPIC33EP32MC504 to gernerate various waves from data stored in a LUT. In general it works very well, however I seem to be getting glitches on the falling edges (aways seems to be on falling, and never rising). As you can see in the triangle wave...
by Lord Grezington
Tue Aug 25, 2020 7:31 am
Forum: Freelance Embedded Engineers
Topic: Job Opportunity for Flowcode Programmer
Replies: 0
Views: 528

Job Opportunity for Flowcode Programmer

Hi All We have a job opening for an experienced flowcode programmer. if you think you are up for the position, please can you PM me with a CV? Thanks Embedded software engineer The Experienced embedded engineer will be required to take control and responsibility for various projects from concept rig...
by Lord Grezington
Wed Aug 12, 2020 3:55 pm
Forum: General Programming
Topic: Gyro_L3GD20
Replies: 11
Views: 2495

Re: Gyro_L3GD20

Hi Ben I am modifying this with more boards, and it seems like every Gygo has a different steady state. This was previously OK, but some of these new ones coming in have very high stationary values (above 15000). Is there some way I can easily set the default to 0, or do I need to do this in code to...
by Lord Grezington
Tue Aug 04, 2020 4:14 pm
Forum: Flowcode V8
Topic: MCP4261 Digital Pot
Replies: 3
Views: 501

Re: MCP4261 Digital Pot

Hi Leigh

The probelm is we cant disable the re-mapping of the pins. On the software mode re-mapping is always on, and the pins available for the remapping are not the standard hardware pins.

Thanks
by Lord Grezington
Fri Jul 31, 2020 1:19 pm
Forum: Flowcode V8
Topic: MCP4261 Digital Pot
Replies: 3
Views: 501

MCP4261 Digital Pot

Hi All We are trying to use the MCP4261 in a design, however when we add the component the parameters try to re-map to different pins as default. We dont need to re-map the pins and want to use the default pinout (MOSI D4, MISO D5 and CLK D6). There are no options to select these pins, even if we at...
by Lord Grezington
Fri Jul 31, 2020 7:54 am
Forum: Flowcode V8
Topic: PIC18F47Q10 ADC not working
Replies: 42
Views: 4171

Re: PIC18F47Q10 ADC not working

Morning Ben

Is it possible you can look into my previous post with the ADC's and the thermistors? It is not a noise issue as all the ADC inputs (including thermistors) have a 0.1uF cap to GND near the ADC pins.

Thanks
by Lord Grezington
Sun Jul 26, 2020 11:30 am
Forum: Flowcode V8
Topic: PIC18F47Q10 ADC not working
Replies: 42
Views: 4171

Re: PIC18F47Q10 ADC not working

Hi Ben I have another "Qiurk" with the Q10... I am running on the inteernal 64Mhz oscillator, and one some chips the ADC works fine, but on others I get some random values. I have managed to get around this issue on some of the ADC's by decreasing the conversion speed (to Fosc/64). This stabalises t...
by Lord Grezington
Fri Jul 10, 2020 1:29 pm
Forum: Flowcode V8
Topic: PIC18F47Q10 ADC not working
Replies: 42
Views: 4171

Re: PIC18F47Q10 ADC not working

Hi Ben I think I may have found another issue with the Q10... As soon as I add the EEPROM component onto the panel then try and compile I get the following compiling errors. -w=359,1273,1388 -fshort-float -fshort-double -std=c90 -Os C:\ProgramData\MatrixTSL\FlowcodeV8\CAL\PIC\PIC_CAL_EEPROM.c:212:18...
by Lord Grezington
Fri Jul 10, 2020 1:22 pm
Forum: General Programming
Topic: Gyro_L3GD20
Replies: 11
Views: 2495

Re: Gyro_L3GD20

I found the issue with this
by Lord Grezington
Mon Jul 06, 2020 2:36 pm
Forum: General Programming
Topic: Gyro_L3GD20
Replies: 11
Views: 2495

Re: Gyro_L3GD20

Hi Ben

Any luck with this? I just need an example of how I can extract say the z-axis data.

Thanks
by Lord Grezington
Fri Jul 03, 2020 7:46 am
Forum: General Programming
Topic: Gyro_L3GD20
Replies: 11
Views: 2495

Re: Gyro_L3GD20

Thanks Ben I will do some tests to see which component is the culprit. I have attached the latest testing variant of the Gyro test (still in software). When running I seem to be getting some data on Data2, but nothing on Data0 or Data1. Do you think you can take a look and let me know how I can dist...
by Lord Grezington
Thu Jul 02, 2020 1:59 pm
Forum: General Programming
Topic: Gyro_L3GD20
Replies: 11
Views: 2495

Re: Gyro_L3GD20

Hi Ben Thanks for the reply. If I disable the SPI component compelty, and then try run in hardware the program freezes (the OLED backlight comes on, but shows blank screen). I can get data if I run in software mode. I have attached my program for you to see. I also seem to be having reading the data...
by Lord Grezington
Wed Jul 01, 2020 4:50 pm
Forum: General Programming
Topic: Gyro_L3GD20
Replies: 11
Views: 2495

Re: Gyro_L3GD20

Hi Ben I have the SPI MAster connected to the same pins as the SPI Gyro (MOSI, MISO, CLK) but with different SS for another component. The program compiles fine, but when I test it on hardware the it freezes. When I then set the Gyro to software mode it does not freeze. Is it possible to use the sam...
by Lord Grezington
Wed Jul 01, 2020 4:40 pm
Forum: Flowcode V8
Topic: PIC18F47Q10 ADC not working
Replies: 42
Views: 4171

Re: PIC18F47Q10 ADC not working

Thanks Ben

All seems to be working fine so far...
by Lord Grezington
Thu Jun 18, 2020 5:13 pm
Forum: Flowcode V8
Topic: PIC18F47Q10 ADC not working
Replies: 42
Views: 4171

Re: PIC18F47Q10 ADC not working

Hi Ben I have copied the file in into the the stated folder, re-started flowcode and even cleared the cache. I have tried multiple channels of the PWM, saved the program under a differnet version number, re-compiled but unfotuantly it still does not seem to be working. Do you think maybe its got som...
by Lord Grezington
Wed Jun 17, 2020 4:56 pm
Forum: Flowcode V8
Topic: PIC18F47Q10 ADC not working
Replies: 42
Views: 4171

Re: PIC18F47Q10 ADC not working

Thanks Ben
by Lord Grezington
Tue Jun 16, 2020 9:12 am
Forum: Flowcode V8
Topic: PIC18F47Q10 ADC not working
Replies: 42
Views: 4171

Re: PIC18F47Q10 ADC not working

Hi Ben

I have tested the "#define MX_TIMERSELECT0"

Unfortuntalty I still dont get anything when compiling on any of the PWM channels.

I measured all the pins just to be sure

UART still works fine

Thanks
by Lord Grezington
Thu Jun 11, 2020 4:56 pm
Forum: Bug Reports
Topic: Serial EEPROM 24C32
Replies: 2
Views: 446

Re: Serial EEPROM 24C32

Hi Stefan I am fairly sure the dsPIC33EP32MC204 device does have two hardware I2C channels. I only need one channel (channel 2) using B5 & B6. I can not change these pins as the design is on a PCB. The 24C32 works perfectly when I use software B5 and B6, but as soon as I switch to the hardware optio...
by Lord Grezington
Thu Jun 11, 2020 12:21 pm
Forum: Bug Reports
Topic: Serial EEPROM 24C32
Replies: 2
Views: 446

Serial EEPROM 24C32

Hi All

I am using the dsPIC33EP32MC204 with a external EEPROM 24C32.

The 24C32 works perfectaly when I use software mode, but I get no I2C when I use hardware mode channel 2 (SDA on B5 and SCL on B6).

Can anyone help with a fix?

Thanks
by Lord Grezington
Thu Jun 11, 2020 10:25 am
Forum: Flowcode V8
Topic: PIC18F47Q10 ADC not working
Replies: 42
Views: 4171

Re: PIC18F47Q10 ADC not working

Morning Ben

Do you think you might have a chance to take a look at this today? The new assembled PCB's should be arriving any minute now and it would be good if I can complete the project this week.

Thanks
by Lord Grezington
Wed Jun 10, 2020 1:57 pm
Forum: General Programming
Topic: RS485 - Driver Enable/Reciever Enable
Replies: 3
Views: 1534

Re: RS485 - Driver Enable/Reciever Enable

Hi Leigh

Yes, it does work. However I still needed to add a 200us delay before re-setting the time and sending the data packet. Still better than software though...

Is it possible to edit the UART hardware component to add this option rather than using the timer?

Thanks
by Lord Grezington
Wed Jun 10, 2020 12:51 pm
Forum: General Programming
Topic: RS485 - Driver Enable/Reciever Enable
Replies: 3
Views: 1534

Re: RS485 - Driver Enable/Reciever Enable

Yeah, I can see that working...

The timer will need to be different every time as I have a different number of data packets, but definitely worth giving a go.

Thanks Leigh
by Lord Grezington
Wed Jun 10, 2020 11:28 am
Forum: General Programming
Topic: RS485 - Driver Enable/Reciever Enable
Replies: 3
Views: 1534

RS485 - Driver Enable/Reciever Enable

Hi Guys I have now moved on in the project to get the RS485 working. Issue I am having is I would like to keep the UART based in hardware rather than software. As the RS485 IC's use a NOT RE and a DE. I tie these two pins together and just use them as a single write enable pin (I have attached the d...