Search found 66 matches

by howard123
Wed Apr 25, 2018 4:42 pm
Forum: Bug reports
Topic: PIC18F26K80 I2C read problem
Replies: 4
Views: 1278

Re: PIC18F26K80 I2C read problem

Hi
I believe you have to have a delay between writing to the ADC and reading from it.
Not positive on that exact chip, but the delay will be related to the resolution you require.

Howard
by howard123
Sat Mar 31, 2018 1:01 pm
Forum: Bug reports
Topic: UART not working after latest patch
Replies: 2
Views: 1221

Re: UART not working after latest patch

Hi Ben Thanks I have followed your instructions and it has worked. On both projects UART1 and UART2 are being used and as best I can tell,on both, UART1 had been assigned to UART 2 and UART2 was not working. On the Properties I swopped channel number 1&2 and then swopped them back again and it s...
by howard123
Sat Mar 24, 2018 2:01 pm
Forum: Bug reports
Topic: UART not working after latest patch
Replies: 2
Views: 1221

UART not working after latest patch

Hello I have just installed the patch dated January 2018 and am now having problems with the RS232 UART not working at all. This has happened on two non-identical boards, one with a 18F45K22 and the other with a 18F46K22. These had both worked before I installed the patch. Unfortunately I have not k...
by howard123
Sat Jan 20, 2018 9:46 am
Forum: Feature requests
Topic: User interface ideas
Replies: 6
Views: 2245

Re: User interface ideas

Hi. Reporting of bugs and status thereof. Bug reporting from the help tab is a useful idea for a fast entry but there is no feedback to the user on the status. How about all bug reports, including those entered on the forum, be given a ticket number. In the case of those entered from the help tab, a...
by howard123
Fri Jan 19, 2018 11:01 am
Forum: Bug reports
Topic: Erratic timer operation
Replies: 3
Views: 967

Re: Erratic timer operation

Hi Ben The code in main is mostly illustrative and not necessarily needed. I have subsequently made a main loop counter to derive time for this application and that is working fine so timers are no longer required. On my hardware, the output within the IRS (B2) is erratic and is related in some way ...
by howard123
Mon Jan 15, 2018 11:32 am
Forum: Bug reports
Topic: Erratic timer operation
Replies: 3
Views: 967

Erratic timer operation

Hello all I am having a problem with the timers on a PIC16F18854 in that there is an irregular behavior in the servicing of the associated ISR. This manifests as the ISR running sometimes as normal, sometimes as irregular and sometimes as not running at all. When it does run, the ISR is at the corre...
by howard123
Fri Jan 12, 2018 2:04 pm
Forum: Bug reports
Topic: Timer not working
Replies: 4
Views: 1103

Re: Timer not working

Hi Ben It may be of use to you to know that I have duplicated this problem on a different chip type from the same family. In this example I have enabled each timer, TMR1 TMR3 TMR5, one at a time to deliver about 30Hz. These are the results.. TMR1 correctly flashes the attached LED at 1Hz TMR3 does n...
by howard123
Sat Jan 06, 2018 4:27 pm
Forum: Bug reports
Topic: FAT component timing
Replies: 1
Views: 453

Re: FAT component timing

Hi
I have changed the SD card to a 80Mb/s type and all is now ok. Changing the frequency now changes the write speed, which gets down to an acceptable 15mS period.
Howard
by howard123
Wed Jan 03, 2018 5:57 pm
Forum: Bug reports
Topic: Timer not working
Replies: 4
Views: 1103

Re: Timer not working

Hi Ben
Here is that code
thanks
Howard
by howard123
Sun Dec 31, 2017 1:13 pm
Forum: Bug reports
Topic: Timer not working
Replies: 4
Views: 1103

Timer not working

Hello all

The TMR3 on my PIC device does not work when used as a timer. Reassigning to identical TMR1 or TMR5 does however work.

Great new year everyone.

Howard
PIC18F45K22
FC 7.3.0.5
by howard123
Fri Dec 22, 2017 12:42 pm
Forum: Bug reports
Topic: FAT component timing
Replies: 1
Views: 453

FAT component timing

Hello all I have noticed on my hardware that changing the SD card HighSpeed Pre-scale value has little effect on the time it takes the thing to execute. Measurements that I have obtained are Fosc/4 : 305mS, Fosc/16 : 304mS, Fosc/64 : 306mS. My Oscillator is running at 32MHz and the string I am sendi...
by howard123
Sun Dec 17, 2017 8:10 am
Forum: Feature requests
Topic: User interface ideas
Replies: 6
Views: 2245

Re: User interface ideas

Hi
Variable case sensitivity for instance finds. A variable is case insensitive whereas an instance find is case sensitive. A variable defined as TestOne is allowed to be written as Testone however the instance find only then finds TestOne occurrences.
by howard123
Wed Nov 22, 2017 9:10 am
Forum: Bug reports
Topic: UART receive problem
Replies: 3
Views: 1325

Re: UART receive problem

Turns out this was a bad solder joint on the SMD receive pin of my device. Sometimes when it made a contact it would work well and when open would cause a timeout (255)

Sorry if I misled anyone
Howard
by howard123
Sat Nov 18, 2017 1:33 pm
Forum: Bug reports
Topic: UART receive problem
Replies: 3
Views: 1325

Re: UART receive problem

Hi Thank you for your interest in this. I have attached a reduced but still UART 2 RS232 dis-functioning version of the project. I have made a Labview simulation of the instrument and so the timing is not as previously described. To compensate, I have set the UART timeout to 50ms for this test. The ...
by howard123
Fri Nov 17, 2017 1:06 pm
Forum: Bug reports
Topic: UART receive problem
Replies: 3
Views: 1325

UART receive problem

Hello all I am having a problem with a serial receive that I hope you could help me with. I send a number to an instrument and receive data from it using channel 2 UART on a 18F46K22 using 9600 baud. One character is sent and one is received. Most often the return character is incorrect with a value...
by howard123
Sat Oct 28, 2017 12:23 pm
Forum: 8-Bit PIC
Topic: PLL not working
Replies: 2
Views: 962

Re: PLL not working

Hi
This has worked perfectly.
Thank you for your kindness.
regards
Howard
by howard123
Thu Oct 26, 2017 2:51 pm
Forum: 8-Bit PIC
Topic: PLL not working
Replies: 2
Views: 962

PLL not working

Hello all I have a PIC18F46K22 running on the internal high frequency oscillator and producing 16MHz. I would like to increase the speed, using the PLL, up to a maximum speed of 64MHz but am not having success in doing this. I have set the PLL Enable (PLLCFG) in the Configuration as well as combinat...
by howard123
Sat Sep 09, 2017 9:56 am
Forum: Feature requests
Topic: User interface ideas
Replies: 6
Views: 2245

User interface ideas

Hello all Here are a few ideas that you may care to consider and implement in Flowcode regarding the user interface. I have included a few minor glitches which possibly have been mentioned before by others. 1. Notes field. I find that when developing something I keep a word processing program on han...
by howard123
Tue Sep 05, 2017 2:26 pm
Forum: Bug reports
Topic: I2C causes processor to hang {Solved}
Replies: 2
Views: 1304

Re: I2C causes processor to hang

Thanks Ben
This has worked
regards
Howard
by howard123
Sun Sep 03, 2017 2:25 pm
Forum: Bug reports
Topic: I2C causes processor to hang {Solved}
Replies: 2
Views: 1304

I2C causes processor to hang {Solved}

Hello All Hope you can help me with this problem. I have a PIC18F46K22 connected to a DS3231 RTC using I2C communicating over hardware channel 2. I am not able to read from the RTC without causing my processor to hang. This is caused by the SDA line being held low - there is no NAK generation. LA te...
by howard123
Thu Aug 17, 2017 3:23 pm
Forum: Bug reports
Topic: Port B not working
Replies: 7
Views: 2060

Re: Port B not working

Hi Ben
Many thanks this has worked :D
by howard123
Thu Aug 17, 2017 10:50 am
Forum: Bug reports
Topic: Port B not working
Replies: 7
Views: 2060

Re: Port B not working

Hi Ben and thanks for the speedy response once again. Unfortunately that did not work for me. My apologies as my example was more illustrative than functional so here is something more robust. I have used a byte wide input rather than bits and compared Port A to Port B. In test1 raising any Port B p...
by howard123
Mon Aug 14, 2017 12:56 pm
Forum: Bug reports
Topic: Port B not working
Replies: 7
Views: 2060

Re: Port B not working

Hi Ben and Martin I had installed those updates some time ago. There is no compiler error message. I am using a PicKit 3 to target the device and this uses RB6 and RB7 for its communications. This works fine and later, with the programmer disconnected, RB7, RB6, RB5, RB4, RB3, RB2, RB1 and RB0 work ...
by howard123
Mon Aug 14, 2017 11:20 am
Forum: Bug reports
Topic: Port B not working
Replies: 7
Views: 2060

Port B not working

Hi all

Writing of bits to any of the B port pins is not recognized. Writing to ports A or C is fine.

This is on my target hardware which is a PIC16F18855.

Any ideas?

Thanks
Howard
FC7.2.1.4
by howard123
Wed May 03, 2017 10:33 am
Forum: Flowcode V7
Topic: delay function problem
Replies: 3
Views: 2329

Re: delay function problem

Thanks I understand now
regards
howard