Search found 29 matches

by ARM
Mon Mar 07, 2016 7:00 pm
Forum: Bug reports
Topic: Bugs in UART and SPI Master and TCP/IP components
Replies: 4
Views: 3883

Re: Bugs in UART and SPI Master and TCP/IP components

Hello, UART1: when enabling UART1 in Macro "SYS_initialise peripheral" (enable 2 Macro calls) and set PA 21 (RXD1) to ground, SPI COM to mcp23S17 and UART0 crashes. You can use the Project "Test_35" or "Flowcode check" SPI: SPI COM to W5500io/WIZ810MJ was tested with "send String" too, but no respon...
by ARM
Sat Mar 05, 2016 3:38 pm
Forum: Bug reports
Topic: Bugs in UART and SPI Master and TCP/IP components
Replies: 4
Views: 3883

Bugs in UART and SPI Master and TCP/IP components

After installing FC V1.3 i got following Bugs. -->UART1 INT no function. Same Error like FCV 1.2 (reported in 2015). --> SPI MAster Mode 0,3 Pin clocking failure: - SPI communication to MCP23S17 is OK. - SPI communication to WIZnet W5100 or WIZnet W5500 not possible, because the single bits are in M...
by ARM
Tue Feb 09, 2016 12:30 am
Forum: Bug reports
Topic: Multiple bugs in UART1 - I2C - PWM - components
Replies: 13
Views: 5095

Re: Multiple bugs in UART1 - I2C - PWM - components

I had insert "TCP/IP Base WIZ810MJ" for Webserver or TCP/IP Industrial Ethernet. I had implement the Example Project "interactive Web Server". But I cannot connect to WIZ810MJ. Maybe there is an conflict with "SPI Master" component? The connection of Ethernet module is ok, because when disconnect Mo...
by ARM
Sun Feb 07, 2016 11:45 pm
Forum: Bug reports
Topic: Multiple bugs in UART1 - I2C - PWM - components
Replies: 13
Views: 5095

Re: Multiple bugs in UART1 - I2C - PWM - components

I had replace the Webserver (WIZ810MJ) to TCP/IP (WIZ810MJ) and CPU doesn´t stop now.

When did WIZ810MJ flashes the LED? After Calling Macro "Initialise"?
by ARM
Sun Feb 07, 2016 9:34 pm
Forum: Bug reports
Topic: Multiple bugs in UART1 - I2C - PWM - components
Replies: 13
Views: 5095

Re: Multiple bugs in UART1 - I2C - PWM - components

Hello, here a short description: - When receiving data on UART1 RXINT Pin, CPU crashes. Macro: - Sys_Initialise_Peripheral - UART1_RXINT_ - When call macro "WIZ810MJ" "create Server Socket" CPU stops. Need them for web server or TCP/IP Industrial Ethernet communication. Macro: - Sys_Initialise_Perip...
by ARM
Sun Jan 31, 2016 3:33 pm
Forum: Bug reports
Topic: Multiple bugs in UART1 - I2C - PWM - components
Replies: 13
Views: 5095

Re: Multiple bugs in UART1 - I2C - PWM - components

Hello,

I have copy the latest bugfix files from 18.01.2016.

Activating the UART1 INT is ok. But when receiving data on Pin, all communication Ports and CPU crashes. The program does not jump in the interrupt macro.
by ARM
Tue Jan 12, 2016 1:11 pm
Forum: Bug reports
Topic: Multiple bugs in UART1 - I2C - PWM - components
Replies: 13
Views: 5095

Re: Multiple bugs in UART1 - I2C - PWM - components

Yes of course,

HMI is running on UART Channel 2. The corresponding pins to these channel are PA5 and PA6 wich relates to RXINT0 in the CPU.
COM#1 is running on UART Channel 1. The corresponding pins to these Channel are PA21 and PA22 wich relates to RXINT1 in the CPU.
(seepage 35 of attachment)
by ARM
Tue Jan 12, 2016 10:54 am
Forum: Bug reports
Topic: Multiple bugs in UART1 - I2C - PWM - components
Replies: 13
Views: 5095

Re: Multiple bugs in UART1 - I2C - PWM - components

When receiving Data in UART1 RXINT (Macro: COM1_UART1_RXINT_Test) UART0 and CPU crashes.
by ARM
Fri Jan 08, 2016 4:20 am
Forum: Bug reports
Topic: SPI Hardware and Software Interface Breakdown
Replies: 0
Views: 1950

SPI Hardware and Software Interface Breakdown

Device: AT91SAM7s512 SPI Hardware Interface, Pin connection Error in SPI properties. No SPI Hardware Interface available, the same problem like the Hardware I2C Interface. Macro: "COM3_SPI_TXD_Test" When Initialise Software SPI_Master_1. CPU Pin MISO is rising to 1 Signal, all other Pins have 0 Sign...
by ARM
Thu Jan 07, 2016 12:52 am
Forum: Bug reports
Topic: Multiple bugs in UART1 - I2C - PWM - components
Replies: 13
Views: 5095

Re: Multiple bugs in UART1 - I2C - PWM - components

Hello, I have a new update for UART1 Bug. There is also a Bug in SPI Hardware Interface: UART1 Hardware Interface Failure: Pin connection failure in RS232 1 properties. Connections: TX = C6 (PA22) --> OK - PA22 (TXD1) RX = C7 (PA23) --> Failure: PA21 (RXD1) SPI Hardware Interface Failure: Pin connec...
by ARM
Mon Jan 04, 2016 1:47 pm
Forum: Bug reports
Topic: Multiple bugs in UART1 - I2C - PWM - components
Replies: 13
Views: 5095

Re: Multiple bugs in UART1 - I2C - PWM - components

Hello,

the resistors on I2C software pins I forgot.

Thanks.
by ARM
Sun Jan 03, 2016 9:48 pm
Forum: Bug reports
Topic: Multiple bugs in UART1 - I2C - PWM - components
Replies: 13
Views: 5095

Multiple bugs in UART1 - I2C - PWM - components

Device: AT91SAM7S512_64 ********** Bug in UART1 (breakdown of UART0 and UART1 hardware interfaces): ********** When UART1 interrupt in macro "Sys_Initialise_Peripheral" is deactivated, the program is running. When UART1 interrupt is active, UART0 cannot receive Bytes. Note: UART0/UART1 of CPU & UART...
by ARM
Sun Dec 13, 2015 7:57 pm
Forum: Bug reports
Topic: Bug in ARM PWM Component Macro
Replies: 5
Views: 2260

Re: Bug in ARM PWM Component Macro

Hello, here I have the latest update: In PWM component: ()=10bit command Cannot set duty cycle. 0-1 (0-19)=PWM is off. 2-255 (20-1024)=PWM is running but no frequency change. Testted with "setDutyCycle" and "SetDutyCycle10". And command "changePeriod" has no effect. Only value in the PWM component P...
by ARM
Sun Dec 06, 2015 9:19 pm
Forum: Bug reports
Topic: Bug in ARM PWM Component Macro
Replies: 5
Views: 2260

Re: Bug in ARM PWM Component Macro

Hello, I had copy the update files and now I have no compiler error. There are still warnings (see attachment), but the program runs. Many thanks. Mill Control - Test_4.msg.txt I have still two questions to PWM component: 1.) In the properties of the PWM component the maximum value of "Period Overfl...
by ARM
Sun Nov 29, 2015 11:47 am
Forum: Bug reports
Topic: Bug in ARM PWM Component Macro
Replies: 5
Views: 2260

Re: Bug in ARM PWM Component Macro

Hello, I have replace the CAL file in the ARM directory and now the compiler generats the folowing message: Device: ARM.AT91SAM7S.AT91SAM7S512_64 Generated by: Flowcode v6.1.2.0 Start des Compilers... C:\Program Files\Flowcode 6\compilers\arm\batchfiles\arm7comp.bat "Mill Control - Test_4" "D:\relea...
by ARM
Sun Nov 22, 2015 6:07 pm
Forum: Bug reports
Topic: Bug in ARM PWM Component Macro
Replies: 5
Views: 2260

Bug in ARM PWM Component Macro

Hello, After I had plug in a PWM component in my system I got the following compiler error: (The error occurs also when I open an empty project and add a PWM component to the System window, without any PWM program code.) ___________ Compiler Message ______________ Device: ARM.AT91SAM7S.AT91SAM7S512_...
by ARM
Wed Nov 11, 2015 6:52 pm
Forum: Bug reports
Topic: Bug in ARM serial communication and external Interrupt
Replies: 4
Views: 2324

Re: Bug in ARM serial communication and external Interrupt

Hello Benj, many thanks for the example. I will test it the next days. I hope not that the bug was in the controller. I must use SAM7S512 because I need much ROM for HMI applications. If the program didn´t run, then I must wait for Flowcode 7. PS: Flowcode is very interesting and I think in the futu...
by ARM
Tue Nov 10, 2015 9:02 pm
Forum: Flowcode V6
Topic: #### Is Flowcode useable for complex applicatios ####
Replies: 9
Views: 5507

Re: #### Is Flowcode useable for complex applicatios ####

Hello, it can be that Flowcode for pic or other chippacks works well. But i had reported my problems. When i want to receive serial Data from external interrupt Flowcode crashes. I missed many things in Flowcode for efficent ARM design. For example chip configuration as in pic chippack or Interrupt ...
by ARM
Fri Nov 06, 2015 10:33 am
Forum: Flowcode V6
Topic: #### Is Flowcode useable for complex applicatios ####
Replies: 9
Views: 5507

#### Is Flowcode useable for complex applicatios ####

Hello, before 1 month i bought Flowcode professional with ARM chippack. The controller where I uses is an AT91SAM7S. - The first problem was, that i cannot jump in external interrupt. This problem was fixed from Matrix very fast. I had become a new *.fcd file for the AT91SAM7S512_64 controller. -The...
by ARM
Sun Oct 25, 2015 7:20 pm
Forum: Bug reports
Topic: Bug in ARM serial communication and external Interrupt
Replies: 4
Views: 2324

Bug in ARM serial communication and external Interrupt

Hello, I am using the ARM controller AT91SAM7S512_64. On PA31 i use a switch for jumping in a macro to send commands over RS232 to the display. Transmitting data to the display and receiving "ACK" from the display is OK (0x06). (Macro: Open_TouchMacro) Pin 20 of the controller (IRQ0) is connected to...
by ARM
Tue Oct 20, 2015 8:20 pm
Forum: Flowcode V6
Topic: external Interrupts on ARM devices doesn´t work
Replies: 8
Views: 3412

Re: external Interrupts on ARM devices doesn´t work

Hello, I´m sorry but I think it was a mistake. In the Atmel datasheet of AT91SAM7s UART0 was connected to Port PA5 and PA6 and UART1 was connected to PA21 and PA22. In Flowcode UART0 of the microcontroller was declared as channel 2 and is connect to PA5 and PA6. So UART0 is actually Channel 2 in Flo...
by ARM
Thu Oct 15, 2015 8:45 pm
Forum: Flowcode V6
Topic: external Interrupts on ARM devices doesn´t work
Replies: 8
Views: 3412

Re: external Interrupts on ARM devices doesn´t work

Hello,

can you fix the problem?
by ARM
Sat Oct 10, 2015 12:01 pm
Forum: Flowcode V6
Topic: external Interrupts on ARM devices doesn´t work
Replies: 8
Views: 3412

Re: external Interrupts on ARM devices doesn´t work

External INT0 and INT1 works fine. TXINT0 also works. RXINT0 no function. When I´m collecting serial data without interrupt, the first byte is ok but all following bytes have value 0xFF (Macro: Initialise_ReadTouchData - at the end of macro). But the first byte is only ok when I´m starting controlle...
by ARM
Wed Oct 07, 2015 9:41 pm
Forum: Feature requests
Topic: Capacitive Touch (mTouch)
Replies: 4
Views: 3006

Re: Capacitive Touch (mTouch)

Hello,

look at edip touch displays. It is a very nice solution for touch project. Also with capacitve touch.

greetings

ARM
by ARM
Tue Oct 06, 2015 10:22 pm
Forum: Flowcode V6
Topic: external Interrupts on ARM devices doesn´t work
Replies: 8
Views: 3412

Re: external Interrupts on ARM devices doesn´t work

Hello,

I just take a look at the fixed file and I had seen that the I/O configuration is not correct, because the file is for AT91SAM7S512 with 32 pins. But I use the AT91SAM7S512_64 with 64 pins.


gretings

ARM