Search found 22 matches

by FCCHow
Tue Oct 26, 2010 2:10 pm
Forum: Components (Other)
Topic: Flashing 7-segments
Replies: 6
Views: 8383

Re: Flashing 7-segments

Dear medelec35,

Wow! It works! Just rebuilt the circuit (as I only had one proto board for two projects) and tested it. Its working fine. Thanks for your help!
by FCCHow
Thu Oct 07, 2010 2:17 pm
Forum: Components (Other)
Topic: Flashing 7-segments
Replies: 6
Views: 8383

Re: Flashing 7-segments

Dear medelec35,

Sorry for the late reply. I will try this out this weekend.


Yeah, I am saving up for FC v4 soon.
by FCCHow
Sat Oct 02, 2010 7:16 am
Forum: Components (Other)
Topic: Flashing 7-segments
Replies: 6
Views: 8383

Re: Flashing 7-segments

So, can anyone help me?
by FCCHow
Fri Sep 24, 2010 12:20 pm
Forum: Components (Other)
Topic: Flashing 7-segments
Replies: 6
Views: 8383

Flashing 7-segments

I have build a circuit which connects to a 3 common anode 7-segment LED display. This is for a project for a friend which I want to test out the 7-segment LED function. The program functions as follows: 1) When powered up, it displays '999' 2) Pressing the switch at Port A6 will make the display cou...
by FCCHow
Sat Jan 30, 2010 11:27 am
Forum: Article Discussion
Topic: MX017 - Mood Light
Replies: 7
Views: 13420

Re: Mood Light

Nice. I've been trying a long time to learn this PWM on a PIC for years that has no PWM features. Alas, this file is a newer version which my Flowcode (3.6.11.53) could not open. Still, I gave it a '5'. "The file you are loading was made by a newer version of Flowcode (31>20) and may not load correc...
by FCCHow
Fri Jan 01, 2010 2:35 am
Forum: Flowcode V2 & V3
Topic: PICs are acting weird
Replies: 4
Views: 2702

Re: PICs are acting weird

Dear Benj, First and foremost, I would like to take this opportunity to wish you and everyone at Matrix a Happy New Year! I have connected the power cable as suggested and frankly, I'm stumped. Maybe I am imagining things but I did remember the last time, previous projects responded well without tha...
by FCCHow
Sun Dec 27, 2009 2:53 pm
Forum: Flowcode V2 & V3
Topic: PICs are acting weird
Replies: 4
Views: 2702

Re: PICs are acting weird

Dear Steve, I have set it to run at 4MHz as this is the normal speed I do with the PCI16F628A. I have also tested other clock sources such as RC and XTAL and they're all gave me the same problem; the program will run fine and was able to "reset" the PIC after I enabled the Master Clear Enable. But i...
by FCCHow
Sat Dec 26, 2009 3:40 pm
Forum: Flowcode V2 & V3
Topic: PICs are acting weird
Replies: 4
Views: 2702

PICs are acting weird

Hi, guys. First of all, Merry Christmas! I am not sure of this is the correct thread since the problem could either be Flowcode v3 or the v3 E-Blocks Multiprogrammer board. But this is a long one. It seems that everytime I take out the e-blocks and the V3 multiprogrammer, something bad happens. This...
by FCCHow
Tue Oct 13, 2009 3:25 am
Forum: General / Misc
Topic: Could not ID the onboard chip
Replies: 3
Views: 3009

Re: Could not ID the onboard chip

Dear Benj,

Thanks for the information. It is weird that all 10 of my 8-pin PICs behaved this way, as if they have an expiry date. Anyway, I have no choice but to regress back to my old PICstart+ Programmer for them. Thank you very much.

Dear Steve,
I shall try the RC and XToption just in case.
by FCCHow
Sun Oct 11, 2009 1:43 pm
Forum: General / Misc
Topic: Could not ID the onboard chip
Replies: 3
Views: 3009

Could not ID the onboard chip

Not sure where to put this but if this is the wrong place, can the Mods please relocate the thread. Thanks. This is my problem: I am using Flowcode 3 and after not using the EB-006 programmer for months, I stored it in a plastic container box. But just today, I took it out to program some amendments...
by FCCHow
Tue Jul 31, 2007 11:23 am
Forum: Flowcode V2 & V3
Topic: Components
Replies: 30
Views: 39743

Wow. Thank you. I actually forgot about that section ever since I went into your Forum.
by FCCHow
Mon Jul 23, 2007 6:48 am
Forum: Flowcode V2 & V3
Topic: Components
Replies: 30
Views: 39743

Well, apart from having to look at new components, I would very much prefer a guided tutorial that explains in terms of macros, interrupts, how each component works, etc. The tutorial files included in the Flowcode software is fine but it just stops there. So in the end, every program that I have su...
by FCCHow
Mon Apr 09, 2007 6:48 am
Forum: Flowcode V2 & V3
Topic: PWM component is almost ready
Replies: 16
Views: 8049

You're welcome. Now, I want to take this a step further. Electroluminescent material needs an alternating voltage from 50volts to 220volts and uses a 2.5mA per sq inch or material. Since I am not so familiar in PWM, is it possible to amplify the sinusoidal wave from the PIC and then make the EL medi...
by FCCHow
Wed Apr 04, 2007 4:26 am
Forum: Flowcode V2 & V3
Topic: PWM component is almost ready
Replies: 16
Views: 8049

Here you go. I have used the sample PWM module and modified a bit to glow an LED on the PIC16F628A. Please ignore the sound as my daughter was curious and took me a lot of takes to get a decent video :lol:

http://chowfookcheong.blogspot.com/2007/04/pwm.html
by FCCHow
Mon Mar 26, 2007 4:18 am
Forum: Flowcode V2 & V3
Topic: PWM component is almost ready
Replies: 16
Views: 8049

I would like to try out the PWM component too for the PIC16F628A to dim and light up LEDs.
by FCCHow
Sat Mar 17, 2007 4:46 am
Forum: Flowcode V2 & V3
Topic: PIC10F200
Replies: 2
Views: 2608

Thank you, Ben.

I might not know much about the PWM, but I think your upcoming PWM module for the Flowcode could be used to drive and dim some Luxeon LEDs. So, this might be a good thing for the PIC10f200
by FCCHow
Fri Mar 16, 2007 5:50 am
Forum: Flowcode V2 & V3
Topic: PIC10F200
Replies: 2
Views: 2608

PIC10F200

Dear Guys,

I just got a PIC10F200 I/P and discovered there is no such PIC in Flowcode. Will there be any for this PIC in the near future?
by FCCHow
Wed Mar 14, 2007 11:08 am
Forum: Flowcode V2 & V3
Topic: Let Us Know What You Are Doing With Flowcode
Replies: 42
Views: 54859

I am using Flowcode to design a system which displays 10 LEDs, have three switch inputs, lights up a Luxeon, and gives multiple sound playback for each button pushed. I am trying to figure out how to use SPI to control the LEDs and the sound IC chip, reading up on MAX7219, ISD4001-120 and PIC. This ...
by FCCHow
Tue Feb 13, 2007 1:28 pm
Forum: Flowcode V2 & V3
Topic: SPI COMUNICATION
Replies: 24
Views: 13057

Hello. There is one question I would like to know, which is, can the PIC16F628A be used for SPI? I have seen a circuit which uses PIC16F84 for SPI, though. This is because I am going to try to use it to control the ISD4002 sound chip which uses SPI. Is there any other tutorials for the Flowcode3? Th...
by FCCHow
Wed Aug 02, 2006 2:50 am
Forum: Flowcode V2 & V3
Topic: Flowcode and MPLAB IDE
Replies: 5
Views: 4256

Dear Ian,

So, this means my untinstalling and reinstalling the Flowcode was not a good idea. Is there any other way to explain how to do this step by step as it all seemed very Greek to me.

Thanks in advance.
by FCCHow
Mon Jul 31, 2006 4:37 pm
Forum: Flowcode V2 & V3
Topic: Flowcode and MPLAB IDE
Replies: 5
Views: 4256

Dear Ian, I have targeted the PIC in both Flowcode and PICstart Plus as PIC16F628A, disabled the Watchdog timer and also, use XT as oscillator. As you have suggested, I created a simple LED flashing program and tried to compile it. Nothing works until I noticed the DOS window when I was compiling to...
by FCCHow
Fri Jul 28, 2006 10:51 am
Forum: Flowcode V2 & V3
Topic: Flowcode and MPLAB IDE
Replies: 5
Views: 4256

Flowcode and MPLAB IDE

I have just bought the Flowcode v2.0 and also finally got to upgrade my 1996 PicStart Plus too. After poking about in the tutorials, I have charted my first program for the PIC16F628A. I saved it, and used MPLAB to assemble it and then programmed it to the PIC. And nothing happens. Although the Flow...