Search found 157 matches

by Alan_37
Mon Jul 27, 2020 12:52 am
Forum: User Components
Topic: Search and Split String
Replies: 1
Views: 135

Search and Split String

Hi, Some time ago I made this simple but very powerful Macro thought would be nice to share with the community. Maybe someone could make a Component out of it I use this almost all the time. The Macro takes an input string and another 2 search strings, It Searches for a specific word or letter in th...
by Alan_37
Wed Jul 08, 2020 12:36 pm
Forum: Bug reports
Topic: Function pow (x,y)
Replies: 2
Views: 137

Re: Function pow (x,y)

Hi Benj ,

chip is Atmega2560, in the simulation work fine.
by Alan_37
Wed Jul 08, 2020 12:27 pm
Forum: Bug reports
Topic: Function pow (x,y)
Replies: 2
Views: 137

Function pow (x,y)

Just found a bug in the pow Function

result = pow (x,y)

pow (2,0) = 1 (ok )
pow (2,1) = 2 ( ok )
pow (2,2) = 3 ( ? )
pow (2,3) = 7 ( ? )

if y is greater than 1 the result is wrong by -1

I resolved this by doing if ( y > 1) {result = result +1 } but i think it is still u bug .
by Alan_37
Sun May 10, 2020 6:00 pm
Forum: Bug reports
Topic: SD Card file name
Replies: 2
Views: 374

SD Card file name

Hi ,

I don't know if this is a bug, but i noticed that if the file name in the sd-card is longer then 8 characters
will return file not found .

Is there a chance we could fix this please ?
by Alan_37
Wed Feb 12, 2020 9:47 pm
Forum: Feature Requests
Topic: SLIP Protocol
Replies: 0
Views: 1705

SLIP Protocol

Hi, I am working on a project that uses ESP-Link it is possible to do outbound HTTP REST requests from the attached microcontroller but in order to communicate with esp-link data must be sent in SLIP protocol format. There is already an Arduino library for this protocol the name is el-client Availab...
by Alan_37
Sat Mar 16, 2019 4:00 pm
Forum: General Programming
Topic: Telnet ENC28J60
Replies: 3
Views: 1668

Re: Telnet ENC28J60

hi For all those who need a network to serial bridge for your microcontroller here is the Answer "esp-link" this free software for esp8266 makes it possible to establish Telnet to serial connection, send commands to the microcontroller via it's HTTP web interface, flash connected AVR, ATmega & ARM p...
by Alan_37
Tue Mar 12, 2019 3:02 pm
Forum: General Programming
Topic: Telnet ENC28J60
Replies: 3
Views: 1668

Re: Telnet ENC28J60

hi Benj, thanks for your quick reply. As I said I am just getting started what I want to accomplish is sending commands to my MCU via HTTP and telnet but before I start to build my flowchart I want to make sure that I can make the connection using the HTTP and telnet protocol so for now, I am experi...
by Alan_37
Tue Mar 12, 2019 1:54 pm
Forum: General Programming
Topic: Telnet ENC28J60
Replies: 3
Views: 1668

Telnet ENC28J60

Hi I am just getting started with this Module I would like to make a telnet connection it is possible using Arduino IDE but would like to make it with flowcode, I have experimented with the HTTP server example it almost works but the only problem is that the module closes the connection right after ...
by Alan_37
Mon Mar 11, 2019 4:12 pm
Forum: General Programming
Topic: ENC28J60
Replies: 7
Views: 2550

Re: ENC28J60

Hi LeighM

Just found it, it was the buffer size increased it from 255 to 500 and everything now works as it should :D
buffeer.png
(18.65 KiB) Downloaded 2181 times
You may also want to update the wiki example file with the one attached below.

Thanks very much.
by Alan_37
Mon Mar 11, 2019 2:52 pm
Forum: General Programming
Topic: ENC28J60
Replies: 7
Views: 2550

Re: ENC28J60

Hi LeighM

Yes, it worked just incremented +5 the data pointer that was it so there is no bug.

Just another weird thing I noticed the MCU stop responding if the 2 disabled macros are enabled
don't know why.
stop.png
(200.29 KiB) Downloaded 2184 times
Thanks for your help
by Alan_37
Mon Mar 11, 2019 12:13 pm
Forum: General Programming
Topic: ENC28J60
Replies: 7
Views: 2550

Re: ENC28J60 Bug

Hi LeighM

Thanks for the info , will try it and keep you posted.
by Alan_37
Mon Mar 11, 2019 11:40 am
Forum: General Programming
Topic: ENC28J60
Replies: 7
Views: 2550

Re: ENC28J60 Bug

hi LeighM Thanks for your reply, in the Wiki example the data pointer is being set in the GetTcpDataPointer component macro, datapontr.png I understand this can be set manually but it would require Wireshark to see the data. I don't know where the data pointer has to be set to get the page1 string o...
by Alan_37
Sat Mar 09, 2019 3:10 pm
Forum: General Programming
Topic: ENC28J60
Replies: 7
Views: 2550

Re: ENC28J60 Bug

Hi
Am I doing something wrong or is a component bug?

Although I use flowcode V7 , the new Flowcode V8.1 might have the same bug!
by Alan_37
Thu Mar 07, 2019 10:40 pm
Forum: General Programming
Topic: ENC28J60
Replies: 7
Views: 2550

ENC28J60

Hi I am playing around with the ENC28j60 I have flashed the example to an Atmega 328p from the wiki page I can Ping the module, view a web page but in the wiki example there are 3 pages I can only access one of them the problem is that Read TCP document request is not returning the “/page1” string, ...
by Alan_37
Mon Feb 25, 2019 5:02 pm
Forum: Feature requests
Topic: LC7981 GLCD
Replies: 1
Views: 1929

LC7981 GLCD

Hi
Have a lot of these GLCD's with the controller SANYO LC7981 240x128 Dots

is there a chance this will be supported in flowcode 7 ?

Thanks
by Alan_37
Tue Feb 20, 2018 9:35 pm
Forum: Bug reports
Topic: Flowcode 7.3
Replies: 7
Views: 2495

Re: Flowcode 7.3

hi Steve, thanks for your reply I will try running it in safe mode as you advise, but I don't think that is the problem because if I use an older flowcode.exe file everything work well again and as I mentioned with the new exe file everything works well until it is time to download the hex to the MC...
by Alan_37
Sat Feb 17, 2018 9:52 pm
Forum: Bug reports
Topic: ESP8266
Replies: 2
Views: 1391

Re: ESP8266

hi Benj

I have discontinued this part of the project because all HTML code is stored
on the microcontroller and have a lot of limitations + it's a bit slow to execute so
I am trying something else

my problem was 99.99% because of the different build version that I was using.

thanks .
by Alan_37
Sat Feb 17, 2018 9:43 pm
Forum: Bug reports
Topic: Flowcode 7.3
Replies: 7
Views: 2495

Re: Flowcode 7.3

A bit old but i don't think that is the problem.
pc.png
(8.72 KiB) Downloaded 2064 times
by Alan_37
Sat Jan 27, 2018 9:47 pm
Forum: Bug reports
Topic: Flowcode 7.3
Replies: 7
Views: 2495

Re: Flowcode 7.3

hi Benj

Just check the EXE file but the same thing it stops and has to close .
by Alan_37
Fri Jan 26, 2018 2:24 pm
Forum: Bug reports
Topic: ESP8266
Replies: 2
Views: 1391

ESP8266

Hi Just found these 2 bugs in the esp8266 module 1. GetFrimwareVertion returns the string "ALT+GMR", not the actual version. 2. CheckTCPServerIP will freeze the mcu and will not return any string . ( only when connected to an SSID in AP mode works OK ) I think these bugs are due to esp8266 firmware ...
by Alan_37
Fri Jan 26, 2018 2:04 pm
Forum: Bug reports
Topic: Flowcode 7.3
Replies: 7
Views: 2495

Re: Flowcode 7.3

Hi Benj

Thanks for your reply, No the chip does not program Flowcode compiles to hex ok then a window pops up
"Connect Your Arduino" after pressing ok Flowcode stops responding and has to close.

I will try the new EXE and let you know.

Thanks
by Alan_37
Wed Jan 24, 2018 11:23 pm
Forum: Bug reports
Topic: Flowcode 7.3
Replies: 7
Views: 2495

Flowcode 7.3

Hi I have just updated to the latest flowcode 7.3 Now have a problem when I try to use AVRDUDE (USBASP) to burn the Atmega 2560 as usual flowcode stops responding and has to close after doing some investigation i found that the problem is in the new FlowcodeV7.exe I can confirm this because when I r...
by Alan_37
Fri Nov 24, 2017 12:21 am
Forum: AVR & Arduino
Topic: avrdude.exe has stopped working in FlowCode V7
Replies: 16
Views: 6475

Re: avrdude.exe has stopped working in FlowCode V7

Hello, For all those that want to use the $5 AVRDUDE or ( USBASP ) here is what i have done some time ago to get it work with Flowcode 7 . There are 3 files and some configuration involved in this which are avra.bat , avrc_asp.bat and the .fcdx file of the chip you need to flash with AVRDUDE , the m...
by Alan_37
Thu Apr 13, 2017 1:30 pm
Forum: 32-Bit ARM
Topic: ARM STM32 Update
Replies: 37
Views: 25596

Re: ARM STM32 Update

Hi My STM32 Dev Boards are finally here :) Image 1.png And I now can start experimenting with the intent of porting my project from Arduino to the STM32F407ZG I know that the STM32 is still work in progress , and that I have already asked this question before but before starting I would really like ...
by Alan_37
Sat Apr 08, 2017 11:17 am
Forum: Feature requests
Topic: BME280 I2C/SPI Temperature Humidity & Pressure Sensor
Replies: 30
Views: 18881

Re: BME280 I2C/SPI Temperature Humidity & Pressure Sensor

Hi John , Good morning I think that 0xEC is referring to address 0x76 , and 0xEE to Address 0x77 , let me explain in order to communicate with a device via i2c we need 3 addresses , the main address of the device for example 0x76 , when this address (1110110) is sent on the i2c bus the device with t...