Search found 149 matches

by Lagoda
Fri Oct 18, 2019 10:24 am
Forum: Flowcode V8
Topic: 18F27K40 Silicon issue.
Replies: 7
Views: 98

Re: 18F27K40 Silicon issue.

Hi Martin,

Does your project file compiled into C language contain the TBLRD instruction?

I tested this silicone issue with a very simple program, because was a problem with string operations.
Unfortunately, I have little experience with this silicone bug.

Regards,

Lagoda
by Lagoda
Thu Oct 17, 2019 10:15 pm
Forum: Flowcode V8
Topic: 18F27K40 Silicon issue.
Replies: 7
Views: 98

Re: 18F27K40 Silicon issue.

Hi Martin, Could you try this C code at the start of the program asm ("BSF NVMCON1, 7"); Source: https://www.matrixtsl.com/mmforums/viewtopic.php?f=76&t=20479 Have you tried it before? I used this solution for PIC18F67K40 MCU and it worked for me. Best Regards, Lagoda
by Lagoda
Fri Oct 04, 2019 6:25 pm
Forum: Bug Reports
Topic: PIC18F67K40 UART "SendString" problem (SOLVED)
Replies: 7
Views: 311

Re: PIC18F67K40 UART "SendString" problem (SOLVED)

Hi Stefan, Maybe you didn't mean MPLAB X? :) Sorry! With which software did you do the test? Looks very good. If you were thinking of a picture attached to the first post, it is the user interface of a TechTools DV518 Logic Analyzer. https://www.tech-tools.com/DV518-logic-analyzer.htm Regards, Lagoda
by Lagoda
Fri Oct 04, 2019 9:39 am
Forum: Bug Reports
Topic: PIC18F67K40 UART "SendString" problem (SOLVED)
Replies: 7
Views: 311

Re: PIC18F67K40 UART "SendString" problem (SOLVED)

Hi Stefan, For register level debugging, I use MPLAB X IDE (v5.20) with PICKIT4 debugger. I use v1.45 from XC8 compiler because Flowcode8 also uses this by default. There is also a Clicker 2 with a PIC32MZ on 200Mhz. I also like this board. It would be nice if the card had an external power connecto...
by Lagoda
Thu Oct 03, 2019 7:29 pm
Forum: Bug Reports
Topic: PIC18F67K40 UART "SendString" problem (SOLVED)
Replies: 7
Views: 311

Re: PIC18F67K40 UART "SendString" problem

Hi Ben, I found the cause of the error: The MCU what I use comes from Device Revision Id = 0 series. If the Device Revision Id = 3, the String operations will be executed correctly. The solution is in this topic: https://www.matrixtsl.com/mmforums/viewtopic.php?f=76&t=20479 By inserting Code C, ...
by Lagoda
Wed Oct 02, 2019 10:20 am
Forum: Bug Reports
Topic: PIC18F67K40 UART "SendString" problem (SOLVED)
Replies: 7
Views: 311

Re: PIC18F67K40 UART "SendString" problem

Hi Ben, I did another test. I wanted to copy a string type constant into a string type variable. Then I convert the string variable to a byte vector and send the elements of the byte vector to the UART buffer. This works great in the simulator, but don't work in the target circuit. During debugging,...
by Lagoda
Mon Sep 30, 2019 10:14 am
Forum: Bug Reports
Topic: PIC18F67K40 UART "SendString" problem (SOLVED)
Replies: 7
Views: 311

Re: PIC18F67K40 UART "SendString" problem

Hello Ben, I tried what you wrote. On 18F devices the extended CPU config setting can cause problems with strings, however looking at your config settings it looks like this is already set to disabled. Maybe try enabling the setting just in case it's been inverted? After enabling, I get an error mes...
by Lagoda
Thu Sep 26, 2019 10:16 pm
Forum: Bug Reports
Topic: PIC18F67K40 UART "SendString" problem (SOLVED)
Replies: 7
Views: 311

PIC18F67K40 UART "SendString" problem (SOLVED)

Hi Ben, I found a bug while testing the UART Component Macro on CLICKER 2 board. The "SendString" function does not work, it is not executed. The "SendNumber" and "SendChar" are working perfectly. PIC18F67K40_UART_Test_OUTPUT.png 3 milliseconds pause between UART TX bur...
by Lagoda
Wed Aug 28, 2019 10:25 am
Forum: Flowcode V8
Topic: 18F67K40 UART Problem
Replies: 46
Views: 1862

Re: 18F67K40 UART Problem

Hi, In my experience, the compiler can be used immediately after installation. See the WIKI for help selecting and configuring the programmer. https://www.matrixtsl.com/wiki/index.php?title=Supporting_Third_Party_Programmlsing_Tools I took a closer look at the PIC24FJGA406 MCU. It has a very rich se...
by Lagoda
Tue Aug 27, 2019 1:44 pm
Forum: Flowcode V8
Topic: 18F67K40 UART Problem
Replies: 46
Views: 1862

Re: 18F67K40 UART Problem

Hi Seokgi,

I'm using the PIC24FJ256GA106 and PIC24FJ256GA110 MCUs.
UART, SPI, ADC, PWM peripherals work perfectly in these devices. (I only use these peripherals at the moment.)
I use INT0, UART RX and Timers interrupts. They are working perfectly too.

That's a good choice, I think.

Lagoda
by Lagoda
Fri Aug 23, 2019 9:41 pm
Forum: Flowcode V8
Topic: FC8 GLCD problem
Replies: 2
Views: 193

Re: FC8 GLCD problem

Hi Sisco1,


In the past I used "ILI9341 SPI" and "SSD1305 Buffered" components.
Both worked properly.

Best Regards,

Lagoda
by Lagoda
Fri Aug 23, 2019 2:45 pm
Forum: Flowcode V8
Topic: Error in the SPI interface
Replies: 7
Views: 300

Re: Error in the SPI interface

Hi Leigh,

I'm sorry! :)
I wanted to ask from Pascal_2016 but forgot to type the username in the address bar.

Best Regards,

Lagoda
by Lagoda
Fri Aug 23, 2019 1:58 pm
Forum: Flowcode V8
Topic: Error in the SPI interface
Replies: 7
Views: 300

Re: Error in the SPI interface

Hi,

The Clk output of the SPI module and the LED are both connected to the B5 port.
Is that what you wanted?

Lagoda
by Lagoda
Thu Aug 22, 2019 5:53 pm
Forum: Flowcode V8
Topic: 18F67K40 UART Problem
Replies: 46
Views: 1862

Re: 18F67K40 UART Problem

Hi Seokgi, I set the transmission speed to 115200 baud. I think have you seen that. I'm sorry it doesn't work. I would like to use this MCU in the future. Just an idea (This is what I do when any peripheral is not working properly.): Create a very simple program in Flowcode that handles the peripher...
by Lagoda
Wed Aug 21, 2019 9:55 am
Forum: Flowcode V8
Topic: 18F67K40 UART Problem
Replies: 46
Views: 1862

Re: 18F67K40 UART Problem

Try this test program. Port C6 is the output of UART TX.

Is it working?

Lagoda
by Lagoda
Thu Aug 15, 2019 3:50 pm
Forum: Bug Reports
Topic: Flowcode v8.2.1.13 freezes
Replies: 3
Views: 331

Re: Flowcode v8.2.1.13 freezes

Hi Ben,

I did what you described and Flowcode8 works again.

Thanks for the help. :D

Best Regards,

Lagoda
by Lagoda
Tue Aug 13, 2019 7:15 pm
Forum: Bug Reports
Topic: Flowcode v8.2.1.13 freezes
Replies: 3
Views: 331

Flowcode v8.2.1.13 freezes

Hi Ben, I'm glad because Flowcode v8.2.1.13 came out and I was curious what changed in it. I couldn't find a patch file, so I uninstalled Flowcode v8.2.0.13 (I just uninstalled the program, but I left the tool chain unchanged) and installed the new version. I started, selected the PIC32MZ2048EFM144 ...
by Lagoda
Tue Aug 06, 2019 10:19 pm
Forum: Flowcode V8
Topic: Pic32MZ2048EFG100 UART is 4 times to slow
Replies: 10
Views: 734

Re: Pic32MZ2048EFG100 UART is 4 times to slow

Hi Stefan and Ben,

I have the same problem with the PIC32MZ EFM.
My target board is Microchip Curiosity.
I attached a little test program what I used for the check.

Best Regards,

Lagoda
by Lagoda
Tue Aug 06, 2019 3:12 pm
Forum: Flowcode V8
Topic: 18F67K40 UART Problem
Replies: 46
Views: 1862

Re: 18F67K40 UART Problem

Have you ever tried in your test enviroment to use only one UART component without LED components?

Lagoda
by Lagoda
Tue Aug 06, 2019 2:33 pm
Forum: Bug Reports
Topic: PIC32 UART port Remap Pins setup
Replies: 2
Views: 288

Re: PIC32 UART port Remap Pins setup

Hi Ben, Thanks for the quick response. You're right, the assignment of UART Channels and port banks is OK. I thought there was a bug in the Flowcode8 because if I change the Channel of UART, the port information in the Connection table will not be updated. If then click on the RX Remap Pin or TX Rem...
by Lagoda
Fri Aug 02, 2019 7:13 am
Forum: Flowcode V8
Topic: 18F67K40 UART Problem
Replies: 46
Views: 1862

Re: 18F67K40 UART Problem

I mean, try to disable the Low Voltage Programming mode. Sorry.
by Lagoda
Thu Aug 01, 2019 6:30 pm
Forum: Bug Reports
Topic: PIC32 UART port Remap Pins setup
Replies: 2
Views: 288

PIC32 UART port Remap Pins setup

Hi Ben, I have a problem with the PIC32MZ2048EFM100 MCU, UART component Remap Pin settings. Bug Description: First I create a new project and only add one UART (RS232) component to the 2D dashboard. Then I try to configure TX and RX Remap Pins, but the "Properties" window shows the wrong p...
by Lagoda
Thu Aug 01, 2019 2:51 pm
Forum: Flowcode V8
Topic: 18F67K40 UART Problem
Replies: 46
Views: 1862

Re: 18F67K40 UART Problem

OK.
Then you are sure that your circuit is not faulty.

Have you ever tried to set the HighVoltage programming mode in Configuration Settings? (This is now set to LV in your test program.)
What type of programming tool do you use?

Lagoda
by Lagoda
Tue Jul 30, 2019 10:34 pm
Forum: Flowcode V8
Topic: 18F67K40 UART Problem
Replies: 46
Views: 1862

Re: 18F67K40 UART Problem

Hi, According to the MPLAB Code Configurator: " External clock frequency is greater than recommended value(20MHz) " You may have to try with a lower frequency. But this is just an idea. Unfortunately the MCLR pin can only be input port. MCLR Disabled.png Lagoda Using MPLABX, I created a te...
by Lagoda
Tue Jul 30, 2019 1:05 pm
Forum: Flowcode V8
Topic: 18F67K40 UART Problem
Replies: 46
Views: 1862

Re: 18F67K40 UART Problem

Hi, Seokgi

The clock signal of target circuit is it working ?
I think, if the clock source is an HS quartz crystal connected to the OSC1 and OSC2 pins, then the OSC2 output must be enabled in the Project Option / Configure window.

Best Regards,

Lagoda